Roon remote not finding core on QNAP [Resolved]

@support This problem has surfaced for me. My Firewall allows Roon access. It seems MS have done an update for the wannacrypt virus and this has prevented Roon Remote from connecting with the core.

I have latest Roon version; 64bit W10; Music on Qnap NAS.

I tried uninstalling and re-installing and the re-installation can’t find the remote library. My NAS does show an error for Roon Server not shutting down correctly; NAS did once shut down abruptly rather than closing down. It has stopped doing that now, after a software update.

I can play music via Manic Moose on the Bryston BDP1 and on JRiver. This seems to be a Roon problem. And Roon is by far the most expensive software.

Maybe I need to be able to roll back Roon to 1.2

Hi @Peter_D_Castro ---- Thank you for the report and sharing your feedback with us. Both are appreciated!

To help my understanding of this issue can you verify a few things for me, you’ve mentioned the following:

“I tried uninstalling and re-installing and the re-installation can’t find the remote library.”

  • My assumption is that you tried to reinstall Roon Server, is this correct?

" My Firewall allows Roon access. It seems MS have done an update for the wannacrypt virus and this has prevented Roon Remote from connecting with the core."

  • Have you checked that the security exceptions are still in place for “Roon” and “RAATServer” since this update went live?

Lastly, in regard to your request about rolling back to a previous version. This is not something we usually suggest, from a procedural stand point that is. We have seen automated updates yield some weird results and my feeling is, that is what’s going on here based on the feedback you’ve provided. I am sure we can get to the bottom of it :microscope:


Re-installation cannot be completed because it can’t find any remote libraries.

Security exceptions are still in place.

Roon & Raat Server have been allowed access on the Firewall control.

Hi @Peter_D_Castro — Thank you for the follow up and verifying that information for me, the insight is very appreciated.

Moving forward, I would like to gather some more data from you as well as have you run a very simple test. Please see below.

Further data gathering…

  1. Please confirm which model QNAP you are working with.

  2. Can you verify if there are any active firewalls on the NAS?

  3. Can you please follow the directions found here and upload us a set of logs.

I would like to propose a simple test in order to confirm that everything is functioning correctly with the NAS + Roon. Can you please perform the following:

  1. Before anything, please make a backup of your current database.

  2. Once your backup has been created and the application is no longer running … I’d like you to please (temporarily of course) try hosting your Roon core on another device and try to add your watch folder back in from the NAS. Does it load music and function as expected?


I use the Roon recommended NAS system QNAP TVS471 with SSD in Bay 1.

I can set up and use Roon from my remote Laptop if I use that as the Core. But it seems the Core can’t be set up on the NAS. I tried to set up Roon core from another laptop and it could not find the Remote Library to set up the core either. It seems there is a problem setting up the Roon Core on the QNAP NAS. There was an upgrade on QNAP recently and that may be causing problems.

I have transferred the Roon Core back to the laptop, from which I used to have skipping and crashing problems. I will operate it that way until the QNAP NAS can operate as a Core again.

Hello Peter,
Which version of QTS are you using?
I was running without any issues.
Currently I am using and I am running into issues with connectivity from my remote to the core.
There is a newer version of QTS ( , but I did not have the timeframe to schedule the update on my device

My QTS is the latest version. I like to keep my software up to date. Also, I was hoping it would fix the problem.

I am also having the same problem. TVS 471 with latest firmware.

I backed up to firmware and everything works perfectly.

I rolled back to firmware and my install still can’t find the Remote Library to install the Core.

Once I backed up to I had to turnoff the RoonServer App and then turn it back on before my remote located the core. I have played it several times today without issue.

You mean remove the Roon app from QNAP? I can’t see a feature to turn it off.

Sorry, I missed the option to “Stop”. I removed it.

Can’t find Remote Library with rolled back version and Roon Server app removed.

I tried installing the Roon core directly in the NAS. That does not work because the Manage from this computer option selects the laptop, not the NAS. When the NAS holds the Core, the NAS name is shown in the settings as being the core.

I believe this is a link of the log requested.

Hi @Peter_D_Castro ---- I tried accessing the link and unfortunately it is not loading :sweat: Can you resupply via a dropbox download link? If you are not a dropbox user, no worries, I can offer an alternative upload method upon request.

Lastly, can you please confirm if exactly which model of the QNAP TVS471 (TVS-471-i3-4G or TVS-471-PT-4G) you are currently running and verify if you are able to successfully ping the the device from another device, say the laptop you are currently running as your core.


It is TVS-471-i3-4G .

I don’t use dropbox, I formatted the SSD on which the Roon Server was, hoping that would flush out any bugs preventing the installation. It did not solve the problem and now there is no log.

I am able to access, locate, ping QNAP from every device on the network, but Roon can’t find it.

Hi @Peter_D_Castro,
Can you tell what version of the qpkg is installed (you can see it in the QNAP AppCenter)? (is it 2017-02-02?)
Can you also tell the IP address of your QNAP and your Laptop?

I’m no tech head, so a lot of this goes over my head. That’s why I subscribed to Roon.

I don’t understand qpkg. I can’t see anything like at in the AppCenter.

QNAP IP address is (DHCP).

Where do I find the laptop address? If it is under wifi it is DHCP

A qpkg is the installation file to install an app for QNAP devices. You have downloaded it to install RoonServer on the QNAP. The installed version is displayed in the QNAP AppCenter next to the RoonServer App name. The latest one is 2017-02-02. (It could also be that it displays 1.0, 1.01 or 1.02 instead of a date).

This is how it should look. In my case the version is 2017-05-01. (But as I said before, it could also be something like 1.0x):

My Roon Server app was removed. I thought a new one would be installed with the new installation.