Roon remote not finding core [Solved, Windows update reverting default firewall]

I’ve seen this post from several others & tried various probable solutions, but no avail. Here’s what I have:

Latest Roon core software on Windows 7 desktop, Antivirus disabled
Latest Roon remote on my Android tablet

This is what I’ve tried:
Tried to connect with my Android phone, with same results
Rebooting the core pc
Rebooting the remote tablet
Entering the core pc name
Entering the core pc IP
Powering down everything (modem and router included)

Nothing was recently changed, Windows firewall is at bay, I’m out of ideas, frustrated and need help, please.

1 Like

I’ve used the Fing app to make sure all IP addresses are
I’ve made sure my core roon is set to accept connections from remotes

Keeps claiming connecting, then connection failed, then repeats

1 Like

I am trialling roon currently. The connection between roon remote on android and core is flaky. I got the the ports opened in my router and firewall. It keeps dropping quite frequently.

Have the same problem - works fine from Core PC - but remotes are not connecting on either iPhone 6+ or latest ipad

I moved this to the “Support” category, and I’m dropping a flag (as the kids say) @support

If you for any reason missed the free W10 upgrade:

This is exactly same upgrade as offered before for free. I’ve tested and it works.

Great… I’ve been wanting to do the update to W10. However, back on topic: is this to imply that people are finding W10 works with Roon & HQPlayer with less glitches than W7?

I am running it on Win 10 pro. I don’t think it is something related to Win 7 only. @support is there any update on this.

Chris - I have using Windows 10 and Roon / Roon remotes with absolutely no issues - this only resulted a few weeks ago - I am wondering whether it has to do with the new Roon software upgrade - as the timing of the Roon upgrade resulted in this problem - very irritating indeed! Has anyone spoken to support here?

I haven’t heard from @support yet. I still have the same issue.

@Chris_Schiller and @Audiofool ----- Thank you for the feedback and my apologies for the wait here. To help me evaluate this behavior you both are experiencing I would like to gather the following information from you both. Please see below.

  1. A brief but accurate description of your setups as seen here.

  2. Please describe your network configurations/topology as well as providing insight into any networking hardware you may be implementing. I would like to have a complete understanding of how your devices are communicating and what tools are being used to make those connections possible.

  3. Since noticing this behavior have you tried reinstalling the remote application? If so was the experience any different, even if it was temporary?


  1. Roon Version 1.3, build 208, 64-bit; Windows 7 Home Premium 64-bit, Service Pack 1; desktop/tower PC: i7 2600 cpu w/ 4 cores & 8 threads at 3.4GHz, 3.8 turbo, Nvidia 1060 GTX gpu, OS on one Samsung Pro SSD, ~2200 music files (mostly flac) on another Samsung Pro SSD, internally mounted, connected to the mobo via SATA, well-ventillated w/ Noctua fans & quality fan control a la Asus TUF Sabertooth UEFI, latest ed.

  2. 15MBps cable ISP, Motorola Surfboard SB6141 modem, TPLink router, hardwired/Ethernet on all connections throughout the data transfer, Roon Core mounted on desktop/tower PC, Roon Remote on Samsung Android tablet for control, ISP>modem>router>desktop Core>HQPlayer as local host>microRendu>iDSD BL DAC at 512DSD>pre>amps>speakers>my ears>bliss (when working :confused: )

  3. I’ve reinstalled the remote app on my tablet twice, b/c essentially it seems that’s where the problem is. I can play direct from HQPlayer (w/o Roon), I can play with Roon & HQPlayer as local host, but I can no longer remote control Roon from my tablet.

Hope this is all the info you’ll need. I know troubleshooting remotely can be a challenge…

Hi @Chris_Schiller ----- Thank you for following up with me and taking the time to answer my questions. Both are appreciated!

Moving forward, may I ask you to please provide the following:

  1. A screenshot of the inbound firewall exceptions set into place for Roon and RAATServer.

  2. Can you please verify the type of connection you have to your network. In Windows 7, you have two profiles: Home or Work and Public (example below - from: Online Tech Tips)

  1. I understand based on your initial report you had also tested with an Android phone to see if you could yield a change in behavior. By chance in your troubleshooting of this issue, have you tested with computer another computer acting as a remote?


Roon Version 1.3 build 209 (Stable 64 bit), Windows 10 pro Version 1607(OS build 14393.693), Desktop QuadCore Intel Core i7-860, 2933 MHz, 8 GB RAM.

Modem (4 port router 1000 Mbps)-> Cat 6 cable -> Desktop
Samsung S5 wireless (Android version 6.0.1)
Asus TF300T tablet wireless. (Android version 6.0.1)

When I first encountered this issue I was on build 208. With build 209 it has improved. I tested it yesterday with my tablet. the initial connection was quick. I am not getting the same behaviour I got with build 208.

What I noticed is that when the tablet display goes to sleep roon disconnects even though the wifi is always on during sleep. When it reconnects back to roon, the playback cuts out for about 5 seconds which is super annoying :grimacing:.

  1. Screenshot of inbount firewall exceptions may gain us some ground, as I noticed some blocking of Roon:

  2. I think I have the network connection setup as Public, to minimize related concerns. Here’s a snapshot… note: when running Roon & HQPlayer, I turn off the VPN:

  3. No – in the process of troubleshooting, I hadn’t/haven’t tested with another computer, only the Android devices (tablet and smart phone).

Chris I played with the Windows firewall settings to allow Roon and remote devices - it now works. It appears on the last Windows 10 update the firewall settings were set to default, in layman terms, the remote devices on the private network were not allowed to talk to each other. The other option is too simply remove firewall for your private network. Anyways - it now works

I’ve gone through many attempts to resolve a separate issue: updating to Windows 10. I finally figured it out, so this may help too. Just a quick update… will update my status after this update when I have some time… may not happen this weekend. THANKS TO ALL THAT HAVE CONTRIBUTED… I’m much obliged… thank you.

1 Like

A quick update & ending of my concern:

I updated my OS to Windows 10 and changed the firewall inbound settings to allow all Roon connections, and low & behold… (drumroll please…) viola! …full control with the Roon Remote tablet again.

Thanks again all for your contributions… I really appreciate not only helping me through, but the knowledge I’ve gained in the process, and hopefully this can help others in the future. Cheers to happy listening!

1 Like

Well done for working though the issue. Now relax and enjoy the music.

1 Like