Roon remote searches for core until I restart my core

Core Machine (Operating system/System info/Roon build number)

same core I’ve had for years. running 1.6 416
connected via ethernet to my router

Google Pixel 3 running roon 1.6 416

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

allo streamer connected by ethernet to wifi extender, roon bridge 1.0 164

Description Of Issue

Roon Remote can’t find core unless I reboot roon… every time I leave my house and return.

Hi @Marshall_Hance,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Have there been any changes to your networking setup around the time this issue started?

Are you able to connect from other remotes during this time, or are all remotes unable to reconnect?

I have no idea what this router is… Sagemcom fast 5280 or RAC2V1S?

It’s branded by my IP, Spectrum.

No changes in the past 5 months.
I only have one remote.

Hi @Marshall_Hance,

Is the remote app running in the background when you leave the house? If you force close the app and restart it without rebooting the remote or Core does that allow you to connect?

I force closed the app and it does not allow me to connect after.

Thanks for confirming this, @Marshall_Hance.

Do you have any other iOS, Android, Windows, or Mac device that you could use as a test? This would help us understand if this is limited to this specific remote or if the Core is having trouble communicating with all devices.

My old phone will also not connect to the core, not on the first try but will after a restart of the core.
It seems to follow that the core ceases to be discover-able after some period of time.

toggling “accept connections from remotes” in the setings/setup immediately allows the remotes to connect… obviously this is not the fix I’m looking for, but might speak to the underlying problem.

Just a heads up, I had a very similar issue that I solved by changing the WiFi extender. If I recall it only affected my android remote and not my apple devices. I swapped from devolo to ubiquity and this solved the issue for me.
Not suggesting you swap as it would be ideal to understand and fix the issue!
Could you try to remove the extender temporarily to see if it helps you?

the extender goes only from the router to the endpoint. turning it off did not remedy.

Hi @Marshall_Hance,

So just to verify here, the Core gets into a state where no remotes can connect. After a reboot or toggling “Accept connections from remotes” off and back on, everything will work again for a while, correct?

Moving forward, I’d like to enable some diagnostics on your account so our technical team can take a closer look. First, I’d like to get some timestamps for when this occurs so we can take a look specifically at this time. The next time this occurs please do the following:

  • Make a note of the time your remote is unable to connect
  • Toggle the remote setting off and on and make a note of the time you do this
  • Make a note of the time your remote connects

Respond here with the three times above and we will take a look.

all three events just happened at 12:15pm today 8-July-19

Thanks @Marshall_Hance,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

I’ll be sure to pass the diagnostics report along to the team for analysis once they’ve come in.

thank you. did the same three events today at 8:40am 9-July-19, if that helps.

@dylan any ideas? this has been pretty annoying since my core is nowhere near my stereo.

Hi @Marshall_Hance,

I just heard back from the team regarding the analysis of the diagnostics report. They’re seeing networking errors that are likely stemming from either the Core machine’s connection to the network or the network itself dropping. In an effort to better understand where this is stemming from, we’d like to propose a test.

If you have a different machine available that you can use temporarily as your Roon Core, and you connect it to the network in the exact same way as the current Core, is there any change in behavior? Do things work properly in this configuration?

recent bios update solved the problem… which I think started with a bios update a few weeks ago. bug created and solved? thank you for looking into it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Unfortunately, the problem isn’t solved… the remote merely stays connectable for a little bit longer than before.