Roon remote stopped working

I’ve scoured the support base for a similar issue, but can’t seem to find anything. I am running the latest Roon 1.5 Core on a headless Mac Mini, with the music files stored on a Synology NAS. I mostly access Roon via my late 2011 MacBook Pro. Playback is via Ethernet into the Bridge II of a PS Audio DS Stream DAC. Everything works seamlessly. Until recently I was able to access Roon Core via the Roon Remote app on my iPhone 5S, and also from Roon Remote on Lenovo Thinkpad running Windows 10. Now, when I try to link to Roon via iOs or Windows 10, I get a ‘Waiting For Remote Core’ error message. Following the troubleshooting guide indicates that there should be an ‘Accept connections from remotes’ setting under the Setup tab. But I am unable to find this setting. What am I doing wrong? Any assistance would be much appreciated! @support

Hey @Deon_Schoeman1 — Thank you for the report!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

May I also ask that you please confirm the following:

  • Since noticing this behavior, have you tried power cycling your Core machine, remote devices, and networking hardware?
  • Are you able to see the Mac Mini over the network?


Hi Dylan

I have rebooted all devices - MacBook, MacMini and Synology NAS, as well as the iPhone 5S and Lenovo Thinkpad I am trying to use as remote devices (and which worked perfectly before). I can see the MacMini over the network from my MacBook Pro. System description as follows:
System description:

Roon V1.5, build 323 64-bit
Early 2011 13-inch MacBook Pro, 2,7 GHz, Intel Core i7, 8GB RAM, 1TB SSD
MacOS High Sierra V 10.13.4

Roon Core running on Headless Late 2012 Mac Mini, 2.5 GHz, Intel Core i5, 10 GB RAMMacOS MacOS High Sierra V 10.13.4
Music library stored on Synology 213+ NAS
Ethernet interface throughout

Network consists of TP Link RE580D repeater providing Internet connectivity to TP Link Gigabyte switch. All ancillaries hard-wired to switch via Ethernet.

As mentioned it all works - just can’t access Roon via remote anymore. Many thanks.

are all the IP addresses on the same network address segment? is you wifi using the same segment? are you on the correct wifi SSID?

The iPhone 5S is on the same Wi-Fi SSID, yes. And all are using the same IP address segment.

Going back to part of my original query: where do I find the ‘Accept connections from remotes’ setting - it seems be absent from my settings tab? Regards

Thanks for the additional details, @Deon_Schoeman1!

where do I find the ‘Accept connections from remotes’ setting

This setting is not visible if you are using RoonServer. With RoonServer, the only way to access Roon is by using remotes, so this option is always enabled.

The TP link switch you mentioned above - Is that a managed switch?

Just to confirm, you cannot connect via the MacBook either, correct? Are any of the remote devices connected via Ethernet, or are they all WiFi? If WiFi, try a wired connection and see if that helps.

As mentioned above, can you confirm that you are able to see the Mac Mini over the network?


Hi Dylan - thanks for the feedback. The good news is I’ve been able to sort out the problem. When I got the error message asking me if I wanted to connect to a different core, I thought it was because my iPhone couldn’t see the core. Out of desperation, I ticked the yes option, and the iPhone then listed the MacMini Core. Once I confirmed that this was the core I wanted to connect to, all was back to normal. The same goes for Roon Remote on my Lenovo Thinkpad. All is good - appreciate your help.

1 Like

For the benefit of other users, I get this same error when I am running a VPN on either my Roon Server or on my remote device. Since the VPN changes the IP address, I am not sure there is any fix to that.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.