Roon ROCK and rooDIAL (volume knob)

I ran roon on my Core i3 QNAP NAS with extensions. Worked smooth. I then decided to get a dedicated setup using ROCK.

I now run ROON ROCK on a NUC natively, without extensions (by design). I read “If you want a two device setup which also runs extensions, then you need to either be able to run the extension manager on the Core or on the endpoint.”

If I want to continue to use the StreamDeck Plugin or even the rooEXTEND plugin from for using a physical volume knob, how can I achieve that?

Is there an option to use a docker image (on my QNAP NAS) that is recognized as an “extension” so I could run my other extensions?

Run extension manager on the Nas in docker and run rooextnd on a pi they can be active at same time. I do believe the dev of rooextend was looking at adding extension manager but not sure how long that would be or how well it would work as some of the extension in ext manager require docker to be installed.

Mmh…I already have a Raspi4 for Ropieee with HAT Hifiberry. Could I somehow use this Raspi for rooExtend?

I dont’ feel like running my NAS and the NUC ROCK and a Pi4 for Ropiie and another Pi4 for rooExtend.

(I should run all on my QNAP in as apps or as docker images…if I knew better how…)

He has added an endpoint I believe. But you will need to check not sure what it supports.

You can: a Pi can running the rooExtend software can also serve as a Roon Bridge endpoint (replacing Ropieee). You’ll need to config the hat manually by editing config.txt in /boot after flashing the card with the rooExtend software.

In rooExtend – The easy start with Roon Extensions it says that rooExtend doesn’t support HAT so my Hifiberry HAT wouldn’t work anymore. I would need it the other way round: add rooExtend to roPieee. Or virtualize rooExtend as the other Pi (roPieee) needs a physical connection to my amp.

No support for HATs yet in rooExtend, only USB audio
Sorry :cold_sweat: