Roon ROCK reliability

sorry, I misunderstood your steps… step #1 was the restart of roonserver only, and although it found other devices, it did not find the dCS Bridge.

the SMB issue is already being looked at by tech team. Can you tell me what SMB server you are using? is it windows/mac/nas/etc… ? what model/versions?

@support will have to look at logs for the dCS thing, unless they already know something about that unit.

1 Like

Thanks. To summarize there are 3 issues.

  1. SMB Server loss after any restart of the RoonServer
  • Support is looking at this I believe.
  • I am using a standard Windows Server 2012
  • Everything is default in its setup
  • Its a basic SMB share
  • A have a dedicated user account called ROON that has permission tot he SMB folder
  1. Roon can’t do playback after n days of usage
  • That was the issue I reported here.
  • In this weeks repro I got there in 5 days with heavy playback
  1. Roon looses the dCS Network Bridge after a restart
  • After restarting RoonServer, the dCS Network can not be located
  • It requires you to power cycle the NBR to find it

I have the logs from today from the dCS NBR if you want them. I was going to send those and this thread to the folks at dCS as well to look at.

thx

Hi @Mohammed_Samji ---- It would be great if you can provide us with the logs from the dCS NBR. I will be contacting you with upload instructions via PM momentarily.

Many thanks!
-Eric

I had the same with my Rossini DAC.
Untill the update of dCS I let Roon usample/downsample to one sample rate.
The issue begins when the ROON/dCS combi changes from high to low sampler rates.
Not always…

Haven’t seen that with mine. It seems to handle sample rate changes ok. I also upsample everything except DSD using Roon.

Hi @Mohammed_Samji

Have you ever gotten into this state while Roon is actively playing back to the Network Bridge? In other words, playback just stops either mid track or at the transition to a new track then the queue starts being eaten.

Before rebooting ROCK are you able to play to any of your Sonos endpoints or do you see the same behavior with them?

If it’s only the bridge have you tried power-cycling the bridge before rebooting ROCK?

There are some known issues with the firmware on the Bridge as it relates to Roon and they’re being worked by dCS. I’m trying to figure out if your issue is a manifestation of one of those known bugs or something new.

I’ve used the Bridge in several situations with a similar complement of hardware (including Sonos) and haven’t run into an issue where the Bridge would get completely lost like that. This has happened with Sonos playback and a restart of the core was required (although in those cases I just rebooted ROCK), but the bridge has usually been pretty reliable in terms of self-recovery.

Yesterday, when I hit the original issue of playback not working, it impacted all my Roon endpoints. Both Sonos and NBR.

Everything is re-started and working, so i’m keeping an eye. The next time it happens, I’ll try re-starting the NBR first.

This behavior sounds like a known issue that is fixed in RAAT SDK 1.1.21 back in July. It was not a very common failure–most common for people with more than one core active on the network. We’ve only had maybe 2-3 reports of it in the wild across the whole ecosystem. It came up in QA at one of our partners where they have many cores running, and that gave us the clue to figure out how to reproduce/fix.

I believe that the bridge is still on an older version (maybe 1.1.18). I think this will be fixed once it is up to date.

I have the latest public firmware for the bridge, but it looks like dCS has a newer version.

I’ve requested the updated firmware from dCS and see if that prevents this.

I’ll respond here when I hit it again.

In the meantime, any idea of why SMB shares don’t reconnect after reboot?

There seems to be a bug here… but we cant figure it out from your logs.

Can you tell us:

  1. are you typing username “samji\roon” + a blank workgroup in some cases and username “roon” + “samji” workgroup in other cases?
  2. do one or both work?
  3. what is the username and domain/workgroup for your smb server?

It’d be nice to have you do the follow:

  1. remove all your shares from Roon, including the backup share
  2. reboot ROCK
  3. then note the date/time, and configure 1 share only for storage
  4. note exactly waht you typed into the setup fields
  5. reboot.
  6. if it doesnt come back up, i need the logs. they should have what i need (along with what you typed and your smb info).

A post was split to a new topic: Content being pulled from NAS struggling to play

Thanks for digging in.

Here are the details:

The server name is -> MSamji-WS
The Active Directory is -> Samji
The User is -> Roon

In Roon I enter the SMB File Share Name as:
\MSamji-WS\Music
or:
smb://Msamji/Music

Both work and have had the same result.

For the User Name I have tried:
Roon
Samji\Roon

But only “Roon” seems to successfully work with having the Share connected.

I also tried using “Roon” as the user name, and put “Samji” in the Workgroup name since it is the name of the active directory, but that didn’t allow the Share to connect.

Tonight when I get home, I’ll delete both Music Shares & the Backup share and re-add all of them. I’ll send you a timestamp when I do that for you.

1 Like

so with Roon as the username and blank workgroup, it works fine? but on reboot it does not?

I ask because your logs are full of other cases, like Samji in the workgroup name and samji\roon in the username.

You’ve been trying so many things, it’s hard for us to tell what is not working and what is, and when it breaks.

Here is what works:

Network Share Name -> \msamji-ws\Music or smb://msamji-ws/music
User Name -> Roon
Workgroup -> BLANK


Other combo’s where I try to integrate the AD name “Samji” cause to fail. Specially either

  • Changing the user name to Samji\Roon (FAILS)
  • OR Putting Samji in the Workgroup name (FAILS)

And this breaks after reboot? or keeps working?

Let me ask a dumb question… :blush: Why are you doing things that don’t work if there is a thing that does work? Is something defective about the other solution or was it not the obvious first choice? I’m clearly missing something…

My goal is simple. Connect to a SMB Share and also reliably reconnect to the SMB share when Roon Server restarts.

Since it fails every time I restart Roon, I was trying other combos that included the Active Directory name to see if that helped solve the Roon reconnect issue.

But adding the AD name had no impact and caused it to fail to connect even when you do the intial connection.

Basically I was experimenting with all possible combos to see what works.

Sorry I missed your first question. Yes the combo above that I indicated works, fails to reconnect after a restart.

did you remove all and note the time when you added just one and rebooted? id like to ask your rock to send us logs.

ok, I think this fixed it.

Here is the steps from tonight

  1. Delete all SMB Shares
  2. Restart ROCK
  3. Add ONE SMB Share back. Confirm it connected and is indexing
  4. Restart ROCK

THIS TIME, it successfully reconnected after a RESTART. (YEAHHHHH!)

  1. Add SECOND SMB Share back. Confirm it connected
  2. Restart ROCK

Confirmed BOTH SMB Shares reconnected with no issues POST ROCK Restart.

So it looks like this is resolved. After you grab logs I’ll start a few more times to confirm it always re-connects.


If we confirm this is fixed, I think there are 2 bugs that should be considered

  1. If you mistype your SMB share settings, and then successful connect, any future re-start should use the correct settings and not use the first set of info entered. It looks like the initial incorrect creds are getting cached.

  2. If you type AD\UserName it should work to connect to an SMB share. Currently just “Username” works.

1 Like

My Roon box (a custom built PC now over 7 yrs old) lasts weeks between reboots - usually just done for Windows updates.

I DO have occasional situations where Roon just won’t play, seemingly stuck at 0:00… This is because I have (through my main Focal system) a DSP correction file rendered by the DSP Convolution feature, and I’m trying to play back a DSD file. Roon can’t (yet?) summon th could power to do this.

My two cents.