Roon ROCK reliability

In general ROON ROCK on a NUC is much more stable then my prior setup of Roon Core on a dedicated PC.

But I’d like to see my ROCK make it more then 7 days before requiring a re-start.

Here is the repro

  1. Roon ROCK - latest version
  2. Roon ROCK hard-wired to a switch
  3. Sonos endpoints - hard wired
  4. dCS Network Bridge - hard wired
  5. Andriod and iOS Roon Remotes (WiFI)

Typically after several days of use, I get into a funky state where things will not playback.

Specifically this week:

  1. I re-booted my NUC around Tuesday
  2. Since then I have been running ROON also continuously to listen over the holidays and to break in some speakers.
  3. We were rocking all day and then…


  1. I can pull up Roon Remote
  2. I can navigate my library
  3. When I click PLAY
  • The track pulls up and is STUCK at 0 seconds
  • It sits stuck there for about 30 seconds, gives up and goes to the next track in the queue
  • Then it pulls up the track, and once again is STUCK at 0 seconds

I’ve seen this a few times. EVERY time it happens, I simply re-boot the NUC and everything works.

FOR NOW, I’m leaving my NUC in this state so you can collect logs.

Let me know once you have logs from this evening, and then I’ll reboot and go back to listening to music :wink:

1 Like

I have seen similar issues, have not diagnosed it to needing a reboot of the ROCK, though. I thought my issue was network related. I will have to keep an eye out for this and pay more attention next time.

Oh, and adding @support so they get notified for you.

Everything is on a wired gigabit network.

One additional note:

I can start stop the dCS Network Bridge with no issues using the dCS app, but Roon is stuck.

As soon as I reboot, it always returns back to normal.

Support please let know once you have logs so I can restart my rock.


if you restart RoonServer on the ROCK using the webui, does it recover?

I’d like to undersatnd if this is ROCK or Roon issues…

Let me try:


I just restarted RoonServer at 6:45am PST.

  • after that I can playback on my other Roon endpoints now (to my Sonos)


  • The dCS Network Bridge no longer shows up as a Audio Zone after I restarted RoonServer.
  • My SMB Shares are no longer connected (see the other ticket I filed). I can fix the SMB shares by deleting them and re-adding them.


I am going to restart the ROCK now - 6:50am PST


Post a reboot of the ROCK. Same result

  • No SMB Shares (easy fix, re-connect AGAIN)
  • I see SONOS
  • no dCS


the dCS is working outside of ROON
I can connect to the dCS web page
I can play / stream to dCS using the dCS App


If I power cycle the dCS, I am certain it will show up again in ROON.
I will do that in a bit. Its up in a rack on the TOP :wink:

Feel free to grab logs.

At 7:20 am PST (I am giving you times so you map to the logs)

  • I added back my SMB folders (since we rebooted both RoonServer and Roon ROCK this morning)
  • I power cycled the dCS Network Bridge

Everything is working again. As soon as dCS power cycled, ROON found it.

What is ODD is the dCS App never lost the dCS Network Bridge, but Roon likes to.

Let me know if you need any additional info.
I see this similar behavior about every few weeks.
This week I hit it in 5 days since I was playing almost continuously.


Same question as before:

Hi Danny

I answered earlier on the impact of restarting RoonServer & Roon ROCK.

Let me know if you want more info. Feel free to email me to get my cellphone if you want to have a quick chat.


sorry, I misunderstood your steps… step #1 was the restart of roonserver only, and although it found other devices, it did not find the dCS Bridge.

the SMB issue is already being looked at by tech team. Can you tell me what SMB server you are using? is it windows/mac/nas/etc… ? what model/versions?

@support will have to look at logs for the dCS thing, unless they already know something about that unit.

1 Like

Thanks. To summarize there are 3 issues.

  1. SMB Server loss after any restart of the RoonServer
  • Support is looking at this I believe.
  • I am using a standard Windows Server 2012
  • Everything is default in its setup
  • Its a basic SMB share
  • A have a dedicated user account called ROON that has permission tot he SMB folder
  1. Roon can’t do playback after n days of usage
  • That was the issue I reported here.
  • In this weeks repro I got there in 5 days with heavy playback
  1. Roon looses the dCS Network Bridge after a restart
  • After restarting RoonServer, the dCS Network can not be located
  • It requires you to power cycle the NBR to find it

I have the logs from today from the dCS NBR if you want them. I was going to send those and this thread to the folks at dCS as well to look at.


Hi @Mohammed_Samji ---- It would be great if you can provide us with the logs from the dCS NBR. I will be contacting you with upload instructions via PM momentarily.

Many thanks!

I had the same with my Rossini DAC.
Untill the update of dCS I let Roon usample/downsample to one sample rate.
The issue begins when the ROON/dCS combi changes from high to low sampler rates.
Not always…

Haven’t seen that with mine. It seems to handle sample rate changes ok. I also upsample everything except DSD using Roon.

Hi @Mohammed_Samji

Have you ever gotten into this state while Roon is actively playing back to the Network Bridge? In other words, playback just stops either mid track or at the transition to a new track then the queue starts being eaten.

Before rebooting ROCK are you able to play to any of your Sonos endpoints or do you see the same behavior with them?

If it’s only the bridge have you tried power-cycling the bridge before rebooting ROCK?

There are some known issues with the firmware on the Bridge as it relates to Roon and they’re being worked by dCS. I’m trying to figure out if your issue is a manifestation of one of those known bugs or something new.

I’ve used the Bridge in several situations with a similar complement of hardware (including Sonos) and haven’t run into an issue where the Bridge would get completely lost like that. This has happened with Sonos playback and a restart of the core was required (although in those cases I just rebooted ROCK), but the bridge has usually been pretty reliable in terms of self-recovery.

Yesterday, when I hit the original issue of playback not working, it impacted all my Roon endpoints. Both Sonos and NBR.

Everything is re-started and working, so i’m keeping an eye. The next time it happens, I’ll try re-starting the NBR first.

This behavior sounds like a known issue that is fixed in RAAT SDK 1.1.21 back in July. It was not a very common failure–most common for people with more than one core active on the network. We’ve only had maybe 2-3 reports of it in the wild across the whole ecosystem. It came up in QA at one of our partners where they have many cores running, and that gave us the clue to figure out how to reproduce/fix.

I believe that the bridge is still on an older version (maybe 1.1.18). I think this will be fixed once it is up to date.

I have the latest public firmware for the bridge, but it looks like dCS has a newer version.

I’ve requested the updated firmware from dCS and see if that prevents this.

I’ll respond here when I hit it again.

In the meantime, any idea of why SMB shares don’t reconnect after reboot?

There seems to be a bug here… but we cant figure it out from your logs.

Can you tell us:

  1. are you typing username “samji\roon” + a blank workgroup in some cases and username “roon” + “samji” workgroup in other cases?
  2. do one or both work?
  3. what is the username and domain/workgroup for your smb server?

It’d be nice to have you do the follow:

  1. remove all your shares from Roon, including the backup share
  2. reboot ROCK
  3. then note the date/time, and configure 1 share only for storage
  4. note exactly waht you typed into the setup fields
  5. reboot.
  6. if it doesnt come back up, i need the logs. they should have what i need (along with what you typed and your smb info).

A post was split to a new topic: Content being pulled from NAS struggling to play