Roon ROCK UEFI Intel NUC not showing HDMI output

So i noticed today that the ARC app on my phone is constantly hanging up and asking to close (Galaxy S22). It worked fine before on the old ROCK. Would this be an issue with tbr early release? Or would they not be tied together?

NICE! Good to hear @Brian_Scafaro

I have an Intel NUC11FNH and was having the same issue in not being able to see the HDMI port when running ROCK. Installing the earlyaccess file seems to have addressed it.

1 Like

Roon Core Machine


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library


Description of Issue

Hi there,
I know that HDMI output seems to be hit or miss and might not be recommended, but should my NUC5i3RYH with the latest ROCK, and AUDIO and HDMI activated in the latest BIOS, give me HDMI output? Only the analogue stereo socket shows up and is working, but HDMI is not showing under the internal devices. I would love to be able to feed the core directly via HDMI into my AV receiver.
I am trying Roon for the first time, and the NUC is what I had lying around for a core.
Thank you.

Hi @Daniel_S,

Can you please try the early access release I mentioned above and let us know if it helps in your case as well? Thanks!

Hi @noris
yes, that worked, thank you. Now I have 5 devices, and one of them worked. Multichannel also seems to work.
Will I now stay on the early access track or is it going to revert to the release track on the next release?

Hi I have just migrated ROCK to a new NUC12WSHi7, and I am having the same issue with HDMI not showing up as device to connect to core. I have tried the early access patch reinstall ( a couple of times) but no luck with this. All the Bios settings seem to be correct and the HMDI displays on screen at BIOS setup just no audio devices in ROON. Any further suggestions would be welcome. I have a good collection of multichannel content so this important for me. Thanks

Hi Just following up on whether there is any answer on the question about HDMI with a NUC 12. I’m thinking about upgrading my existing NUC and although I’m not sure there’s that much difference for Roon would normally want to go with the latest generation, ie 12 instead of 11. Any advice appreciated!

Please see this post from yesterday…

Hi I have done the update Version 1.0 (build 256) production on my new NUC12WSHi7, however the HDMI is still not available under Audio, likewise USB-C and Thunderbolt. The only options are USB hi-res (when I connect DAC) and HDA Intel PCH. I have logged under support.

How long does the new release take to show up on the ROCK? It still thinks the 255 ist the current build. Or do I have to do a clean install after being on the earlyaccess track? That would be really annoying.

I had to do a new install so it picked up the update, otherwise stuck on 255, it seemed to be looking for 254. Unfortunately neither 255 or 256 worked for me on NUC12, and I still only have USB.

OK, after reading around in here, I solved the problem by doing a Reinstall with the roonos-production.bin instruction file, which got me to 256 production. However, Roon really should move all early-acces units to the next production release automatically, if the early-acces problem is covered in that production release, as was here the case.

Did you replace the original BIN file and remove the early access BIN to upgrade to the PROD 256 version? I’d like to upgrade to PROD from the Early Access as well. Not sure If I still have the original BIN file though

The Early-Access bin should remove itself automatically after installation, if I remember correctly. The production bin I think I got from here. Just follow the instruction on the page. Good luck.

Hi @MikeS54 ,

There is no harm in staying on the earlyaccess branch, especially if you wish to participate in future RoonOS testing, but if you wish to switch back to the production version, you can use the following bin and the below instructions:

  1. Download the RoonOS instruction file from the below link and save it on your computer - do not modify the name, extension, or content of this file.

  2. Navigate to the /Data/Reinstall directory on your ROCK.

  3. Copy the instruction file that you downloaded into the Reinstall directory.

  4. Visit the RoonOS Web Administration Page and click on the “Reinstall” button.


A post was split to a new topic: Distortion on HDMI

5 posts were merged into an existing topic: No HDMI on supported NUC12WSHi3

The issue regarding HDMI output on UEFI has been resolved for NUC11 and older. Discussion regarding troubleshooting HDMI output on NUC12 has been migrated to the below thread:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.