Roon seems to be not recognizing my Nucleus (?) and will only play through AirPlay

Roon Core Machine


Networking Gear & Setup Details

Connected Audio Devices

Bluesound Node 2i that is connected to Nucleus.

Number of Tracks in Library

Description of Issue

I have a Bluesound Node 2i that plays just fine through the Bluesound App.

My Roon Nucleus is listed, in Audio Device Setup as “Unidentified Device Nucleus HDMI A” and only will play audio playback through AirPlay now, not through any other audio zone I thought I’d set up.

Also “connected to the Core” is a second version of it “Unidentified device Nucleus HDMI B”. I don’t even know if this mess is a duplicate installation.

I’d like to do a simple reinstall and have the opportunity to set the whole thing up again. How can I remove the mess and start cleanly?

Additionally, I have a Bluesound Node 2i in the other room pumping sound – again only through its app to another set of speakers; it works fine. And Roon works through Air Play only.

I know I am not touching/accessing the full audio quality possible here. Can you help me clear this up?

Ignore the HDMI outputs if you don’t have anything connected directly via HDMI they don’t do any harm and are meant to be there.

Ensure the Bluesounds are on the same network as your core this means the same vlan. All devi If you using a mech network system often they create an additional network for wireless or on top of your main router. Roon will not see any devices that are not on the same network.

Please fill in what your network setup this will help with diagnostics.

As a step identify the ip addresses of your Nuclues and the Bluesounds they should share the first 3 sets digits e.g 192.168.1 or 10.0.0. The last set will be different. If they don’t share the same first 3 sets then you have the devices on a different network.

If they are the same, restart all your network gear, Nucleus, and Bluesounds and see if it helps; more often does.

Thank you very much, but you attribute too much knowledge to me. I can’t even tell why there are two Nucleus’ listed, one A and one B (is one of these my Node 2i?), let alone why neither audio zone I set up plays. I would like to reinstall the whole system and set it up, making believe I just bought a Bluesound Node 2i and then added Roon to it. Or…take the Node 2i out and set up the Roon Nucleus first? But…how to get rid of all the old settings? And, no, I don’t know how to tell what address they are on. Don’t even know where to look.

Hi Jerry can you post a screenshot of what you see in Settings->Audio
Look for any Roon Ready devices there and try and get them in the screenshot

It will look something like this (depending what device you are using)

No none of them have anything to do with the Nodes as they connect to Roon over the network not via any direct connection. The Nucleus has hdmi connectors which are outputs that can be used to an AV Receiver or an outboard DAC if nothing is connected to them then they are not used. The Audio settings section in Roon allows you see all the available options that Roon offers for output this includes the HDMI ports. If they are not enabled in this section they are not shown as options to play via.

If you have connected the Nodes via HDMI direct to the Nucleus then don’t as that won’t work.

The nodes if on the same network as Roon show up under a section below the Nuclues which will be headed as Roon Ready. Here you enable them as zones to play to. If you don’t see them here then as I explained you have them on two different networks and Roon wont see them. You need to get the Nucleus and nodes on the same network.

I strongly recommend you read the Roon FAQ and help from the support section of the ap if you don’t get the fundamentals of how to set up Roon.

Please tell us how your home network is configured, how you connect the Nuclues to it and how the nodes are connected to it.

I obviously have set it up in a weird way.

Hi Jerry thanks for posting that.

I will try and walk you through a few things as Roon support do not work weekends (I’m just an end user like you)

I see you have your WiFi network on the network range 192.168.7.X
Is your Roon Core on that network or a different network?

What is the address of your Roon Core?

Thank you very much, Michael. Could you tell me a simple way of telling the Roon Core address/network?

Actually it says Nucleus
Is that the problem?

And, if so, how to fix???

Jerry it’s under settings in the first page

So that suggests that everything is on the same network which is a good start.

Are you currently able to play from Roon to your Node 2i over Airplay, if yes then it should also see it on RAAT (the Roon protocol). You probably want to unplug the HDMI cable if you have not already.

Are you running your Node on Ethernet or WiFi?

I have the Node plugged into a network switch that it hard-wired/Ethernet. I have the Roon Nucleus plugged into the same. Yes, Roon “plays” over Airplay only (which I seemed to have set as grouped-zone in BlueOS; maybe the problem is with the zones I set as default in BlueOS??

But “the path” always shows, as say, Qobuz playing through BlueSound Node 2i via Airplay even if I’m “controlling” it through Roon. Doesn’t show ANYTHING going through the Roon Nucleus at all. Just seems to regard the Nucleus as a big Remote for my Blue system. Does that make sense? All have been configured for Ethernet, not using Wifi.

Jerry thanks you read my mind
This is what mine looks like,.I don’t think you can disable Roon in the Bluesound app. Can you check for any updates.
I have a Bluesound PowerNode 2i upstairs in a box, maybe I will plug it in and check the settings.

Good taste in music BTW :+1:

So for the moment that is doing exactly what it is meant to do. The change should be that when you go into Settings->Audio then there should be another Node2i Roon ready device that you should be able to enable it and have a full Roon version.

It won’t actually change anything but will give you 24/96 upsampling if you want it

Thank you friend, for struggling with this annoying stuff with me on a beautiful Saturday. Will experiment. At this point it is acting like I don’t even have a Nucleus…this is the stuff that drives people mad.

You obviously have the basics working as Roon is doing its thing and it’s connected to Qobuz and playing over Airplay.

Trust me it’s not a nice Saturday here in South Wales, most and rain is all we have to offer today :grin:

Michael, it is a bizarre 73 degrees Fahrenheit here today – 5th day of November? – signaling that the world will probably end from global warming before I figure out how my Node 2i and Nucleus play with each other properly.

Thank you for giving me a friend in South Wales. You have one in the Hudson Valley of New York.

1 Like

Good to meet you Jerry from the Hudson Valley, and the weather has been very strange here, but it has turned winter in the last couple of days, at least rain wise, still not that cold.

I am a little slower than usual at the moment as I Covid positive but I found my PowerNode and turned it on. What I see there now with this enabled is an additional device (as below).
If you scroll down through your Settings->Audio do you see anything with the option to enable it ?