Roon sees KEF LSX as an Airplay device not a Roon Tested endpoint

I’m having an issue enabling KEFs LSX in Roon. The device only shows up as a generic Airplay endpoint. There is no dedicated KEF device as shown in this image.

  • I have rebooted and power cycled the KEF LSX
  • I have shut down and restarted Roon
  • The KEF LSX does work as a Roon Airplay endpoint.

The issue is similar to this one. Output showing as AirPlay for LSX
The difference is that I didn’t have the option of disabling Airplay and only using the dedicated KEF device.

Any help gratefully received.

Have you upgraded the firmware to the latest on the LSX?

Thanks that’s a good pointI should have added that in my original post, but yes it’s on 4.0.

Have you tried restarting your network gear. Turn you router and any switches you might be using off. Then turn them back on in order of router then switch. This can sometimes clear some discovery problems.

What’s your core running on? Is it wired or wireless.Do you have any other Roon Ready devices in your setup? Do they show up ok. Are the LSX wired or using wireless? Listing your network topology will also help support point you in the right direction.

Hi @GregW,

Please provide the information that @CrystalGipsy requested, as it would be useful in helping troubleshoot this issue:

Also, can you please share a screenshot of your Roon Settings -> Audio Tab? This screenshot should look something like this:

Firstly, I’d like to say thanks for responding @CrystalGipsy @noris Here’s some more information.

Core Machine (Operating system/System info/Roon build number)

  • macOS 10.13.6
  • Model Name: Mac mini
  • Model Identifier: Macmini5,1
  • Processor Name: Intel Core i5
  • Processor Speed: 2.3 GHz
  • Number of Processors: 1
  • Total Number of Cores: 2
  • Memory: 16 GB
  • Roon 1.6 (Build 416)
  • 20775 tracks in total(13022 Tidal)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Here’s an audio focused view of my home network.


  • There are 2 Cisco Meraki access points on each floor providing wireless coverage
  • There is a also a MinimServer on the network

Until now I’ve not had any issues with wired or wireless device discovery accross a range of audio and video devices.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Have you tried restarting your network gear.


What’s your core running on?

1.6, wired

Do you have any other Roon Ready devices in your setup?

Yes, Sonore microRendu which has worked flawlessly since 2016.

Are the LSX wired or using wireless?

I’ve tested both, but primarily wired.

Have you tried restarting your network gear.


Hi @GregW,

Thanks for letting me know that information and providing the diagram, it is helpful. I just want to confirm, if you plug in the LSX to the same switch that the Core is on, they still don’t appear?

If you manually set the KEFs to Network mode (using the KEF Control app) is there any change in behavior?

I also wonder if factory resetting the speakers will help, the LSX should have a “Reset” button on the back, if you press and hold this until they start flashing, does this trigger any change in behavior?

I was having a problem where my LSX would not show up natively in Roon. I did a firmware recovery from the KEF Control app and have not had problems since.
It’s been about three days. They would show up as airplay devices immediately. I know it’s intended for recovering from an interruption to a firmware update but I was at wits end to get it working.

Conclusions: good news and bad news after a weekends extensive testing.

  • After connecting the LSX to the same switch as the Roon Core and AP, Roon could see the native LSX device.
  • But only after @Terry_Murray suggestion to perform a firmware recovery.
  • Upon movement to another floor/room the connection to Roon was available for about 30 minutes before being lost again.
  • It looks like Roon can’t see the LSX one or more hops from the Roon Core in my network, despite it being available as an Airplay target irrespective of proximity to the Roon core.
  • I tested both wired and wireless configurations with the same results.
  • My conclusion is that in my network the Kef’s non RAAT’ ‘Roon Tested’ implementation is not going to work. Keep in mind that my microRendu has worked perfectly for about 3 years with this configuration.
  • It’s not the end of the world, I’ll put them in my office instead.

Thanks again for your collective help, it was much appreciated.

FYI. In my testing/troubleshooting I discovered that for iOS users who have upgraded the KEFs to version 4.0 of the firmware there is a new process to onboard or change the wifi network of the LSX.

Currently, it’s not covered in the:

  • Control App
  • FAQ
  • Quick Start Guide

The product manual updated (3-Jun-2019) does. Chapter 7.4.3 iOS (Airplay 2) Method

Once your speakers are upgraded with Airplay 2, iOS users can use this method to connect the speakers to your network.

  1. To get the speakers connected to a network, connect the power cables to the AC input connectors at the back of the speakers. The LED indicator on the Master Speaker will flash orange and white.
  2. Open the KEF Control app on your device. Select “KEF LSX Airplay” from the selection menu and then tap “Next”.
  3. Select “LSX_XXX” under “Set up new airplay speaker…”.
  4. Select the network to join and then tap “Next”.

The onboarding process will be automatically completed. The LED indicator on the Master Speaker will light solid white when the connection is successful. The Slave Speaker will be automatically and wirelessly connected to the Master Speaker.

Source: LSX_User_Manual_v1-0.pdf
Retrieved: 12.08.2019

Hi @GregW,

Thanks for sharing your experience here. I wonder if the network switches have anything to do with the issue. I know you mentioned that you tested on Wireless configuration, but I assume that the Core was still connected to the managed switch in the same config as before. From our Networking Best Practices:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Not sure if you are willing to investigate this aspect or just leave the KEFs in the office, but either way thanks again for your feedback here.

Hi @noris

During my testing I checked a number of settings including flow control, layer 3 and 7 firewall etc. None of the settings made a difference. Due to performance requirements and > 100m cable runs the switches are backhauled with fiber (SFP+). I don’t have a dumb copper/fiber SFP+ switch to test with.

I’m happy with my current solution, but I appreciate your suggestions.

Hi @GregW,

Thanks for the update here and for checking those aspects as well. If you are happy with your current solution and don’t want to investigate this further, we can close out this thread. Thanks again for reaching out to us and I wish you a pleasant listening experience!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.