Roon server becomes unresponsive after idling

Roon Core Machine

Windows 11 22H2, 5600x, 16GB Ram

Networking Gear & Setup Details

ASUS AC1200G+ as access point

Connected Audio Devices

Roon arc on oneplus 10 pro, roon remote on asus zenbook, roon remote locally

Number of Tracks in Library

150k or so

Description of Issue

I run roonappliance on my personal rig for now. and sometimes i need to leave the house and use roon arc. Typically, this works fine for the first 2 hours or so, but almost always, roon arc will tell me that the connection is poor or that it is unable to connect after that. At the end of the day, I often come home to roon remote on both the same machine that is hosting the roonappliance and my laptop both unable to play music, nor able to stop buffering for the home page or album page. This requires a restart of the roonappliance to remedy the issue

Hi, fellow user here
Does your comp go in to sleep? Disable sleep if so

computer does not go to sleep mode

Oh, that was the only time that my roon was non responsive. Maybe there are some more settings but I do not know. I have Roon Server installed on a Mac mini and it is running 24/7 in the livingroom background endpoint. Arc and remotes and other endpoints were frozen only when there is sleep.

windows 11 is set not to sleep, but i suspect that this is caused by something in window 11’s background app efficiency features, but I am not sure. I have not seen any other users report issues with windows 11 like this

Well that is way beyond my computer skill. But have you tried just to let music on playing, ghost like, with the shut down amp or on a virtual endpoint?

I think you’re onto something here.
I recently moved my core from a Mac to Windows 10.
I’m not too familiar with Windows yet but I seem to recall having similar issues which were resolved by changing the Windows Power Settings or maybe a something in the Ethernet Adapter settings?

1 Like

@traumerei - A very possible candidate, try it and see what effect it has disabling the power save option:



completely unresponsive. roon remote thinks it is connected but nothing that needs a response from core does anything

There is something on windows that does that.
Are you running Roon or Roon Server? Maybe Roon Server would work better (in my case it did)

1 Like

running roon server

will try this.

1 Like

tried this and came back to it being unresponsive again. I will try again, i suspect that this is caused by me leaving on the lockscreen

1 Like

not just that, but even after restarting roonserver, without restarting the computer itself, the roon arc section in gave a network timeout error(whose code i did not take down), and required changing the port number to work again.

roon server became unresponsive again within minutes

Aren’t there admin rights for specific application in Windows 11?

“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“2401:7400:c804:e2be:3c1c:3891:b7b2:1fe”,“router_external_ip”:“”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}
roon arc randomly gives messages like this. will test keeping system not in lockscreen

:frowning: sorry cannot help here, I only fave a forwarding rule from the router
hope others will

Hi @traumerei,

Can you check something for me? In Windows, navigate to Control Panel>Power options, and click Change plan settings for the selected power plan. Once there, give me a screenshot of what you see. It’s possible for the lock screen to mean two things. It can show up when you move the mouse when your computer OR the monitor is set to sleep and I want to verify that the computer itself isn’t sleeping. If it is, it’s surely the source of our issue here.


1 Like

the computer is not sleeping, i have set it to never sleep. it worked well today for the most part, but now i am having “something is wrong” i will check again.