Roon Server Incompatable with Home Assistant on Linux Ubuntu

Core Machine (Operating system/System info/Roon build number)

Ubuntu 20.04.1 LTS
Intel i5-4690, 32G Ram

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google Nest Router, Brand New - This Machine Connected via Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chromecast Audio

Description Of Issue

Firstly, I am new to Linux, which isn’t helping I am sure.
When I do a brand new install, and just install Roon Server using the following code, everything works great. Tested for 2 weeks, and all worked perfectly.

sudo apt-get install ffmpeg
curl -O
sudo apt-get install cifs-utils
chmod +x
sudo ./

However, this machine is my Home Assistant machine, and when I install home assistant and docker, Roon no longer connects to my chromecast. Error along the lines of ‘Audio device refused to switch to roon’. At this point, I take a look at this machine, and it has a system crash error. I did not copy the entire message, sorry. But I will add it in comments as soon as it happens again. I am currently going to reinstall the whole thing again.

System error included: opt/roonserver/roonmono/bin/mono-sgen
sigabrt in_gl_raise()

I can provide any info that is requested. I just initially wanted to ask if this was something that is fundamentally flawed. Docker with home assistant and room on the same server.

Any thoughts would be appreciated. I really don’t want 2 machines for these two tasks.

If you’re going down the Docker route deploying Roon as a Docker container may fix this.

Carl, you might be right. I just did this half an hour ago, and it is working fine. Will test for a little while, and then install home assistant to test. Will post results soon.

1 Like

Ok. I still have the same issue, even when installed on Docker. This time though, there is no Ubuntu system crash error. Just that my remote (Android Pixel 2) has the error:
Audio device refused to switch to roon

This is all a brand new fresh install. No customization to home assistant. I setup Home Assistant using these commands via terminal:

sudo su
apt-get install bash jq curl avahi-daemon dbus software-properties-common apparmor-utils
curl -sL "" | bash -s

After that install, it fails.

I did however have some info… I use portainer to manage docker. When I stop the container: hassio_multicast
The problem goes away. Even when the container restarts. But, if I restart the machine, the error is back.

I am not sure if this helps, I am sorry I don’t have a specific error message. This would be very reproducable, as it is all a fresh install. Roon and home assistant, thats it.

This looks interesting:

Interesting, and also super complex. For me anyway. I have opened up a new topic on the Home assistant forum:

I can not be the only person to install home assistant and roon on the same machine, yet, there doesn’t seem to be any info about it.

Pretty sure that this is your issue

But it looks tricky. There’s a combination of a Chromecast issue and HomeAssistant issues that are causing this.

A fix might be coming via the zeroconf update BTW.

Thanks Carl. Looks like it could be. But, just to add, I can’t play music on any of my google home devices either. Not sure what zeroconf is, but I sure hope it fixes it.

IF I’ve interpreted the issue thread correctly, and that is an if, the problem has nothing to do with Roon. The multicast module for home assistant is causing the issue and it will still happen without Roon. I can see that recent releases have changed the source for some of the multicast elements. I suspect that the implementation is a little immature.

I’d be curious to see what happens if you start HomeAssistant and the multicast agent with no Roon. I suspect you’ll still have trouble casting to the CC. I also get the impression that patching a config file on a docker container might solve the issue, but that may give you upgrade headaches.

Do you have supervised install? If so there is a roon add on for home assistant. That might help

I’d created a thread with support before finding this one:

The issue with zeroconf + the multicast container crashing CCAs mentioned here (mdns-repeater causes ChromeCast Audio devices to cease broadcasting mDNS responses when interface MTU exceeded · Issue #3 · home-assistant/plugin-multicast · GitHub) should have been resolved earlier this year when version 0.27.0 was incorporated into Home Assistant, but unfortunately, that does not correct the problem with casting from Roon.

It’s more likely that the issue is this one, which appears to be related:

For the time being, I have modified the hassio_multicast container image to simply disable the mdns-repeater service. This way, the multicast container can run to keep the watchdog happy, but the mdns-repeater doesn’t flood the interfaces. Sure enough, Roon is now able to cast to our Chromecast devices without issue, and all of my Chromecast integrations in Home Assistant continue to work as they always have. If any issues crop up with HA from hobbling the multicast container (or if the container gets updated and I need to pull the new one), I intend to try the suggestion of @pierre2113 on GitHub, which is to bind zeroconf to the default network interface:

Part of me feels like this is the real fix for our issue, but I started out by disabling the service altogether, and that seems to be working fine. In any case, I’ll be happy to provide further assistance if anybody needs it. Just happy to have a working Roon installation for the remainder of my trial.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.