Roon Server on DietPi?

I’ve just noticed that @Dan_Knight announced the availability of Roon Server on DietPi.

I rather thought that the RPi would not have enough horsepower to cope with Roon Server on anything more than a very small music library.

Has anyone tried this out yet?

1 Like

This is most probably aimed at Dietpi running on a x86 machine.

1 Like

Ah - of course. I associate DietPi with SBCs, but I now see it’s spreading its wings…

1 Like

Hi Geoff,

Yep, we like to try new things :slight_smile:

Roon Server is only available in our x86_64 Native PC beta image:

Hi Dan,
i am having issues with this install. It seems that my database and all settings are destroyed upon each update of the Roon Core. :frowning:

This might be up to my rookie knowledge of Linux but it still works just fine when it does…
But having to restore my DB from backup on each software update is a bit frustrating.

Mikael I too tried this and was met with the same issue…Im guessing its because its all running in RAM perhaps. I gave up on it and ran rock, no issues now. I dont think I ever tested resting a backup…but it was just a fun thing to try and the hardware was well under for server anyway…barely runs rock too but as a bridge its fine but much higher power footprint than a RPi

Hi Wiz, i should have stated that i do run the DietPi Optimized Software from within the DietPi x86 distro, on a ASRock J4105-ITX. So it’s not a Pi, but rather a low power barebone. Underspec? Yes, but still very well performing.

Do you have any suggestions on how to make ROCK run in a UEFI environmen? :slight_smile:

I dont have any systems with UEFI…so cant advise there but im guessing its not going to happen. I got Rock running on a 2012 i7 Mac mini server but it was just a proof of concept and didnt work on the base Ethernet.

My diet pi x86 was on an Intel D510MO it can run rock OK but only for tidal content…maybe a very small local library but my i7-7700 copes far better with my 275K track library, soon to be housed in the chassis and not via NAS. The D510MO can run rock as an endpoint but I dont think its any better than RPi4 or 3 to be honest. And the power use is probably a lot more.

these days im less inclined to mess so much with different setups, ROCK is great on the NUC, MOCK is better on faster setups with my large library and im probably looking at another Lumin D1/2 for my other setup with the RPI’s with IQAudIO digiamp+ hats driving bookshelves for other smaller room setups like dining room and bedroom etc.

sorry for the ramble :slight_smile:

1 Like

Ah, i see… The ASRock is quite speedy actually, a lot faster than my Innuos Zen Mini MkII and my previous Asus Prime J3355I-C.
Upsamples RedBook to DSD128 at 5.0x processing speed, which is near my NUC/ROCK’s.

@Dan_Knight So, now again i lost the complete Roon database while updating to the latest build. Please, have a look at whats causing this, or simply remove Roon Server from the “Optimized software” list of DietPi.
It can’t be optimized and still crash and burn on every update :wink:

@Mikael_Ollars -

It the past, it has seemed that @Dan_Knight doesn’t visit this forum much anymore.

You might have better luck in the DietPi forum.

Yes, i noted the same. I followed your suggestion and got a response within 30minutes on the DietPi-forum! :slight_smile:

I had tried this many moons ago with much the same results and gave up and just went with ROCK. Interested to know what the reply was from Dan

Same problems here !
I’ve thought that is normal untill now but it seems it is a problem.
I am running DietPi on ESXi as virtual appliance.
Everything is working fine except of database reset on updates.
DietPi roon installer script is modifiied, and RoonServer is installed in anotere location than usual linux installation.
To be more specific, default Roon installation uses ‘opt’ as installation folder, and on DietPi Roon is installed under mnt/dietpi_userdata
Maybe this is an issue for updates?

I think we would understand better if the @support crew could outline the update process for a Roon Core/Server? And we could bring that info to the DietPi-guys also,

I think the problem is the database location.
By default, roonserver database is set to be in var/roon/RoonServer
DietPi team has changed the database location to be in the same folder as roonserver app, but the update process first delete installation folder and then unarchive the updated version.
So, the database is deleted on every update.

1 Like

IIRC DietPi runs all in RAM

I think it runs in RAM on RPi.
I am talking about x86 version of DietPi.

My conclusion is that Roon claims that it’s OK to change the $ROON_DATAROOT to, say:
And DietPi does this, but at each update the update procedure deletes the database and then rewrites it?

I assume I have to uninstall Roon Server using DietPi Software manager and then reinstall it using Roons easy install scripts to make sure everything is default.
And then, once again restore my database! :slight_smile: I’m getting good at this now though! :smiley:

1 Like

I think you are right !
Like I said also in DietPi forum, it is OK to change the $ROON_DATAROOT but I think is shall not be in the same folder as roonserver installation !
That’s why roon has database by default on var/roon.
I have thought also to try this:

  1. Stop roonserver
  2. move RoonServer folder from /mnt/dietpi_userdata/roonserver to var/roon
  3. modify roonserver.service file on etc/systemd/system and change this line: Environment=ROON_DATAROOT=/mnt/dietpi_userdata/roonserver
    to be:
  4. restart roonserver
  5. see what’s happening
1 Like