Roon Server on Mac mini not working

Sent you a private Roon message

I noticed in your pictures that one of your watched folders is on “Deryck HD” which presumably is your Mac mini hard drive? Actually it looks like you’re watching your Music Folder and your user folder (that contains your Music folder) - unless you have music outside of your Music folder (on the Desktop, for instance) you shouldn’t need to do that.

I don’t know if it’s a good idea to name your NAD the same as your main hard drive. That seems to be when the problems detecting the NAD started. Factory reset and rename it or rename your main HD temporarily.

If and when you are able to see your NAD as a folder you are 90% of the way there. Make sure you have Windows file sharing enabled on your Mac mini (Sharing -> File Sharing -> Options). That is exactly what I had when I tried to connect from the computer running my Core to a Mac mini running Roon Bridge. The Music folder on the Mac mini would show up on the Desktop but I would get the “invalid Network Path” error. Turning on the Windows File Sharing got rid of the error. I checked the owner’s manual for your NAD and it doesn’t seen to have a setting but your Mac mini does; I’m almost sure that turning Windows File Sharing will get rid of the error.

Also if your NAD disappeared from the Finder you may have a sketchy Wi-Fi connection. I didn’t see anything in the owner’s manual to say that a factory reset would erase your music so you might try resetting it and setting up your connection from scratch. If you can connect your NAD with a wired connection it would be even better.

Once you can see it in your Desktop again set Windows File Sharing to ON and fingers crossed, enjoy your music.

Hi Jose,
I renamed the NAD which had been called “Marcel” to “Deryck HD” That’s where my music files reside(d). Thanks for your suggestions re Windows File Sharing". Sound promising. -David


Just updated the iPhone and the iPad to iOS 12.

Immediately, neither could find the Core, still running on the Mac Mini, though that was updated to High Sierra 10.13.6. Obviously, iOS 12’s fault. But nobody else was complaining…

An extremely frustrating afternoon.

So, after some thrashing around, I discovered that the Mac Mini on which Core was running had both ethernet (gig ethernet) and wifi connections.

I killed the wifi, and now the Roon on the iPhone works. And so does Roon on the iPad.

So: simple advice (Roon Support are welcome to comment/correct):

  • have only ONE network connection on the machine running Roon Core

This sounds like it could be an OS issue or it could be a Roon issue, but it shouldn’t happen. Perhaps Roon Core could look at network connections and prompt the user appropriately (assuming I’ve diagnosed an issue, rather than something specific to me)?

– P


I sympathize with your plight. With every major Apple OS revision things tend to go sideways and gremlins appear. I just installed Mojave and weird things began to happen. Much beach balling and some audio drops and loss of connection with Tidal. Probably not Roon’s fault. These things happened before I ever used Roon, at least the gremlin side of things.

Today I just did a complete clean OS install on my Mac Mini and Air LT. Not real hard since I seem to do it on all the major Apple OS pushes. Just a lot of time backing up music files so as not to lose anything.

Can say now with two fresh OS and Roon installs, core and client, that things are smoking fast and good.

Back to listening to music.