Roon server show "Not Responding"

Roon Core Machine

Roon server

Networking Gear & Setup Details

I don’t use VPN in my home network.

Connected Audio Devices

All endpoints are connected to the core via my home network.

Number of Tracks in Library

I have only 6 to 7 K tracks in my storeage.

Description of Issue

Roon server started become Not responding when I check it in the sys tray on my server. None of my phones, PCs, tablets running Roon Remote sees the core. Server PC specs and Roon server status are in screenshots attached.
I reinstalled the latest Roon Server, reboot the server PC multiple times and no improvement.
I then tried installed Roon software on the same server PC and using it as the core and my Roon remote on my phone can see it as the core.

Roon Server not responding:

System specs:

Hi @Stephen_Lee1,

Thank you for writing us and thank you for awaiting a response.

Have you been using Roon Server previously and the problem just now manifested or is this something that occurred from the onset of install?



It had been working continuously. Then one day last week, remote ciuld no longer find the core. When I checked the server PC, it shows Roon Server not responding.
For now I run the Roon software with the UI on the same server PC as a workaround. The remote app on all my devices can see the core from of the Roon software.

Hi @Stephen_Lee1,

Thank you for the clarification. I know you reinstalled but if you’d like, you can follow these steps to wipe things clean and try to install on a clean slate. Just make sure to observe step 1 and let me know how it goes.

  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Followed the steps. Remote cannot find the core and Roon server is still “Not responding” on the server PC.

I have the same issue. Tried reinstalling and it didn’t help.
It could be because of windows 10 update that I lately installed but I’m not sure.
Installing full roon on intel nuc and making new server is working.
It’s not working when only roon server is used.

ps. Firewall is turned off

In my case, the issue was not preceded by Windows updates as I set up Windows to only notify me of updates but I start updates manually. Roon server was fine after the last Win update.

I seem to have the same problem. My Roon Sever is showing as ‘Not Responding’ after startup. I have tried reinstalling and clearing and Roon Server will not start on Windows. This only happened after I installed the Windows Update and the latest Roon update.

Edit, does not work anymore. I will be opening my own case as completely removing everything and a fresh install of Roon Server still shows Not Responding

Alright, so I went in and was able to uninstall ‘KB4023057: Update for Windows Update Service components’, which seems to be labeled as a Feature Update for 22H2. I uninstalled and rebooted and now Roon Server is working again.


For easy finding of @Stephen_Cosgrove’s new thread:

I’ll try to do that tomorrow and see the outcome

1 Like

Interesting. Mine
was not working and Windows update just prompted my last night for the 22H2 update.

I have supported Windows machines since 1993 and can honestly say this is par for the course! They’re what I know best but sometimes they surprise me with things like this.

We looked at your case today with our development group and would be interested to see logs if the issue recurrs. Please let me know if it does but for now, I will mark your thread as resolved.


My Room Core stopped responding about 4 months ago. I’ve tried rebooting everything in an effort to fix it and don’t know what else to do after having invested such time and money on something that I now feel inclined to dispose of down the local refuse tip. Maybe I can sell it on eBay…, except I’ve lost all my music library’s that had taken endless hours to create.

I hope you are not closing this thread as the issue is not resolved for me. My last post indicated I had the issue before Windows 22H2 update.

I did not remove KB4023057. However, I might have found out the culprit may be Avast free antivirus. From Sys tray, I can disable Avast’s all 7 Shields. Roon server would show Not Responding steadily. But as soon as I disable Avast’s all 7 protection shields, within seconds, Roon Server would show running and Remote start picking it up. I can then reenable all 7 shields and Roon Server would continue to run. But if I stop Roon server and than start it again while the shields are running, the issue recurs. So as long as all Avast’s 7 shields are not running while Roon server is starting, server can start.
By going through Avast’s detail settings, I was able to identify 5 of the 7 protection shields, namely, File Shield, Behavior Shield, Web Shield, Mail Shield and Ransomware shield. I cannot find what the other two shields are. I ran the following test against each of the 5 shields identified: 1. make sure Roon Server is in Running state (see above on how to get it there). 2.Then disable a shield. 3. Stop Roon Server and start it again to see if the shield stops Roon server from starting properly. Ransomware shield is the only one that prevents Roon server from starting properly. Under Ransomware Shield settings, I can make Roon Server an app exception but it didn’t stop the shield from preventing Roon server to start…
I like Avast and don’t want to try another antivirus. So as a workaround from now on, whenever I reboot or stop Roon server, I would disable the Ransomware shield briefly, start Roon Server and then enable Ransomware shield again.
As I indicated, the issue started last week, Avast must have run some updates to have changed something. Perhaps Roon Dev Team can play with Avast on your test environment to see why this is a problem. It would also be interesting to find out why Roon software (with UI) does not experience this issue.
Here’s Avast’s detail. Please keep the case open for a short time in case things change on my end. Thanks!

1 Like

That’s funny. I had avast shields disabled (all the time) and It didn’t work.
But i tried turning it on and off and kaboom everything is working now :slight_smile:

Being a software developer myself it’s not even strange to me, just funny - in digital world there is always something unpredictable happening.

Alright, great brainstorming! I turned off my Avast Firewall yesterday thinking that would be it, I never thought of trying the others. It probably worked briefly yesterday when I disabled everything for a few minutes.

I run Avast as well and doing as you said, turning off the Ransomware feature seemed to do the trick. I posted in my other thread that the issue was I couldn’t get past the startup requiring to use the broker-cert.pfx file. Once the Ransomware feature was turned off, Roon Server was able to use the file and initialize what it needed to:
11/03 13:48:26 Trace: [broker/backups] initializing
11/03 13:48:26 Info: [loadstatus] account loading is complete

Once that was able to run, all the other processes started no problem. I am currently restoring a backup, thank you again for all who took the time to troubleshoot and find a workaround.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.