Roon Server Software doesn't run / restart

Hi, I hope you can help me!

I am running Roon Rock on a NUC i3-7100U / 128GB M2 SSD / 2x4 GB Crucial RAM since about 3 months. My CD-Database is located on a QNAP-NAS. Everything worked fine.
Today Roon Core stopped responding. The Roon OS starts but the Server Software keeps showing the message “Not Running”. Tried to restart it in the browser, tried to shut down (also disconnected power-cable) and restarted, nothing changed.

What can I do? I would be very thankful for your help. Sincerely,


P.S.: The user forum is a little tricky for me. Don’t know how to send it to the support or otherwise in the forum, so I addressed it to you - as I read on of your topics. Thanks!

I’m no expert in this sort of problem. You do far better posting a topic in the Roon support forum and including @support in your post to get their attention.

If the ROCK software isn’t running it would seem to me that you’re going to have to recover or reinstall it. See

But I’d be asking others who know much more before doing it, plus you need to be confident you have up-to-date backups of your Roon database. Good luck.

Hello @Helmut_Woehrer,

Thanks for contacting support, I’d be happy to take a look over this issue with you. Before going down the recovery and reinstall route I’d like to see if we can’t get RAATServer in a “fresh” state.

To do so, please:

  • Navigate to your ROCK Data directory from another computer using these instructions
  • Locate the “RAATServer” folder
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Reboot the ROCK machine

Please let me know your findings after doing so, look forward to your reply!


Greetings from Austria and many thanks for your reply. I would have reinstalled roon rock, if my last saved recovery would be newer. It’s been more than a month since then. I’ve imported more than 250 cds with necessary adaptions which prevents me from reinstalling to fast.
Thanks for your help, Helmut

Hello Noris,

many thanks for your support! I’ve tried your suggestion, renamed the RAATServer and restarted. The Roon Server starts now but restarts every 18 seconds and is not reachable.
Is there something else I can try before reinstalling? As I wrote to Lloyd, my last save/recovery is about 40 days old … mea culpa :wink: Thanks, Helmut

Hello @Helmut_Woehrer,

Sorry to hear that the RAATSever refresh has not resolved this issue. Is the ROCK staying powered on and accessible through the web administration page even while the server software is not running?

I have gone ahead and enabled diagnostics mode on your account and what this action will do is next time the ROCK is active, a set of logs should automatically be generated and uploaded to our servers for further analysis.

Just in case this diagnostics report does not reach our servers (which I fear may not happen without the server software), can you please also send us manually send us a copy of the logs from the machine? To do so please follow the below instructions:

  • Power your ROCK on

  • Navigate to your ROCK Data Directory from another computer on the same network

  • Open the folder called “Data”

  • Open the folder called “RoonServer”

  • Create an zip file of the “Logs” folder:
    On OSX, right-click the Logs folder -> Compress
    On Windows, right-click the Logs folder -> Send To -> Compressed Zipped Folder

  • Upload the zip file to our servers for analysis (I will send you a link shortly on how to do so) or upload them as a Dropbox Shared folder and provide the link.

The folder that you are looking for should look like this:

Please let me know if you are able to perform the above, or if you have issues with any of the steps, I can gladly clarify. I noticed you were asking for similar instructions on the other thread @Lloyd_Borrett, so if you are able to access your logs in this fashion as well, that would be helpful in troubleshooting.


Hello Noris!

Since restarting my NUC today the Data-Directory is no longer reachable. I saved the whole data-folder 2 days ago and did the zipping of the folder. Don’t know if it helps. I uploded the zipped log-folder. The link on my dropbox is (Think, I would need your email-adress):

Don’t know if u able to access it this way.
Thanks, Helmut

P.S.: Should I try the recover option via the webinterface? And if it fails too?

Thank you for your help, Helmut

Hello @Helmut_Woehrer,

Sorry to hear that the NUC Data directory is no longer reachable. I noticed that in the shared dropbox folder, you have only uploaded the primary .log file, usually there are 20 log files included in that directory so if you would be able to upload the rest, that could allow us to look for patterns and see why this behavior is happening.

I would keep that Data folder somewhere safe for the meantime, it should be possible to extract your database from the Data folder, but you may not even need to go this far. If you want to try the OS restore from the Web Administration page, you can certainly do so and it shouldn’t affect your database, it is this button:

Please let me know your findings.


Hello Noris, sorry that I’m responding so late.

You know: Since the diagnostic mode is activated I can’t access the actual Data-folder … It’s the saved one from a day before.

As there are no other log-files or -folders in the directory you told me, I have uploaded the logfiles located in the RAATserver-folder. There are about 20 files inside. Hope I did right.

Do you think that reinstalling whole ROON Rock on my NUC would solve the problem. Do you have a link for me, how to manage this and how can I extract the database from the Data folder?

If you think I should try something before the new installation, tell me.

Thanks for your patience, Helmut

P.S.: ROON rocks, there is no way back to other music-player :wink:

Hello @Helmut_Woehrer,

Thank you for the RAATServer files, I have added them to your case.

Activating diagnostics mode on your account should not have any impact on you being able to access the data folder. Since you are unable to access the data folder, this makes me believe that the issue could be with the Network setup or the ROCK hardware itself, are you able to still access the Web Administration page on on the ROCK?

I would try the "Reinstall Operating System button I have highlighted in my previous screenshot and see if that stabilizes things, this should not affect your database. I would not do a full restore just yet because since the Data folder you have copied is not a typical backup made from within Roon, I would not like to change the database if we can at at all avoid it. I have submitted your case to QA and would like to get their take on it before performing more aggressive troubleshooting, I will be sure to let you know what they advise.


Good morning Noris!

Hit again the “Reinstall Operating System” button. Nothing changed.

  1. Not accessible datafolder
  2. The Roon Server restarts every 18 seconds and is not reachable.
  3. Web Administration page is reachable. So I did the Reinstall of the Roon OS, I’ am able to stop the perpetuum Roon Server restarts, I’m able to shut down the NUC (Roon OS).

Want my music back :wink:

Thanks, Helmut

Hello @Helmut_Woehrer,

Thanks for confirming that the Reinstall Operating System button had no effect here.
Just to avoid any confusion on my end, I want to confirm where you are in the restore process:

  • You have reinstalled the ROCK’s Operating System but have not reset the database yet
  • The Web Admin page is still reachable
  • The Data folder is not
  • After the last reinstall, the Roon Server doesn’t restart randomly anymore and stays online
  • You have a complete backup of the ROCK’s Data Folder (including all of the contents of the RoonServer folder – This is important)

If you meet all of the conditions in the list above then yes, you can go ahead and reinstall the ROCK OS and clear the database. You can do this through the Web Administration page by pressing Reset Database and Settings and then performing a Reinstall of the Operating System with the button or if you are still having issues after reinstalling from the Web Administration page you can follow the initial ROCK Install Guide.

After re-installing ROCK, I would make sure that you have updated to our latest build 354 and check to see if the ROCK is running properly without restoring your database just yet – I would like to confirm that everything is operational with a fresh database before attempting to restore the old database. Please let me know your findings after the reinstall.


Hello Noris!

  1. Roon OS reinstalled but not reset database - YES
  2. Web Admin page reachable - YES
  3. Data folder not reachable - YES
  4. since the first reinstall (the second too) the Roon Server restarts randomly. I only stopped this through the webinterface - during the 18 secs it’s not reachable (only stopable through the webinterface) - then it restarts … - so NO
  5. YES - I copied the Data Folder to my desktop … and I have an older correct save through the interface of the Roon Server.
    Copied Data folder:

Thanks, Helmut

Hello @Helmut_Woehrer,

Thanks for clarifying that for me. I would go ahead and perform the ROCK database reset and reinstall now.

Since it seems that Roon Server is having issues staying online your best bet here would be to follow the ROCK Install Guide that you originally performed when setting the machine up. After the reset, you should focus on getting everything stable, verifying there’s no more issues with Roon Server stopping in the Web Admin page and that music plays fine and then we can perform the database restore afterwards.

Please let me know if you need any help with the reinstall but the guide I linked above should have all the necessary information.


Hi Noris,

thanks for your quick answer. I will reinstall Roon Rock in the morning.

Thanks for now, Helmut

1 Like

Hello @Helmut_Woehrer,

I just wanted to check in with you here and see how Roon is working after reinstalling ROCK, any more issues? Please let me know when you have a minute.


Hello @Helmut_Woehrer,

Just wanted to check in here again with you.
Have you been able to reinstall ROCK and things are working as expected?

Please let me know if you require additional assistance regarding this issue.


Hello Noris!

Sorry for my late answer. I was really busy last weeks …

About 2 weeks ago, I decided to try a reset through the webinterface of roon first, because I had not much time. The reset was succsessful * and I imported my saves. Roon is running as it should.
/* First after reset I had copied the roon server cache from the saved DATA folder to the reset but this did not bring back my changes. So I imported the SAVE. /
I lost - as I mentioned before - my changes to the last 250 CDs. I did a few corrections till now but mainly to the genre (classic, keyboard, opera etc.) if it was missing. It’s easy to know changes from CDs you have retagged and imported the day before (about 7 to 10 CDs a day) but it’s hard to see incorrect/wrong recorrected roon-import-tags from CDs you worked on 2 months ago.
After the basic corrections I will do a save of the database. Then there would be a possibility to try something else, if you would have a suggestion for me.
I hope, my explanations are understandable, english is not my native language … as you did mention before :wink:

Thanks for your help, Helmut