Roon server stops allowing connections

Hi I am having a continuing issue with my roon server. After its been running for a few days you cant connect to it using any of my remotes. There are on a mixture of OS, IOS,Android and Windows. When clicking on the choose server option it shows my server and in the status it says its Initializing and is stuck in this mode and is unresponsive and you just cannot connect. The only thing I can do is restart the server and then its ok for a while again. The Mr’s is not happy as it tends to happen when she wants to use it. I moved to Roon from LMS expecting to get a more stable platform but this is not the case currently.

For reference all my end points are Squeezeboxes,1 x radio and the rest are Squeezelites running on PiCore Players with some on wifi and some using LAN. It doesn’t matter which end point I am using either as its happened when we have been using any of them and does not seemed linked to one of them.

My server is running on Vortexbox 2.4 OS and is fully up to date. Hardware is :
Intel Core i3 4160 – 3.6GHz
Memory: 4GB Corsair 1600MHz CL9
Storage: 120GB SSD

Any advise would be very good. Let me know what extra info you might need to debug.

It’s dont it again now after only a few hours since last restart and I have not played anything at all.

Hi @Simon_Arnold3 ---- Thank you for the report and sharing your observations with us, the insight is greatly appreciated. My apologies for the troubles.

To help aide in my evaluation of this behavior you are experiencing, may I very kindly ask you to please provide me with the following information:

  1. An expanded description of your current setup as seen here.

  2. Can you please provide the details of your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a clear understanding of how your devices are communicating and what tools are being used to make those communications possible.

  3. Have you tried reinstalling the application on any of the devices that are acting as remotes?


Rooney core running on :
VORTEXBOX 2.4 OS which is based on Fedora23.
I3 3.6GHz CPU 4GB RAM and 128GB SSD.
Music is located on QNAP NAS via SMB share.
Server and NAS on same network using wired connection 1gb straight to Netgear R8000 Nighthawk router no additional software or hardware is involved.
Tidal is UK account, HiFi quality.

End points are made up of Squeezebox Radio, PiCore Players for 3 x Raspberry Pi using Squeezelite. These are connected to Roon core via a combination of wired over Power line adaptor for one PiCore Player, wireless G for Squeezebox Radio and wireless N for the rest of the PiCore Players using the same Netgear router.

Remotes are running on Windows 10 latest version on Laptop using Wireless A.C. iPhone and Android tablet and phones all wireless. The remote on Windows the main one I use for controlling settings has been uninstalled and reinstalled recently.

Hi @Simon_Arnold3 ----- Thank you for the follow up and taking the time to answer my questions, both are appreciated.

In regard to any troubleshooting you have performed thus far, while trying to diagnosis the cause for this behavior, have you tried testing with a hardwired connection from the Win10 laptop (Roon remote) to the Netgear router? If so, was the device able to stay in communication with your server?


No not tried that but it’s really easy for me to do. I am away from home for the next week so wont be able to try this. One thing to note is this only started to happen with the recent update. Before that I had no connectivity issues.

Same problem here. Mostly with Roon on an Android tablet. Never had such issues with the previous versions.

Still having these issues with android and iphone remotes, Cant connet to the core, have to choose connect to a new core to see my core and its stuck on initializing. I can use the PC client on windows ok during this though and its on the same wireless network. Very odd.