Roon Server Ubuntu 16.04.5 LTS redlines all the CPUs [fixed in 1.6]

I installed Roon Server on Ubuntu 14.04 LTS, and it was painless and worked perfectly.

I subsequently upgraded to Ubuntu 16.04.5 LTS, and it seemed to be fine.

I looked at the “Signal Path Processing” speed, and found it had fallen to 1.0.


So I looked at the box with htop, and found that even when idle, roon appeared to be redlining all the CPUs.

I don’t know how long this had been in this condition.

Shutting down roon and restarting (sudo service roonserver stop/start) fixed it.

Any idea why this was happening?

To be clear, did you perform a distribution upgrade or a fresh install? Just thinking that Roon could be analysing your media files.

Also, can you please provide more information regarding your setup using this thread as a guide?

Let us know what version of Roon you’re running plus the specification of your the Linux box. Is Background Audio Analysis turned on?

Thanks for that - I was wondering where to get the software release version.

I’m running roon core version 1.5 build 363 64 bit.
The linux server is twin processor, each with 12 cores, Xeon in a Dell Poweredge 410 with 64Gb RAM.
Music is stored on a Synology DS1815+, and Roon did it’s own mounting of the music folder.
The roon installation was a fresh install (but on LTS 14.04) with auto updates, and the Linux O/S was recently (in the last few days) upgraded from 14.04 to 16.04.
Background audio analysis was turned on, but there have been no additions of audio tracks to the collection for about a week.
The collection is about 27k tracks.

Did you get this solved? I noticed you have Plex consuming resources in htop, which may not play nice with roon. Both of those can be aggressive when scanning files, but according to my experience Plex should be allowed to hog the system only when there are no other significant usage demands on the system. In any case you should NOT allow Plex to scan or auto-transcode when you do initial roon scans, or if try to listen to music directly on the server.
In fact I gave up Plex because it knows absolutely no limits in hogging system resources.

Arguably it shouldn’t have to. That’s what cgroups in the Linux kernel are for…

Sorry not to reply earlier, however…

Did you get this solved?
I just shut roon down and started it again when it took all the resources. Since the update to roon 1.6, the problem has not reappeared.

I gave up Plex because it knows absolutely no limits in hogging system
I just bought a 24 core server instead. But with up to 10 video streams at once, we probably need it.