Roon "silently" plays Qobuz intermittently

Roon Core Machine

Roon 2.0 build 1311 running on QNAP TS-873A QTS

Networking Gear & Setup Details

HP ProCurve switches
Raspberry Pi 4B, RoPieee 2023.09 (1117), Allo DigiOne HAT

Connected Audio Devices

Denon X2000, SPDIF

Number of Tracks in Library

7500 tracks

Description of Issue

Have a Qobuz subscription, playing CD-quality audio. Also have my local library ripped as either FLAC or MP3 192 or 320.

I often set up a few tracks in the queue, mixed from local library and Qobuz. All seems to work fine, until for unknown reason a Qobuz track starts to play… I can see the progress indicator showing the track playing and advancing, but no sound. Restarting playback on that track doesn’t get the sound… but if I play a track from local library, then try the Qobuz track again, it works fine. And, it continues to work until, arbitrarily, it stops again.

How can I figure out what has gone wrong? I’ve restarted the Core and the NAS, I’ve tried with and without a local static-linked ffmpeg. This has also continued to happen across many releases of Roon and Ropieee, I don’t know exactly when it started happening.

Any advice appreciated. Thanks.

Can anyone make any suggestions what to try to solve or help solve this?

Still trying to solve this. I know now that it has to be the user-supplied ffmpeg I added from John Van Sickle - FFmpeg Static Builds.

I’ve tried several versions of this amd64 build, and when i install that, the intermittent playback from Qobuz starts.

I wanted to use this since Roon with the supplied ffmpeg won’t play AAC radio stations. So this helps that, but messes up Qobuz.

Is there a way to get help?

Hi @Alan_Sparks,

Thanks for your patience while our team works through each thread!

As of right now, there isn’t a way to skip or block AAC files from Qobuz through Roon. Your best bet would be to ask Qobuz directly if there’s a way to restrict playback to FLAC on an account basis.

You could also see about ruling your NAS out of the question, and temporarily host Roon Server on your PC.

Sorry for the delay responding.

Unfortunately, I think you don’t understand the problem.

My issue is that the ffmpeg apparently on the QNAP by default has no AAC codec, so some radio stations do not play. I’ve tried to replace the ffmpeg with a current statically-linked version, which fixes that issue. But, randomly, Roon starts playing a track from Qobuz, and no sound comes out.

Restarting playback on that song doesn’t help. But, playing a local library track, then going back to Qobuz works.


Bump. Please, can someone help or suggest a way to debug this?

This is still happening, and not just with a custom ffmpeg.

I’ve seen this also happen on a stock install of RoonOnNAS on my QNAP TS-873A.

A Qobuz track will start playing, I see the progress indicator moving, but no sound output.

Sounds like the dac in the Denon maybe tripping up at sample rate changes. Try to establish if this only happens on certain tracks of a certain sample rate and bit depth.

Try upsampling content to the max rate the device supports which is 192/24 and see if it all plays ball.

Thanks for the reply. So far it’s just been FLAC at 44.1 16 bit music… Not expecting any real sample rate changes, but will look for a pattern. As noted, the same item from Qobuz usually plays fine, except when it randomly doesn’t.

I turned on sample rate conversion in MUSE for 192/44.1. Don’t think there’s any DAC-related settings in the Ropieee or Denon ends… Playing with that to see if that changes anything.

Thanks for this suggestion of enabling sample rate conversion. Not sure if it was tripping up the Denon, or the Allo Digione HAT, but since adding this I’ve not experienced the issue. Even moved to the custom FFMPEG to fix the AAC support issue on my NAS.

Appreciate the help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.