Roon skipping tracks during import on 1.3 build 209 [Resolved]


I believe this was already reported in the past and also solved with a latest release but I am still experiencing I/0 failures upon import.
This morning I added 7 new albums and every album reported one I/O failure. As such one track wasn’t imported. Most of the time this is the first track. Sometimes the second.

Both Core and connecting device are running 1.3 build 209.
My files are stored on a Synology NAS.

Below is a screen shot of the skipped files:

I know I can re-add the files and most ogf the times they do re-appear again. But imo this needs to be solved in the software.

In the meantime I have copied the skipped files out of the default storage location and copied them back.
However Roon doesn’t discover them. Not after a forced rescan, nor from a rescan from the album menu. They just don’t appear. However these are valid .flac files capable of playing.

When rebooting the Mac (or just restarting Roon Core) the tracks are added tot the library. So surely a Roon issue.
Can you guys look into this (again)?
This morning I added another album. Again first track wasn’t displayed. After recopying the track and restarting Roon it gets discovered. This is not a nice way of working.

something not right here.

Can you give us a full description of your setup, and a screenshot of the Storage tab of Settings?

On the machine running your Core, you’re able to copy these files from the NAS? Can you play them in any other apps?

Hi Mike, below you’ll find a description of my setup:

Core 1.3 build 209 (64bit) I am using the latest version on all devices.
running on a Mac Mini running OS X 10.11.6 (1.4Ghz, 4GB RAM).
Music is stored on a Synology NAS (DS1511+), DSM 6.0.2-8451 Update 9
amount of tracks 6300
Yes I can alter, copy and play the missing tracks on the Mac running Core, but also on other systems. The skipped tracks are valid tracks which are playing after moving them and restarting the Core App. (Feature Suggestion: Restarting the Core from a connected device).

Core and NAS are connected through a cabled connection. Control Devices are running iOS and Android over a wireless connection. Works perfect…

Let me know if you have enough information or you need more.

Hi @Werner_De_Bijl ---- Thank you for the follow up and providing the requested information. Both are are appreciated!

Can you verify for me if have your tried to copy the content to the Mac Mini’s internal storage and then accessing is that way from Roon? If so, was the experience different of the same?


Hi @Eric, the experience is the same.
I just copied some albums and again only the first or second song is skipped. But now I didn’t recopy the files and restarted the Roon Server. I only restarted the Roonserver which was enough to have them listed again.
So in my case it would be great if i could just restart the roonserver from my phone or something.
At the moment I have scheduled a reboot of my Mac every night. This way I am certain newly added albums are complete the next day without further manual intervention.
This works for me, but it isn’t a nice fix obviously.

@Werner_De_Bijl - can you post a screenshot of what you’re seeing in DSM under Control Panel > File Services > SMB > Advanced Settings?

Hi @mike,

Here you have the screenshots.

Hi any update on this?

I am still seeying this. Below a screenshot of an import of today:

And when I restarted the Roon server on my Mac Mini:

So it is solved in 2 seconds… but a nice solution imo

Hi @Werner_De_Bijl ---- Thank you for your patience and my apologies for the wait . We are still trying to determine what could be causing this behavior to occur and would like to test with a sample of your media in house.

Can you provide me a dropbox download link via a PM containing a sample album you have noticed this import issue with?


Hi @Eric, I will provide you a link later this evening.
However I am not sure if this will lead to a resolution. I have this issue on every import: HDTRACKS, MP3 files. It doesn’t matter. During my recent imports none of them were complete on the very first import; always missing the first or second track.
Nevertheless I’ll provide you with some of my recent albums. Other suggestions or tweaks are welcome.

Hi @Eric and @mike I am very positive with the tests on the latest Roon build on my Mini. I have done several tests after it has been released by adding new and existing content to Roon and it is adding all tracks.
Not sure if it has something to do with a fix or just a fresh copy of the software but it does do the trick.

I’ll perform some further testing today and if all is ok I will comment it here!

1 Like

Hi guys, sorry for my late response. But as promised I would came back to you.
Since I am running the new version of the sw on my Mac Mini the track skipping thing is completely vanished. Why? I don’t know. But I am happy.
This one can be closed and marked as solved.