Roon skips all Track on PC, refuses to work with ALL audio devices connected to it after purchase of license

Roon Core Machine

Version 2.0 (build 1148 and tried on build 1149)
Windows 11 Pro, i9 9900K 64gb ram

Networking Gear & Setup Details

Wired Network, with VPN, but Roon is excluded from it

Connected Audio Devices

All other external audio devices work fine, such as a BlueSound Node 2i, an Apple TV and Marantz AVR.
The PC itself has a Fostex USB Audio HP-A4 DAC, as well as an HDMI connection thru Nvidia Card, none of which will play.

Number of Tracks in Library

3,400 tracks with Tidal

Description of Issue

I’ve been using Roon fine for the last 2 weeks, both to control my BlueSound Node 2i and my PC when working. I had set up the PC to use the System Output so not to take full control of the audio device, as well as in WASAPI mode, if I wanted it to switch to HIRES.

I doubt it’s related, but the coincidence is strange, but my Trial expired on Friday and so I purchased a 1 year membership. This morning, when trying to get it to work on my PC, it simply refuses to play anything, simply skipping everything, with no message error. I’ve tried all Audio devices on the PC and all behave the same. Even installed ASIO drivers for the Fostex sound card, but this made no difference.

I was running an Early release version of it, so I did uninstall it to see if this would help. I didn’t, so I uninstalled again, this time deleting all preferences. It worked, for a few songs. Had to stop it for a an hour, refuses to play again since then.

The strange thing is, if I try to play to the Fostex set in exclusive mode, it does stop any other software from accessing it, so it does take control of it.

The only thing that changed this weekend, was that I installed the Android Virtual Machine now available on Windows 11, but I did also uninstall it…

Any help would be greatly appreciated!

I’m adding a section of the logs, when I try to play a Track and the error that seem to occur.

I really hope to get this fixes, as it’s quite strange that it stopped working the Moment I paid for a yearly license :expressionless:

11/29 10:33:02 Info: 
--[ SignalPath ]---------------------------------------------
SignalPath Quality = HighQuality
    Source Format=Flac 96000/24/2 BitRate=2889 Quality=Lossless
    Raat Device=System Output
    Output OutputType=Local_SharedMode_Wasapi Quality=HighQuality SubType= Model=System Output
11/29 10:33:02 Warn: [System Output] [zoneplayer/raat] failed to sync sender clock to endpointSystem Output: Sooloos.Broker.Transport.ClockSyncResult
11/29 10:33:02 Warn: [System Output] [zoneplayer/raat] failed to sync clocks with any up
11/29 10:33:02 Info: sleep 0ms after flush
11/29 10:33:02 Info: [audio/env] [zoneplayer -> stream] All streams were disposed
11/29 10:33:02 Info: [audio/env] [zoneplayer -> stream -> endpoint] All streams were disposed
11/29 10:33:02 Warn: [zone System Output] Track Stopped Due to Error
11/29 10:33:02 Info: [zone System Output] OnPlayFeedback StoppedEndOfMediaUnnatural
11/29 10:33:02 Debug: [zone System Output] _Advance (Track)
11/29 10:33:02 Trace: [System Output] [HighQuality, 24/96 FLAC => 24/96] [STOPPED @ 0:00] 
11/29 10:33:02 Trace: [roonapi] [apiclient] CONTINUE Changed {"changes":[{"operation":"remove","index":0,"count":1}]}
11/29 10:33:02 Trace: [roonapi] [apiclient] CONTINUE Changed {"zones_changed":[{"zone_id":"1601355c746467358a1bfdcc07ff9e410548","display_name":"System Output","outputs":[{"output_id":"1701355c746467358a1bfdcc07ff9e410548","zone_id":"1601355c746467358a1bfdcc07ff9e410548","can_group_with_output_ids":["1701355c746467358a1bfdcc07ff9e410548","170175dc1a9d4c82272a3f92f1abcae8d338"],"display_name":"System Output","volume":{"type":"number","min":0,"max":100,"value":100,"step":1,"is_muted":false,"hard_limit_min":0,"hard_limit_max":100,"soft_limit":100},"source_controls":[{"control_key":"1","display_name":"System Output","supports_standby":false,"status":"indeterminate"}]}],"state":"stopped","is_next_allowed":false,"is_previous_allowed":true,"is_pause_allowed":false,"is_play_allowed":false,"is_seek_allowed":false,"queue_items_remaining":0,"queue_time_remaining":0,"settings":{"loop":"disabled","shuffle":false,"auto_radio":false}}],"zones_seek_changed":[{"zone_id":"1601355c746467358a1bfdcc07ff9e410548","queue_time_remaining":0}]}
11/29 10:33:04 Info: [library] saved recent ProfileId=59ca1f81-f8b9-417e-9479-2c5647f3e321 Time=2022-11-29 3:33:03 PM DataType=album Type=long_nav MetadataId=326777 ContentId=326777 LibraryId= Text= Genre=

I recently had the same situation. Roon skipped through all the songs on the album without sound. I changed many settings in the Win/settings/sound area trying out some Multichannel files and then Roon wouldn’t work. It sounds like you’ve done some of the same things I did to get it to work so something is still amiss.

Don’t forget to reboot your core. Then go to Roon settings/audio and enable the end point you want to use. Make sure you have selected the Fostex (not Realtek) and your Win settings are on 2 channel (not multi or Atmos) and with settings that your hardware can handle (ie. 24 bit 192khz) with WASAPI not Direct Sound. I know this is basic but I hope it helps.

That’s the Crazy part, I don`t think I changed anything that had anything to do with sound.
I did install the Android Subsystem, which I removed later.

I’ve rebooted multiple times, removed anything I could think of, removed Nahimic sound drivers and it’s service… but these where there even when it was working.

When I did uninstall the second time, it did work briefly, so it does seem to be a Roon issue, as that was the only thing changed in that instance. Other apps all work fine, including Tidal, that can take control of the sound card no issues.

I did try to do a system restore to last Wednesday, as a Nuclear option, but Windows being Windows, it wasn’t able to complete it :expressionless:

If your Windows settings are OK and your end point is available and enabled in Roon settings/audio it should work. Last thing I can think of is to check your firewall settings. I know it worked before but you never know.

One reason I moved my core from my Windows machine was to avoid the updates from Microsoft because it affects many things and you really don’t know when it happens. Not saying that is what has happened here.

All the best. John

Just an update on this issue.

I’ve uninstalled both my Antivirus, Bitdefender as well as my VPN, PIA and It’s now working again.
Which is again strange, as it was working fine for 2 weeks prior…

Roon was excluded from the VPN, and was working fine before, as all other devices could see the server fine…

I’ll start by re-installing Bitdefender to see if this was the issue, as it was set to auto update, so perhaps it was an quiet update during the weekend that caused the issue…

Well I guess the issue Resolved itself?!

I’ve now re-installed both the Antivirus and VPN and everything still works.
No idea what the issue was, or how it got resolved… Hopefully it doesn’t happen again.

I’m surprised that at the price this software is, that no one from support never chimed in…

Glad I pointed you in the right direction.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.