Roon slow with playback (loading/changing songs) both local and Tidal and generating overviews

@support new data point. Just added a pair of Devialet Phantom II’s to my setup. If I try to play files on this as a Roon device I get exactly the same behaviors as on my DCS. Meaning extremely long waiting times.

Something is really wrong here. I would appreciate we accelerate the timelines to get this solved.

Thanks once more

Hi @Jilco_Schuurmans

Here’s what I’m hoping we can do next:

  • Play to System Output of a remote
  • Provide a couple of examples of Roon loading slowly, including:
    • Time that you start playback
    • Length of time it takes to start
    • Name of the track
  • After you provide some examples, use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).

We’ll take a look at these specific examples when playing to System Output. Thanks!

1 Like

@dylan when playing to direct system output on my PC (using my NAS as a Core) I have seldom experienced this problem. I have the Devialets plugged directly to my PC soundcard and I have them as a proper Roon playback device. It is when I use the DCS or the Devialet as playback devices directly this is when the issues occur.

@dylan any updates?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

@dylan as a matter of trying for solutions my local dealer gave me a Roon Core+ to try out.
Currently connecting my library to this to test. Will do a restore so I have exactly the same library as on my NAS

Interesting is that also the Roon Core+ has some delay not as bad as my NAS. It has a way more responsive moments where I can happily skip between various tracks (Personal Library and Tidal) and out of the blue it stalls again.

@dylan @support for comparison, using Tidal direct on the DCS via the DCS app give no slowness whatsoever. Roon Core+ still has delays from time to time. Also JRiver has no delays when using local library only

Hello @Jilco_Schuurmans ,

Thank you for the additional data point here! This is definitely interesting that a different Core has the same behavior.

I was reviewing earlier in the thread and I noticed that you have a fairly complex network setup. Since the issue doesn’t impact local devices, we should try to further simplify this network:

Would it be possible for you to try connecting the Core to the same switch that the Bartok is connected (the first one in the connection path), even temporarily?

That way we can eliminate other switch interactions from the equation. Please let us know if you are able to perform this test, thanks!

@noris as per one of my posts I have the QNAP, DCS Bartok all on the same unmanaged switch (the top hand 16-port Switch) connected directly to the router. I also connected the Nucleus+ to the same switch (I also played with various switches on this node with no results). With this setup I get the same problems as when I scatter my devices across the network. No issues whatsoever play Tidal directly on any device nor JRiver. Hope this give the info you need (also attached the updated Network diagram)

@support will test this weekend again with the new release to see if anything changed

I can confirm that with a Roon Core the problems are solved in this new release. Will be testing the QNAP shortly

Back on the QNAP tonight @support unfortunately the problems still persist. Some minor improvement in load time however still have to wait to skip tracks, so no real solution this release

keen to get more help

Hi @Jilco_Schuurmans ,

Thanks for the update here!

Just to confirm, the Nucleus and QNAP were both connected to the same switch when the Nucleus was working as expected but the QNAP was not, is this correct?

Have you confirmed if a fresh database on the QNAP also exhibits the same behavior? The instructions on how to set up a new database should be similar to the normal install instructions, as long as you configure a different shared folder:

@noris Yes both the Nucleus and the QNAP are on the same switch

I’ve restored a backup of my Nucleus back onto my QNAP as I don’t want to loose any playlists, library corrections etc. So the QNAP and the Nucleus effectively ran the same library both in size and actual content

1 Like

Hello @Jilco_Schuurmans ,

Thank you for the additional information.

Since the Nucleus is working properly, and this issue is only impacting the QNAP, it suggests that there is an interaction on the QNAP causing this behavior.

Have you had a chance to set up a fresh database on the QNAP and the behavior is the same? Even as a temporary test, this can provide a useful data point, thanks!

@noris can you please ensure my account is temporarily assignable to 2 different cores?
This way I keep one functioning one whilst I rebuild the other one

thanks for your help on this

Hi @Jilco_Schuurmans ,

You are free to switch between as many Roon Cores as you wish, the caveat here is that there can only be one active at the same time. Hope this helps!

@noris that one I knew of course, I need two concurrent logins as I don’t want to be down on my core whilst resetting the other one. Thx for helping out