Roon software on PC problem

My PC is having more and more trouble with Roon’s PC software. When I open Roon on my desktop, this frozen image first appears:


When I want to close this page I see the message that Roon is not reacting:

My desktop is running Windows 11 and has an Intel® Core™ i3-8100 CPU @ 3.60GHz from 2018.
The last few weeks I saw this happen more often but after restarting Roon the problem was solved. Unfortunately this no longer works. Roon gets no further than the screens shown.

What have I already tried:
Restarted the desktop.
I have rebooted the sonicTransporter.
I tried the Roonserver on local playback, which didn’t help and put it back.
A restart of the Roon server.
I uninstalled and reinstalled the software.
Checked the Firewall for allowed apps.

Unfortunately nothing has helped.
My Qobuz app for Desktop does work.
Other than that, the apps for Roon on my iPhone and iPad work fine. There I get to see my PC with DAC enabled at Settings> Audio.
Does anyone recognize this problem and is there a solution?
Is it my Desktop or Roon or both?
Thank you very much for the attention and help.

1 Like


Thank you for the diagram. Let’s see if I understand this correctly. The sonicTransporter is your Roon server, and it is connected directly via Ethernet and two switches back to your router? Do your iPhone and iPad see the Roon Core and can they both control or play music on it?

The PC running Windows 11, and acting a Roon Remote, is having the problem from what I read, although it appears the Core is able to see the DAC connected to the PC. Also, this PC can connect to the Internet since you are able to connect to Qobuz, is this correct? Is the PC connected to your network using an Ethernet cable or WiFi?

Your Windows Firewall screenshot shows that both roon.exe and raatserver.exe are disabled for public networks. I think they should both be enabled (they are on my Windows 11 system where the Roon client is installed).

That’s right. It’s a solution Andrew from Small Green Computer recommended and it is very successful for my iPad as remote.

Yes they can see and do. They can even control my desktop setup what my desktop can no longer do.

It’s all correct and the PC has a wired connection to my network.
Speed measured via my PC:

Through task manager I can see that Roon is putting a lot of strain on the computer. I don’t know if this is normal.

I think this was the default setting without having problems, but I had already adjusted the settings today:

…but that didn’t help either. Roon still doesn’t react.

I think I would uninstall Roon from your desktop (and check the “delete database and settings” in the uninstall) and then download from Roon Labs and reinstall it again. You are using it as a remote, so the database and settings for the active Core are held on the Sonic Transporter.

It definitely seems to have a problem - my Windows 11 Roon remote consumes < 1% CPU when running and playing to the endpoint on my Windows PC.

1 Like

I agree with Geoff, I don’t believe it is a network issue but most likely a configuration issue on the Windows 11 PC.

I had already done that.

But because of your answer I started looking for Roon.exe on this PC and when I clicked on the icon (red arrow) something strange happened and this screen appeared:

After relaunch then this:

That’s nice, of course, but I don’t understand why it turned out that way. The standard procedure for an update should not be like this. I’d really like to understand what was going on. If I know that then the problem is really solved.
But anyhow thanks!


Build 778 is really quite old, dating from a year ago. Recent builds do check compatibility between Core and Remote builds, and perhaps 778 was too old to work correctly with the check in these newer builds. However, it would seem as though the remote has now got itself updated to the latest build, and you are back up and running again…

I’m sure I had the latest update for my PC. Somehow it jumped back (I don’t think you can do that yourself) tangled up and caused a frozen home screen that prevented me from updating. How is that possible? I do not know. Who knows?
Now I have this About:

From 16 March 2022 I had for both the update version1.8 build 918 but I didn’t make a screenprint of it.
This is the latest screenprint (24 Januari 2022) :

I’m not sure if it’s the same, but I’ve encountered a similar issue where the windows client crashes. For me, it seems to happen on specific artist pages. This time, I attempted to load the artist page for Ray Charles, and the app froze up. Then I force closed it, and upon reopening, it did the same thing, presumably because it’s trying to load the same artist again. My laptop’s fans spin up when this happens, and Roon uses 15% CPU, which is more than usual.

I’ve had this happen once before, and the only way that I could fix it was by completely uninstalling the application and installing it again (this was a week or 2 ago the first time). I’ll leave it as is for now if there is a way to get useful logs out, but I suspect that I’m going to have to reinstall again to fix it. Luckily, that has worked for me in the past, although it is a pain to need to change all my settings every time.

So yesterday I searched and found Roon.exe via the search window in this PC. That could of course have been a file from last year. I didn’t check that first but when I clicked on it I got a few firewall warnings and suddenly I had the About page. Maybe it’s a coincidence that it was pulled loose with an outdated version. A few hours earlier I had removed the Roon software via the Windows configuration program and installed the latest software via the Roon website. That didn’t help then. It is remarkable that the Roon.exe did have an effect in the second attempt.
Can you conclude that in this case you need an outdated Roon.exe if things have crashed? If so then you don’t need to do a complete reinstall like Nolem did.

Was hoping that the update today would resolve the issue, but no dice there. I suppose the client doesn’t actually survive long enough to do the update, so it only would have mattered if the server update did the trick.

In any case, I uninstalled and reinstalled the Roon client once, this time without deleting “Settings and Databases” or whatever the option is called. I then downloaded from the website, and installed. Upon launch, the same crash happened.

I did it again, this time removing my settings, and just the first time I had this issue it worked, but I had to set all my preferences again.

I saw the following trace in my server logs when I kill the windows processes, not sure if that’s helpful at all.

System.Net.Sockets.SocketException (104): Connection reset by peer
   at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.ThrowException(SocketError error, CancellationToken cancellationToken)
   at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.System.Threading.Tasks.Sources.IValueTaskSource<System.Int32>.GetResult(Int16 token)
   at System.Threading.Tasks.ValueTask`1.ValueTaskSourceAsTask.<>c.<.cctor>b__4_0(Object state)
--- End of stack trace from previous location ---
   at System.Threading.Tasks.TaskToApm.End[TResult](IAsyncResult asyncResult)
   at Sooloos.RnetJsonClient.<>c__DisplayClass65_0.<_BeginRead>b__0(IAsyncResult ar)

I also saved a client log file, but I glanced through it and there wasn’t anything that looked super wrong. Not that I’d know exactly what to look for, but there weren’t any stacktraces or Error/Fatal level messages, and the only Warn messages didn’t seem very important (but what do I know). These are the only “Warn” messages at the end of the log file.

03/28 20:27:54 Warn: [rnet/RnetJsonClient] failed to connect A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
03/28 20:28:17 Warn: [ui/slowness] widget scrollbar_parent(1184) took 224ms to _Update

And it’s happening again now. This time I don’t even recall it crashing the last time I had it open, but when I went to open it up this evening it did the usual thing, and I’ve had to reinstall again. This is really getting to be a pain - is there anything that can be done as far as logs or crash reporting to figure out what the cause is? I’m not interested in reinstalling roon every other day.

I suggest that you open a new Support request for your issue, rather than continue to post in this existing thread that was started by someone else.

The Roon support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. Hence my request.

In order for Roon’s support team to better assist you, please provide a brief description of your current setup and the nature of the issue using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they have a clear understanding of how your devices are connected. Thanks.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.