Roon states it playing multichannel but Denon receiver just plays stereo (doesn't switch to Multi In)

Core Machine (Operating system/System info/Roon build number)

i7 32GB RAM, Files live on this machine
Windows 2012 Server
Roon: 100600416 1.6 (build 416) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hardwired LAN. Core and Files are on the same machine

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mini PC with HDMI output directly connected to a Denon AVR-2313

Description Of Issue

I’ve a odd issue.
I have multi channel playing fine from my mini pc into my Denon AVR-2313 via HDMI.
But the mini pc has an old slow harddrive in it, so I replace it with an SSD drive, and reinstall windows and roon
I’ve set Roon up in the same way as it was with the old drive.
Now when I play multi channel audio, roon states it’s all playing fine, but the Denon doesn’t switch to ‘Multi In’ it just stays on stereo.

I’ve even swapped the old hard drive back in, and that works, swapped the ssd one back in, doesn’t work.

An hints or suggestions as to what I could try?

Is this the same zone you use your custom stereo configuration with?

Hi. No. As it’s a fresh install, I haven’t set any custom stuff up yet…

Fresh install without loading a backup? Then check your device settings (Settings|Audio); make sure you use the HDMI and it’s correctly setup for multichannel output.

I’ve done that…
I even screenshot all the settings from my old hard drive installation and copied them exactly.
Roon seems to be behaving (well, it thinks it is, it’s saying it’s spitting out 7.1) but the amp doesn’t switch as it normally does…
I’ve going to try and clone by old mechanical drive to the new ssd, see if that works. Not as nice as a fresh install but might work…

If you can post your current settings here this might be of great value for others that trying to help you. You can use the instructions found here to do so. A screenshot from your signal path when playing multichannel content can provide some insight too.

Note: As this is a fresh OS install (I assume) it might as well be a driver issue (missing driver/missing or wrong configuration in Windows).

1 Like

Hey @BlackJack It’s late here in Oz, so i’ll have to try and get back to this tomorrow. I will post more info. Thank you for helping out :slight_smile:

1 Like

Morning @BlackJack,
I’ve managed to get it working…
I did the following:

  1. Reformatted and installed from scratch (just to ensure I was starting from a clean slate)
  2. Installed the ION NVidia HD Audio driver (this was missing before, it was just using the default windows HDMI driver - I think this was the key point)
  3. Opened UDP port 9003 onm the wirewall
  4. Enabled and changed the WASAPI device to:
    • Exclusive mode;
    • Max sample rate 96khz
    • Enable Event Mode = true
    • Channel Layout = 7.1

It then worked. :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.