Roon stops playing after a few hours

Roon Version:
Roon Version 1.5 (build 363) stable (64bit)
Running on a QNAP TVS-871T with OS version

Playback devices include:
Meridian HD streamers

Music is stored on the QNAP in a dedicated Roon folder. We have also tested external storage devices to rule that out. Collection size is 150,000 - but we have done testing with only 30 tracks to make sure that a large library wasn’t the issue.

Had CISCO certified network technician inspect network, no problems were detected. All other music services work perfectly, including Tidal on its own. Plex and another more data heavy services also work perfectly. QNAP, Meridian and Sonos are all wired.

Media consists of FLAC files. Majority are 44.1kHz 16bit. Issue happens regardless of files. Media was purchased from digital media retailers. It does not “hang up” on a specific track or type of track. We have done testing with limited libraries to confirm this.

Screenshot attached of media playing. I was looking for the other audio settings to screenshot mentioned here I'm having a problem with Roon -- where do I report it? but was unable to find it. If you think that is relevant please let me know how to find that.

After Roon plays for a couple of hours, it no longer can search for new tracks. The display does not put up a warning, but the arrow continues to go around searching for music. When you reboot Roon, it works again.

It worked for nine months without issue. This issue is new. We can’t confirm if it started happening after a specific update, but all software is up to date and it has been happening for three months so it has spanned software updates that would have potentially fixed some specific bug.

Disconnecting Tidal does not solve the issue. We thought this was a potential trigger.

It does not matter which output device is used, it will happen regardless.

Finally, we even tried buying a Nucleus server and testing that - but there was no improvement. The same issue. Even if we just connected a USB drive to completely isolate the file system.

Any help would be appreciated.

Log files located here:

Some piece of (networked) equipment somewhere in the chain may be going to sleep, so first thing check energy settings.

Thanks for response, Mike.

The network is pretty simple, and there is really only a Cisco managed switch (left unmanaged) in the chain and that has no sleep mode. The Meridian offers no sleep mode, Sonos is, well, Sonos.

There is a side symptom that might help to mention, which I forgot: After the short time period, playing music (any music, it isn’t format related), when I go to Roon to change the track, it will not change or else is very slow to change tracks. So for example some times I might say I want to change to a new track, and when I click play, up by Tracks & Credits it will show a spinning disc while it is looking for the album. Then eventually it finds the album, but that might take 30 seconds to 3 minutes to forever. It varies. It’s like it is out of resources, but then when I reboot the Roon Server it will be snappy fast again. This made me think it was my QNAP (even though that seemed silly since it handles Plex which is much more intensive as far as I can tell), so I bought a Nucleus to try that. Same problem!

flagging @support here for you

Sometimes managed switches have „features“ (often with unclear names) that limit or regulate streaming through them to stop one port hogging the bandwidth. It might be worth checking for this too.

1 Like

Yep, easy enough to just put in a small un-managed switch to isolate that issue.

Yes, we have tried that. I tried another more basic switch to make sure that it wasn’t the issue, and the same problem occurs.

We also took the Sonos off the network at one point to test that, and took the Meridian off also to see if that was causing some problem.

Thanks for your help

Hey Skip – first off, sorry for the trouble here. Our support team can definitely take a closer look at this after the holiday, and I’m sure we can figure out what’s going on here.

Some questions that will help them get started:

  • Can you describe all networking gear in use here?
  • Can you give us a timestamp for one or two occasions when this happened? That will give us something to look at once the support team pulls diagnostics from your install.

Thanks for your patience Skip and sorry again for the trouble!

Thanks for your help, Mike.

The networking gear in use is a Cisco SG-200-50P gigabit switch. The wireless network is run through a Ubiquiti wifi system. While all of the equipment is wired, we still control wirelessly (using iPads or iPhones generally), hence why I’m noting the Ubiquiti system (points are UniFi UAP-AC-PRO).

The streaming devices are Meridian 218s and Sonos. Again, we’ve isolated both of those by removing them and testing one at a time.

We just had a lockup today around 3:40pm (3:41-42 maybe), here is a fresh log package:

It seems like it needs to play for a while for it to happen. A few hours maybe. If I just listen to a few songs I notice no problems, but on a Sunday afternoon listening all day I’ll have a few lockups/searching for tracks/issues described above. I suspected a memory leak in the software originally, since when I rebooted the application on the QNAP it works fine again, but I imagine you’d know of that immediately and have lots of forum posts about it.

Happy Holidays!

Some good timestamps in this updated log:

5:09 Problem Noticed - Music stopped playing and clicking on a new track nothing would happen. It may have started a bit earlier, but this is the first point I noticed the problem.
5:12 Reboot needed for Roon to work again
5:13 restarted Roon.


Hello @Skip_Braver,

I took a look at your submitted logs and unfortunately it doesn’t show much other than the buffer is not being filled for those timestamps and that RoonServer is disconnecting at other tiems. I can ask the QA team for a full analysis but do note that it may take a bit of time until the holiday season has concluded.

Since you mentioned that this same issue occurred with a Nucleus as well this leads me to believe that it is networking related. I would take a look at our Networking Best Practices Guide for some ideas.

I know that you already tried replacing the managed switch with an more basic one, but I wonder if it could be the router causing the issues. If your router is listed under our Networking Best Practices guide it may be worthwhile to try toggling those settings. Another guide that may give you some more ideas here is our Troubleshooting Dropouts Guide.

Please let me know if any of my suggestions help, I will also start a ticket for this issue with the QA team and will let you know as soon as they have had a chance to look over the diagnostics. I appreciate your patience here and wish you a great holiday as well!


Thanks, Noris.

Using a Nucleus, I connected it directly to the router rather than having it go through a switch. I played it in two zones, “Meridian Family” and “Meridian Master”. It locked up at 21:08 on the server logs, with “Fleetwood Mac - Oh Well” and “Led Zeppelin - Walter’s Walk”. The Roon app stopped responding and the music stopped playing in both rooms. Interestingly, if you look at the logs it will show it kept playing as far as Roon is concerned. But the music stopped, and the app isn’t responding.

Attached are those logs. If you search for those songs in your text editor you’ll find the point where everything stopped.

Thanks again for the help.

Hello @Skip_Braver,

Thanks for providing those logs, I have attached them to your case with the QA team and will let you know as soon as I have some feedback regarding the analysis of those submitted logs.


Hello @Skip_Braver,

Apologies for the delay in getting back to you here due to the holiday season. I had a meeting today with the QA team regarding your case and they have a few suggestions/questions:

  • How is your multicast configured with the UniFi setup? Can you please verify that you are not blocking Multicast traffic from passing through? I would double check that LAN to WAN multicast is enabled and take a look over this UniFi troubleshooting Guide to see if it it applies to your setup.

  • We have noticed quite a few DNS errors in those logs, can you try to change your DNS from the ISP provided ones to Google DNS or Cloudflare DNS?

  • After performing the DNS change, can you please let us know another timestamp of when this issue occurs?


Thank you, Noris.

I checked the UBNT Wifi system and the option to block broadcast on SSID was disabled. Multicast and broadcast filtering is already disabled. I am using Google’s DNS already. I also checked the firewall on the modem and nothing is being blocked. Any other suggestions?

Thanks for confirming that info @Skip_Braver,

I still believe this issue to be Networking related from what I see, multicast is likely failing somewhere and as I noted before, you seem to be having buffering issues and I am noticing disconnects from a few of your endpoints randomly. I would also take a look to see if you have “flow control” as an option on that switch as we have previously seen that have an impact.

Let’s try this: I’d like to get a new set of logs to see if there are any patterns between the one’s you submitted and the current ones, so I kindly ask you to reproduce this issue once more and note the exact local time in your country (ex. 8:04PM) that you notice the behavior again.

I am also tagging our resident QNAP expert @crieke to see if he has any other suggestions here based on the log files that you have submitted. Please let me know the new timestamp when possible.


Hello @Skip_Braver,

I just wanted to check in here again with you and let you know that I have brought your case to the senior devs today who also confirmed that this issue appears to be networking related.

Our dev team discussed this issue and thinks the clear next step here is to try and localize the problem by simplifying the network and confirming when the issue recurs as you add complexity back in

I would try my previous flow control suggestion and then to simplify and rebuild your network, this can include temporarily bypassing the switch and trying to connect the QNAP directly on the router to verify if the same issue still occurs.