Roon Suddenly Not Playing to AirPlay Device (Firmware 7.6.9)


(Andrew Webb) #1

Please do not advise me to buy a different endpoint.

Roon Core 1.5.339 is running on a Mac Pro, Late 2013, 64 GB of RAM. 3 GHz 8-Core Intel Xeon E5. Mac OS 10.13.6. The Core machine is connected to the network via Ethernet; WiFi is turned off.

Music is stored on a RAID connected to the Mac via Lightning cable.

The endpoint that Roon decided it doesn’t like is an Apple Airport Express, Firmware 7.6.9, in Bridge Mode, wifi turned off, connected via Ethernet to Airport Tower base station, which is serving wireless for this floor. The Tower is wired to the Mikrotik hEX RB750Gr3 5-port Ethernet Gigabit Router in the basement, which is wired to the Fiber ONT.

Airport audio out to amplifier & speakers.

Roon has been seeing and using this endpoint for weeks.
All iOS and Mac devices on the network can play through the endpoint, whether they be wired or WiFi.

What happens:

Pick a song in Roon, press play, and the Play button turns to a Pause button. Sometimes the playhead moves, and the waveform appears, sometimes the playhead does not move. No audio output on the endpoint.

Remedies I have tried:

Checked that no devices are using the endpoint’s AirPlay.

Checked that the audio files I am trying to play are where Roon thinks they are, and that they are playable both locally and to the endpoint.

Restart Roon Core.
Disable endpoint, restart host Mac, re-enable endpoint.
Restart Airport via Airport Utility.
Restart Airport via yanking the power cord.
Disabling endpoint in Roon, setting an Airplay password on the Airport, re-enabling endpoint and entering password.
I did the hokey-pokey and I turned myself around, sacrificed a chicken, and had my horoscope read by the weirdo down the street.

Anyone have a suggestion? @support


Why aren't all your friends using Roon?
Apple Playback Issues
(Paul Williams) #3

AirPlay itself maybe the problem rather than Roon. I have multiple devices that use AirPlay - printers, Apple TV as well as an amplifier that is AirPlay compatible. Sometimes the AirPlay option does not appear on my iPad. Usually, I can fix this by simply turning off the wifi option on my iPad and then turning it on again.


(Andrew Webb) #4

“All iOS and Mac devices on the network can play through the endpoint, whether they be wired or WiFi.”


(Noris) #5

Hello @Andrew_Webb,

Thanks for contacting support, I’d be happy to take a look over this issue with you. I have a few follow-up questions:

  • Can you please provide a screenshot of your Airplay section of your OSX’s Applications -> Utilities -> Audio Devices?
  • Do you by any chance have an iPhone/iPad plugged into your computer via USB when you notice this issue?
  • Have you by any chance upgraded the firmware on the Airport Tower? There have been some reports that firmware 7.8 causes issues with airplay.

Please let me know when possible.

Thanks,
Noris


(Andrew Webb) #6
  1. There is no AirPlay section in my Core’s Audio Midi Setup. There is Built-in Output and DisplayPort.
  2. Yes. An iPhone.
  3. Firmware is at 7.79

(Andrew Webb) #7

I unplugged the iPhone and it seems to be working now.
What’s up with that?


(Andrew Webb) #8

Now (over RAAT to a Mac Mini running Roon Bridge) I’m just getting the usual File is Loading Slowly errors whenever Roon feels like it’s played enough for one day. Quite possibly the worst error message in my world, as every single one of these files is available to every device on the network and streams flawlessly using any other transport. When it happens on the Core, a restart will cure it. When it happens on an iPhone X or a MacBook Pro, sometimes turning off the WiFi and making sure Roon is killed and then restarting both works, and sometimes not. If it doesn’t work right away after that, I just give up and use another transport. It’s sad that the others always work and Roon needs babying and futzing. Bums me right out.


(Noris) #9

Hello @Andrew_Webb,

Thanks for letting me know that unplugging the iPhone has resolved the issue.

We have had a previous report describing similar behavior to what you’re seeing and we’re going to do some testing as to what could be causing this issue, I will be sure to update you on our findings.

As for the “File Loading Slowly” errors you are experiencing, is there anything exotic happening on your network that would cause it to perform differently than expected? Are you by any chance using a VPN anywhere in your current setup? If you temporarily connect your affected devices directly into your router do you still experience the same behavior? Do you by any chance have a firewall active on the Mac OSX?

Please let me know when possible.

Thanks,
Noris


(Andrew Webb) #10

Nothing at all happening on the network when the File Loading errors occurred yesterday.
No VPN. (Though I’m not sure how Backblaze works; this problem has been happening since before I started using Backblaze.)
No firewall.
File Loading errors were happening running Roon on a WiFi-connected MacBook Pro, audio zone was an Ethernet-wired Mac mini running Roon Bridge.
Had the same problem this afternoon. If I start playback on an album, then let the errors happen, after skipping a few songs, Roon often catches up and starts playback A few more songs will play before it fumbles again.
The same media, accessed via any other player—even QuickLook across the network—plays back perfectly.
Same thing happened with Tidal today. Not working through Roon, worked perfectly through the Tidal app on the same machine.
I have ordered an Orbi setup, partly because I need more coverage in this house, and partly because I wonder if, as several people have said, the Airport Extreme hates Roon for some reason. Instead of sending it to expensive counseling, I’m going to ask it to leave the network and never come back. Harsh, maybe, but hey, you gots to earn your rent around here.
The Orbi should be in service by Monday evening, so don’t waste too much time thinking about what might be wrong with my current setup.
Thanks for your help, @noris . Everything they are saying about you in the Noris Appreciation Thread is true.


(Andrew Webb) #11

Update: All Apple WiFi devices are gone. Orbi network up.

Mikrotik router>Ethernet>Orbi RBK50+2 Satellites. Internal WiFi speeds of 350Mbps.
Mac Mini as above running latest Roon Bridge (or Roon, same results). Mini is now on a fixed IP.
No VPN.
No notable network activity.
No iPhones plugged in.
All devices and network parts have been restarted.
Same behavior as before. Sometimes songs play, often they don’t. They almost always play on the Core machine. They almost never play on an iPhone X.
Add that Tidal tracks often time out, even when played from the Core machine, though the same tracks play through Tidal’s app on all machines and devices perfectly.
What do you think, @noris?


(Noris) #12

Hello @Andrew_Webb,

Thanks for updating me regarding the issue.

We have previously seen reports that unchecking Disable IGMP Proxying in Orbi routers improve communication in cases like this. Can you please try changing this setting from the Router’s configuration page and let me know if this helps resolve the issue?

I would also make sure that these ports are set up for proper access on the Router & Core’s Firewall:

I look forward to hearing your findings after doing so and if you have any questions/difficulties just let me know.

Thanks,
Noris


(Andrew Webb) #13

I had already unchecked “Disable IGMP Proxying” when I set up the Orbi system.
I don’t understand why the port forwarding should be necessary. The core can see the remotes/endpoints just fine. The Mikrotik router I use is not exactly user-friendly, and port forwarding requires knowledge I do not have and cannot find clear instructions for. I cannot presently use the Orbi as a router, though that may change in the next few months.


(JNieves) #14

I had similar issues on a Linksys Velop mesh system, also in bridge mode, running off a Synology router. Same symptoms on Apple devices. Everything went away when I disabled IPv6 in the LAN. My ISP supports IPv6, my router has an IPv6 address but my LAN (and particularly my Mac mini running Roon Bridge) just didn’t like IPv6. All my Macs and AirPort endpoints were set to configure IPv6 automatically; this seemingly didn’t matter. I have never had another hiccup since I disabled IPv6 in the LAN. I hope this helps.


(Andrew Webb) #15

@Jose_R_Nieves Thank you. I’ll try that. Looks like I can set some Macs to OFF and some only to Link-Local or Automatic, so I set those to link-local.


(JNieves) #16

I did it in the router; didn’t try that way but hopefully it works.


(Andrew Webb) #17

IPv6 was already off in the router, so I doubt what I did made any difference.


(Noris) #18

Hello @Andrew_Webb,

I am curious, why you can’t use the Orbi as a Router? I ask because you have gone ahead and replaced the Apple Tower Base Station and are still running into issues, so maybe the issue lies a step back the chain and it’s due to the Mikrotik?

I have not heard of the Mikrotik router previously but I have seen similar Orbi setups work well with Roon. Would it be possible to have the Mikrotik act only as an access point in a non-listening Room and use Orbi as the Router? Since the settings for the Mikrotik are obscure and hard to configure as you mention, could it be blocking multicast from properly happening (and thus our RAAT protocol)?

Also, I just want to confirm the issue to prevent confusion on my end, I gather that the full network topology looks like this, please correct me if I am mistaken:

Mikrotik router (Ethernet) -> Orbi RBK50 (Mesh) -> 2 Orbi Satellites

Orbi RBK50 (WiFi) -> Core (Lightning) -> Library RAID Volume – [Question - What happens if you connect the Core via Ethernet?]
Orbi RBK50 (Ethernet) -> Mac Mini Roon Bridge (USB?) -> Endpoint?

One of the Orbi satellites (Ethernet) -> Airport Express -> Amplifier + Speakers
Same Orbi satellite (WiFI) -> iPhone X (Lightning) -> Apple Headphones?

You are having issues with the:

  • Core sometimes not playing both TIDAL content and Local Content in Roon
  • The Mac Mini (running Roon Bridge) sometimes not playing both TIDAL and Local Content in Roon
  • The iPhone X often not playing TIDAL content and Local Content in Roon

If this issue is not affecting local content I would have suggested taking a look at DNS but since both Local and TIDAL here seems affected, I believe the issue most likely lies with the Mikrotik as it’s the one thing in the system you haven’t changed yet.

Either that or there is a firewall located on the Core somewhere that you’re not aware of, I would check to see if you by any chance are using the app “Little Snitch” as I have also seen reports of this app preventing Roon from operating properly.

Please let me know your thoughts regarding my suggestions.

Thanks,
Noris


(Andrew Webb) #19

The network isn’t as you’ve described. It’s like this:

Mikrotik Router (no WiFi)
>Ethernet>Core
>Ethernet>Orbi RBK50 Main Unit
>Ethernet>2009 Mac Pro (was Mac mini) running Roon Bridge>Amp>Speakers
>Ethernet>Airport Express (no WiFi)>Amp>Speakers
>Ethernet>Airport Express 2 (no WiFi>Amp>Speakers
Orbi RBK50 WiFi (in Access Point Mode)
>2 Orbi Satellites
>iPhones
>MacBook Pro
>iPad
>Mac Mini2

Control is from MacBook Pro on Orbi WiFi

I can’t delete the Mikrotik because the house is being renovated and the Mikrotik is in a metal box in the basement, where it is safe from dust and workmen. The Orbi would not work there. The Mikrotik is in its stock configuration. The Mikrotik is not particularly exotic in networking circles, but few consumers use them.

I had the same problem when I was using an all-Airport network at another location, and using a Netgear Nighthawk at yet another location; that was before the Mikrotik.


(Noris) #20

Hello @Andrew_Webb,

Thanks for clarifying your network topology for me. Since your Core is currently connected to the Mikrotik router and you can’t change that piece of the setup, does the same behavior occur when you connect the Core to the Orbi RBK50 main unit? Also, if you try using another machine as the core such as your Mac Pro running Roon bridge do you experience the same behavior? Please let me know your results when possible.

Thanks,
Noris


(Tibor Kovacs) #21

Same happened to me. First the music stopped playing. After roon upgraded itself even the Marantz available receiver disappeared. Mikrotik router. Tried to set UDP ports, etc no help. Very annoying. I am able to play music via Tidal, Plex though… I think Roon needs to fix this otherwise this great product will be useless.