Roon Suddenly Not Playing to AirPlay Device (Firmware 7.6.9)


(Andrew Webb) #22

I can’t connect the current Core directly to the RBK50.
The Mikrotik is in the basement, as are all of the starting points of the Ethernet wiring. Everything is wired home-run style, no point-to-point.
I can & will set up a Core on the old Mac Pro (the one running Bridge); I’ll have to give it a temporary library to work with, as I can’t move the RAID—speaking of which, the current Core is drawing from ~200,000 tracks (~4TB). IS that load too heavy for Roon?


(Noris) #23

Hello @Andrew_Webb,

Thanks for letting me know your reply to my questions. I agree, setting up the old Macbook Pro will help us eliminate some possible causes for this behavior. While testing the Macbook Pro setup, I would avoid adding more than a few hundred tracks just to test to see if you have the same issue as before. For your question regarding the track load on the Core, Brian discusses the recommended number of tracks & specs a bit here. Please let me know your results with the Macbook Pro when possible.

Thanks,
Noris


(Chris Lischy) #25

Completely agree on this. Tired of screwing around with Roon to work WiFi/Mac Mini/Airplay. Not spending a mortgage payment on a Roon Nucleus, etc. Should be as easy as any streaming service and it’s not there yet. Just want to push play with out the skipping, drops and seizures. My MM has nothing running but Roon and airplay devices disappear, reappear or won’t play. Reboot and fine for a while but always at the wrong time.


(Tony Reimann) #26

Seems to me that many of those having issues like this are devotees of the Apple ecosystem. I have been running trouble free for several years and I don’t own a nucleus. The server running Rock and all endpoints are on a 1000baseT network. The only piece of Apple gear in use is an old iPad Air which is connected via WiFi and used as a remote. Like you say I just press play and everything works, every day, every time.


(Tibor Kovacs) #27

I can only support your views. Roon is rather expensive to be a black box. I have now idea why Airplay suddenly disappeared. I have opened firewalls for the UDP ports 9001-9003 or so… The documentation is very poor, there is no information on what is connected, what is not and why. Although Roon is a great concept, I must afraid, I wont extend my subscription as I cannot use / enjoy it.


(Mike) #28

Hey @Tibor_Kovacs – the issues in this thread are almost certainly related to the environment, and we have 10s of thousands of users running Airplay devices without issue.

If something isn’t stable for you, I’m absolutely confident we can get your setup rock solid with some more details in a new thread, as described here.

We’ve been investigating the Marantz issue, and all signs point to this being related to a firmware update on the Marantz side – from what we can tell, this device simply no longer supports Airplay 1. Nothing has changed on Roon’s side, and for the moment we have not made any comments regarding Airplay 2 support in Roon.

Anyway, if you’re having issues, we’d love to help so please let us know!


(Andrew Webb) #30

Update 20181201: Power went out at the house, for about three hours. When everything came back up, Roon works as advertised 100% of the time, going on 2 whole weeks now. I have no idea why.


Why aren't all your friends using Roon?
(Andrew Webb) #31

Update 2019-01-17

No Apple networking gear, only Mikrotik and Orbi. Roon doesn’t play to WiFi devices, though I can control Roon from those devices, and I can play the exact same files via any other media player that can read the network (Jriver, Plex, iTunes) on the same WiFi devices. So frustrating. Control Roon with my iPhone? Great. Playback to phone? NO. NO. NO. I even tried a freshly erased iPhone 6 with no other apps other than Roon. Again, it can control but not play. That suggests that something is awry with the app on the iPhone, doesn’t it?
I love Roon when I’m sitting there with my laptop reading interesting stuff and surfings my library, full-size stereo sounding sweet. I hate Roon when I’m working late at night and want to run it locally off my phone. I don’t understand why it can’t just play the damn music like literally every other music player I have. Infuriating.


(Anders Vinberg) #32

I do both.

At the moment, I’m playing to my main headphone rig over WiFi.

And tonight I will play on headphones plugged into my iPad.


(Andrew Webb) #33

I wish I could do that.


(Anders Vinberg) #34
  1. Playing directly on iPad or iPhone, with headphones plugged in directly: go to Settings, Audio, and enable the iDevice. It works in every form: if you hav3 nothing plugged in, it will play over the iPad speakers. I usually plug in Audeze headphones which use a Lightning connector. For really high quality sound, high res or DSD, I use an Apple USD connector dongle, and plug a usb cable into a Chord Hugo 2 and plug high end headphones in there.

  2. For playback over WiFi to a non-wifi capable devices, I use a WiFi connection node (mostly Eero these days, but I have used others), and connect an Ethernet cable to a streamer (Meridian or Sonore) and then to the DAC.

In all cases, the zone must be Enabled in Roon (although Roon recognizes the MicroRendu so I don’t have to do it again).

Also note that by default, the iDevice is set up as a Private device, so you can control it only from that same device. If you want to control music playback on the iPhone from another device like a laptop, just uncheck the Private setting.

(This means that an old iPhone or iPad is a very inexpensive WiFi endpoint.)

Is there anything of this that doesn’t work for you?


(Andrew Webb) #35

Roon can see the iPhones, but refuses to play to them. “An audio file is loading slowly. This may indicate…”

So yeah, the whole “playing music through my iPhone” part doesn’t work for me.


(Anders Vinberg) #36

Ah, when you describe your problem, we can see this is about troubleshooting, not that you don’t know how to set it up. So my post was wasted.

No idea why it doesn’t work in your system.
Troubleshooting.


(Andrew Webb) #37

Not wasted, Anders. It gave me hope that someday, I too will enjoy using Roon on my phone. I had lost faith; I had fallen into a pit of despair; I had become overwhelmed with anger and sadness. Now I once again see a glimmer of possibility, a faint flickering in the far distant darkness. I have put away my razor and my rope and am quietly humming my favorite tunes to myself, in lieu of using Roon… for now.


#38

Most likely user error. Take deep breath. Relax. Fgure out what’s wrong. Troubleshoot


(Andrew Webb) #39

Troubleshooting is my least favorite activity, and I resent being forced into it by faulty software. If all the other methods of playback work, then the fault is with Roon, and that’s a bummer. Playback is the number one priority.


(Andrew Webb) #40

It’s not user error, though. Every other form of local-network streaming works. Playback to wired endpoints works. Zones are enabled, nothing is private. If Roon won’t play to a freshly-set-up phone that appears in the Roon Audio Settings as a playable zone, how can it be that I’m doing something wrong? All I gotta do is press “play”…


(Tim) #41

@Andrew_Webb,

Since you mentioned you are using an Orbi router you might want to check Advanced / WAN Setup and make sure Disable IGMP Proxying is checked.

Orbi%20Advanced%20WAN%20Setup

Tim


(Andrew Webb) #42

Did it when I set it up, per instructions here on the Forum, but thank you.

I’ve been trying to get this fixed for a long time. I’ve read a lot, I’ve tried many things, I’ve talked to Support. It should work, but it doesn’t. (I’m not discouraging suggestions!)


(Tim) #43

Unfortunately I don’t play music to my phone nor do I use Apple products so I’m out of ideas.

Hope you get it working … Tim