Roon Suddenly Not Playing to AirPlay Device (Firmware 7.6.9)


(Mike O'Neill) #44

Bit late in here, what you want is doable

Maybe Post a screen shot of your iPhone Roon app

Settings> Audio

The iPad in my case is top of the list “connected to this tablet”

Do yo see that ?
Is the button to the right saying Enable , it should show a text box if it’s active eg Mike’s ipad


(Mikael Ollars) #45

Why not start a thread in the Support forum instead?
This thread is hardly the place for setup issues.
And, i bet my right hand you have network configuration issues, not Roon issues. :slight_smile:


(Tim Rhodes) #46

I agree this sounds like a network/wifi config issue rather than a Roon issue. The fact everything else works for you sort of confirms it to be honest, if there was a Roon issue I’d expect other problems in your setup.

Could it be due to your wired and wifi networks being on different IP subnets? Is there a firewall/router/switch between the wired and wifi networks that is causing a problem? I had to turn off IGMP on a managed swtich in my LAN to get Roon to work smoothly for instance.

You should really raise this in the support forum, I’d be very surprised if it cant be fixed. Most users have no issue playing through their iOS devices myself included.


(Daniel Beyer) #47

Hey guys, these posts really belong in the support section so that Andrew can get support to take a look. @support.


#48

So all the history is in one place … I’ve merged all the related posts I could find into the original support topic.


(Mike) #49

So are you actually using the Orbi to administer the network now, or is the Microtik router still in the mix? I can see in our internal records for this issue that our engineers suspected that router might be related.

At a minimum, if you’re using a laptop for a Core, it might be interesting to bring the laptop + iPhone to a friend’s or neighbors and see if that makes any difference.

Obviously, Macbook Core and iPhone is a pretty common setup for our users, so I’m suggesting you focus on the network/router because that’s most likely to be the thing in your environment that’s different from other users running the same kind of setup without issue. Other possibilities could be networking settings on the laptop (or phone), or something on the phone that’s interfering with the audio output. Since you tried 2 phones, I have my doubts about that last one.

Also, just to be clear, what shows up in Settings > Audio on the phone – do you see the iPhone there at all?


(Andrew Webb) #50

Still using the Microtik as the router. Orbing is just serving up WiFi. House still being renovated; I’ll take the Mikrotik out as soon as I can.
Not using a MacBook for a core. Mac Pro, Ethernet.
Yes, I can see the iPhone(s) from the Core in Audio Settings. All running the latest OS. (BTW, MacBooks on the network can be seen by the core and can be designated as endpoints, but get the same error and the Phones. Anything hardwired works fine.

@Tim_Rhodes said, and that confuses me. If everything except Roon works, why would one think that it’s not Roon?


(Andrew Webb) #51

Now I’m using just the Orbi. Network is:

Nextlight Fiber>Fiber-to-copper converter>Orbi Router>Ethernet to Core
WiFi to 2 Orbi Satellites, backhaul via Ethernet on one of them.

Hardwired endpoints work, wireless ones don’t. Same deal as before. Once in a while, I can play a song over the iPhone, but usually I just get the “File Loading Slowly” error.

It doesn’t seem to matter if the WiFi on the Core is turned on or off.


(Noris) #52

Hello @Andrew_Webb,

Thanks for trying the Orbi setup directly. Can you please let me know the model/manufacturer of the Fiber-to-Copper converter that you are making use of?

Also, I can confirm that the newest diagnostics from your Core have reached our servers and I am seeing some critical network traces present, this still appears that it’s still a networking issue to me I have asked QA to take a look

Would it be possible for you to bring your Laptop and iOS device to a friend’s house and verify if the same issue still exists on another network? This would be a really good data point to have and will give us a clue where to look further to troubleshoot.

Thanks,
Noris


(Andrew Webb) #53

Hi Noris,

The Fiber-to-copper box is a Calix Gigapoint 801G. It is the box that converts the fiber signal into an Ethernet signal. It doesn’t belong to me, it’s property of Nextlight, the Fiber Internet provider.

The Core is not running on my laptop, it’s running on a Mac Pro, not a MacBook Pro. And no, I can’t take the Core machine out of service.


(Daniel Beyer) #54

Are you running other processes/software on the machine?


(Andrew Webb) #55

Yes.
However, the same problem occurred when the core was on another machine with nothing else running. It has happened across four different network scenarios and two Core machines in two different houses. Different media storage, too.


(Noris) #56

Hello @Andrew_Webb,

We just released Roon Version 1.6 which contains some improvements to network streaming. Can you please update your Core and Roon Remote to the latest builds and let me know if the issue still occurs afterwards?

Thanks,
Noris


(Andrew Webb) #57

Yes, I’ll do that.


(Noris) #58

Hello @Andrew_Webb,

I just wanted to check in with you here, has there been any change since installing Roon 1.6? Are things working better than previously?

Thanks,
Noris


(Andrew Webb) #59

Yes, I have updated Roon on all devices, and restarted all of them.
No, it’s not working any differently.

I did get it to play through my iPhone X for about three songs, though! Guess it was a fluke.

Wi-Fi attaches devices do not work, wired ones do.


(Mike) #60

Thanks for working with us on this @Andrew_Webb – I know this troubleshooting has gone on longer than we’d like.

So, I’m still focused on the network here, since if there was a problem with your Core or storage, I don’t think this would be the case:

Since the issue only happens with wifi involved, I think we want to continue troubleshooting in that direction.

Is this still the setup you’re running? Are all devices running DHCP? And addresses are being given out by the Orbi?

Assuming I have that right, I think it would make sense to try running with the Core, the Orbi, and the Airplay devices – turn the satellites off completely.

Also, is the Orbi running the latest firmware? I know this is annoying, but have you tried resetting the Orbi to stock settings? We’ve had issues like this in the past where weeks of troubleshooting came down to an option someone checked off during setup, so it might be worth trying this with 100% “vanilla” settings, to see if that yields any change.

Thanks again for your patience here Andrew – looking forward to getting this resolved for you soon!


(Andrew Webb) #61

@mike
Thanks for sticking with me, too!

Yes, all running DHCP, all addresses being given out by the Orbi.
Yes that’s still the correct network info.
Orbi firmware is up to date on all three devices.
I’ll try taking the satellites out of the network. If that doesn’t help, I’ll reset everything and re-configure the network.

Why is it that Roon is so sensitive? Literally every other software product I have works fine across this same network—I can even read the contents of the iPhones from the wired computers. Screen sharing, file sharing, remote screen software, many other music players… Rogue Ameoba’s Airfoil can even deliver and sync music to all of these devices at the same time. (I do turn all this stuff off when trying to get Roon to work.) I’m really curious about this aspect of Roon.