Roon Suddenly Not Playing to AirPlay Device (Firmware 7.6.9)

Hello @Andrew_Webb,

I am curious, why you can’t use the Orbi as a Router? I ask because you have gone ahead and replaced the Apple Tower Base Station and are still running into issues, so maybe the issue lies a step back the chain and it’s due to the Mikrotik?

I have not heard of the Mikrotik router previously but I have seen similar Orbi setups work well with Roon. Would it be possible to have the Mikrotik act only as an access point in a non-listening Room and use Orbi as the Router? Since the settings for the Mikrotik are obscure and hard to configure as you mention, could it be blocking multicast from properly happening (and thus our RAAT protocol)?

Also, I just want to confirm the issue to prevent confusion on my end, I gather that the full network topology looks like this, please correct me if I am mistaken:

Mikrotik router (Ethernet) -> Orbi RBK50 (Mesh) -> 2 Orbi Satellites

Orbi RBK50 (WiFi) -> Core (Lightning) -> Library RAID Volume – [Question - What happens if you connect the Core via Ethernet?]
Orbi RBK50 (Ethernet) -> Mac Mini Roon Bridge (USB?) -> Endpoint?

One of the Orbi satellites (Ethernet) -> Airport Express -> Amplifier + Speakers
Same Orbi satellite (WiFI) -> iPhone X (Lightning) -> Apple Headphones?

You are having issues with the:

  • Core sometimes not playing both TIDAL content and Local Content in Roon
  • The Mac Mini (running Roon Bridge) sometimes not playing both TIDAL and Local Content in Roon
  • The iPhone X often not playing TIDAL content and Local Content in Roon

If this issue is not affecting local content I would have suggested taking a look at DNS but since both Local and TIDAL here seems affected, I believe the issue most likely lies with the Mikrotik as it’s the one thing in the system you haven’t changed yet.

Either that or there is a firewall located on the Core somewhere that you’re not aware of, I would check to see if you by any chance are using the app “Little Snitch” as I have also seen reports of this app preventing Roon from operating properly.

Please let me know your thoughts regarding my suggestions.

Thanks,
Noris

The network isn’t as you’ve described. It’s like this:

Mikrotik Router (no WiFi)
>Ethernet>Core
>Ethernet>Orbi RBK50 Main Unit
>Ethernet>2009 Mac Pro (was Mac mini) running Roon Bridge>Amp>Speakers
>Ethernet>Airport Express (no WiFi)>Amp>Speakers
>Ethernet>Airport Express 2 (no WiFi>Amp>Speakers
Orbi RBK50 WiFi (in Access Point Mode)
>2 Orbi Satellites
>iPhones
>MacBook Pro
>iPad
>Mac Mini2

Control is from MacBook Pro on Orbi WiFi

I can’t delete the Mikrotik because the house is being renovated and the Mikrotik is in a metal box in the basement, where it is safe from dust and workmen. The Orbi would not work there. The Mikrotik is in its stock configuration. The Mikrotik is not particularly exotic in networking circles, but few consumers use them.

I had the same problem when I was using an all-Airport network at another location, and using a Netgear Nighthawk at yet another location; that was before the Mikrotik.

Hello @Andrew_Webb,

Thanks for clarifying your network topology for me. Since your Core is currently connected to the Mikrotik router and you can’t change that piece of the setup, does the same behavior occur when you connect the Core to the Orbi RBK50 main unit? Also, if you try using another machine as the core such as your Mac Pro running Roon bridge do you experience the same behavior? Please let me know your results when possible.

Thanks,
Noris

Same happened to me. First the music stopped playing. After roon upgraded itself even the Marantz available receiver disappeared. Mikrotik router. Tried to set UDP ports, etc no help. Very annoying. I am able to play music via Tidal, Plex though… I think Roon needs to fix this otherwise this great product will be useless.

1 Like

I can’t connect the current Core directly to the RBK50.
The Mikrotik is in the basement, as are all of the starting points of the Ethernet wiring. Everything is wired home-run style, no point-to-point.
I can & will set up a Core on the old Mac Pro (the one running Bridge); I’ll have to give it a temporary library to work with, as I can’t move the RAID—speaking of which, the current Core is drawing from ~200,000 tracks (~4TB). IS that load too heavy for Roon?

Hello @Andrew_Webb,

Thanks for letting me know your reply to my questions. I agree, setting up the old Macbook Pro will help us eliminate some possible causes for this behavior. While testing the Macbook Pro setup, I would avoid adding more than a few hundred tracks just to test to see if you have the same issue as before. For your question regarding the track load on the Core, Brian discusses the recommended number of tracks & specs a bit here. Please let me know your results with the Macbook Pro when possible.

Thanks,
Noris

Completely agree on this. Tired of screwing around with Roon to work WiFi/Mac Mini/Airplay. Not spending a mortgage payment on a Roon Nucleus, etc. Should be as easy as any streaming service and it’s not there yet. Just want to push play with out the skipping, drops and seizures. My MM has nothing running but Roon and airplay devices disappear, reappear or won’t play. Reboot and fine for a while but always at the wrong time.

Seems to me that many of those having issues like this are devotees of the Apple ecosystem. I have been running trouble free for several years and I don’t own a nucleus. The server running Rock and all endpoints are on a 1000baseT network. The only piece of Apple gear in use is an old iPad Air which is connected via WiFi and used as a remote. Like you say I just press play and everything works, every day, every time.

1 Like

I can only support your views. Roon is rather expensive to be a black box. I have now idea why Airplay suddenly disappeared. I have opened firewalls for the UDP ports 9001-9003 or so… The documentation is very poor, there is no information on what is connected, what is not and why. Although Roon is a great concept, I must afraid, I wont extend my subscription as I cannot use / enjoy it.

Hey @Tibor_Kovacs – the issues in this thread are almost certainly related to the environment, and we have 10s of thousands of users running Airplay devices without issue.

If something isn’t stable for you, I’m absolutely confident we can get your setup rock solid with some more details in a new thread, as described here.

We’ve been investigating the Marantz issue, and all signs point to this being related to a firmware update on the Marantz side – from what we can tell, this device simply no longer supports Airplay 1. Nothing has changed on Roon’s side, and for the moment we have not made any comments regarding Airplay 2 support in Roon.

Anyway, if you’re having issues, we’d love to help so please let us know!

Update 20181201: Power went out at the house, for about three hours. When everything came back up, Roon works as advertised 100% of the time, going on 2 whole weeks now. I have no idea why.

Update 2019-01-17

No Apple networking gear, only Mikrotik and Orbi. Roon doesn’t play to WiFi devices, though I can control Roon from those devices, and I can play the exact same files via any other media player that can read the network (Jriver, Plex, iTunes) on the same WiFi devices. So frustrating. Control Roon with my iPhone? Great. Playback to phone? NO. NO. NO. I even tried a freshly erased iPhone 6 with no other apps other than Roon. Again, it can control but not play. That suggests that something is awry with the app on the iPhone, doesn’t it?
I love Roon when I’m sitting there with my laptop reading interesting stuff and surfings my library, full-size stereo sounding sweet. I hate Roon when I’m working late at night and want to run it locally off my phone. I don’t understand why it can’t just play the damn music like literally every other music player I have. Infuriating.

I do both.

At the moment, I’m playing to my main headphone rig over WiFi.

And tonight I will play on headphones plugged into my iPad.

I wish I could do that.

  1. Playing directly on iPad or iPhone, with headphones plugged in directly: go to Settings, Audio, and enable the iDevice. It works in every form: if you hav3 nothing plugged in, it will play over the iPad speakers. I usually plug in Audeze headphones which use a Lightning connector. For really high quality sound, high res or DSD, I use an Apple USD connector dongle, and plug a usb cable into a Chord Hugo 2 and plug high end headphones in there.

  2. For playback over WiFi to a non-wifi capable devices, I use a WiFi connection node (mostly Eero these days, but I have used others), and connect an Ethernet cable to a streamer (Meridian or Sonore) and then to the DAC.

In all cases, the zone must be Enabled in Roon (although Roon recognizes the MicroRendu so I don’t have to do it again).

Also note that by default, the iDevice is set up as a Private device, so you can control it only from that same device. If you want to control music playback on the iPhone from another device like a laptop, just uncheck the Private setting.

(This means that an old iPhone or iPad is a very inexpensive WiFi endpoint.)

Is there anything of this that doesn’t work for you?

Roon can see the iPhones, but refuses to play to them. “An audio file is loading slowly. This may indicate…”

So yeah, the whole “playing music through my iPhone” part doesn’t work for me.

Ah, when you describe your problem, we can see this is about troubleshooting, not that you don’t know how to set it up. So my post was wasted.

No idea why it doesn’t work in your system.
Troubleshooting.

Not wasted, Anders. It gave me hope that someday, I too will enjoy using Roon on my phone. I had lost faith; I had fallen into a pit of despair; I had become overwhelmed with anger and sadness. Now I once again see a glimmer of possibility, a faint flickering in the far distant darkness. I have put away my razor and my rope and am quietly humming my favorite tunes to myself, in lieu of using Roon… for now.

3 Likes

Most likely user error. Take deep breath. Relax. Fgure out what’s wrong. Troubleshoot

Troubleshooting is my least favorite activity, and I resent being forced into it by faulty software. If all the other methods of playback work, then the fault is with Roon, and that’s a bummer. Playback is the number one priority.