Roon suddenly unable to identify new music

Roon Core Machine

Windows 10; all updates applied
Roon runs on this PC and all music is on USB-connected external drives
Roon is the latest 1.8 build

Networking Gear & Setup Details

Ethernet connection to router; have also tried USB connection to mobile phone. Same result

Connected Audio Devices

Not relevant to this issue

Number of Tracks in Library

58,283

Description of Issue

I completed a restore from a backup. I have not used Roon for some time and so I elected to add the new music since the backup bit by bit. My music is organized at the highest level by type: Spoken word and audio books, blues, classical, jazz, popular. I completed the addition of spoken word, blues and jazz without an issue and added about 5,000 tracks. However, on adding the classical stuff Roon has got stuck. The spinning wheel keeps spinning and the message is ‘Adding music to library: Of 10116 tracks, 10116 added, 0 identified’

There was no change to the setup between finishing adding classical to starting to add jazz.

Any suggestions where I should look in the logs to try to find out what’s failing? I assume it’s some sort of internet issue and Roon can’t connect to HQ so as well as my normal router I’ve tried connecting via my mobile phone: no difference. I should also add that no other applications (Plex, Backblaze, Google Drive etc.) are experiencing any internet connection issues.

I should add a couple of other clues. From the Roon App I am able to access my Account Information but I am not able to update my profile. When I tried to add my correct birthdate to my profile I got ‘Please check your connection’. And I can log in successfully obviously, so some functions have no issue with the connection and some do.

Have you done basic troubleshooting like rebooting everything from the network outward?

Yes. Restarted computer, restarted router, switched to different internet connection. No effect.

I can see in the logs that it is unable to connect to the network. Not sure what the next step is when one flakey piece of software has an issue that no other app is experiencing. This whole thing is only coming about because in doing a restore I had to go back a LONG way to find a working backup because Roon has happily been completing backups of a corrupt database for a while. Right now I’m not impressed with this thing.

This has been prevented since the release in December 2021 of build 880 of Roon. Have you ensured that your Roon installations (Core and remotes) are fully up to date?

I’m running the latest release now but I don’t know what release was running when the backups were taken in June and April. I have had very little access to the computer that runs Roon this year for various personal reasons I don’t need to go into but I have it now. When I started it this time it clearly did an update because I got the message about the latest version needing a database update. The first time I restarted I just let all the new music from two different external hard drives be applied at once and it failed. I then tried the restores. The June backups didn’t work but the April one (the earliest I have saved) did and I applied the new music one type at a time. Now I’ve hit the network issue.

It’s good to know that the database backup issue has been addressed.

Out of interest why do you back up so infrequently ? BU is designed for exactly this problem but not if you haven’t got a recent BU

I BU Daily …

Because I’ve had very infrequent physical access to the machine that runs Roon since late last year. Spends most of its time powered down.

Hey @Michael_Mill,

Ben here with the support team, it’s great to see you on community again! I’m sorry to hear you’re running into issues loading some new music into your account.

In the past, we’ve seen this sometimes happen when a few corrupt files hit a snag in the upload process, and cause everything else to come to a halt.

As a test for this, would you be able to potentially split up the remaining tracks into smaller subsets, and attempt to upload a handful of the small subsets? I’d be curious to see if your issue persists with this.

I’ll be monitoring this thread for your reply :+1: