"Roon Tested" device not listed as Audio Device (nothing)

As I mentioned above, I have rebooted everything recently.
Ropiee has been updated and rebooted today.
Roon has been rebooted today.
Denon has not been hard booted today but has been and has yet to make a difference.

My wife play spotify to the Denon via Airplay.
I can play podcasts from mt iphone through the Denon via Airplay.
My mac will allow my to select the Denon as audio device. (The mac, not roon)
Open iTunes on my phone and play the free U2 track, I can choose the Denon via Airplay.
I open Tidal on my phone and can choose the Denon as the audio device.
The only thing I cannot do use use Roon with the Denon in ANY WAY, SHAPE, or FORM.

Just rebooted Roon. Squeezebox thing went away; nothing else changed.

1 Like

As of your system description, it seems that the Denon is the only device connected to your Netgear switch. If I were you, I would try to bypass the switch and directly connect the Denon to the router temporarily to see if then shows up in Roon (move it around if necessary – no need to connect speakers for that).

I tried that weeks ago, before I installed it in a difficult to reach cabinet with air filters and cooling. Basically, about 30 minutes crawling, opening a cabinet, disconnecting 10-15 wires, crawling out with it, etc etc.

Yes, it is the only item connected to the netgear, however, I was using it with WiFi prior to installation and had the same issues.

What I can easily do is disconnect the port on the netgear and set it up to use WiFi again.

Disconnected from Netgear and now on Wifi.

The only change is now my Macbook is listed as a device and it is somehow related to “Built-In-Audio Core Output”.

As has always been the case, I am able to select the Denon from my list of playback options on my Mac.

Screen Shot 2020-06-08 at 4.51.27 PM

Thank you for testing this and providing all these additional data-points. I think it’s now up to official support to further help you make use of the advertised “Roon Tested” AirPlay support.

This is just weird.
Ultimately, aggrivating.
I started looking at another raspberry Pi to use with the denon and got a little pissed off; this thing is supposed to work with Roon and apparently does not. Why am I going to spend an extra $100+ on something when the Denon/Roon combination should have worked in the first place.

I checked with Denon and I had already covered everything they would suggest.
I am now here hoping it can get figured out.

Everything has the latest firmware - Asus, Denon, Ropiee, Roon, NAD, Netgear - all of it checked today prior to opening this thread.

People without extensive A/V component experience, please stop pointing to USB. AVRs with USB-B that can accept direct connections from computers (hence Roon) are rarer than hen’s teeth. USB-A on nearly every A/V component is for cellphone or storage connection only.

USB is irrelevant to Roon in this case. Rather, this is an AirPlay networking issue, maybe due to different subnets.

AJ

I wrote my first comment about USB in an update – after I visited the product page from Denon where they wrote about “USB audio” support. If this means in fact that the device only reads the music stored on an iDevice then I’m deeply sorry pointing in that direction. Maybe the manufacturers should make it more clear then what they actually support with their devices.

I’m a network engineer and can assure you these are not on different subnets.
I have enough complexity in my work life, home network is quite simple.

Can it be that some software on your NAS (other media server software and the like) is using port(s) that are needed for AirPlay and thus prevent Roon from seeing AirPlay devices on the network?

If you have another AirPlay device like an Apple TV you could certainly test this hypothesis.

I empathise with Dale. here is what I see in my setup:

  1. Roon core on Windows 10 Acer desktop
    2.Everything else on AT&T fiber giga wifi: Bluesound node and Flex speakers show as roon ready / Apple TV shows as roon tested / Yamaha AVR and Yamaha wifi speakers as ‘other’ devices via airplay / Vizio TV as roon tested via cromecast
    All these wifi devices spread between two floors have stayed connected without any trouble

Does this help in any way?

Ultimately, everything I have works as it should minus the Denon which is supposedly Roon tested, whatever that is supposed to mean, as acknowledged by both Roon and Denon.

It is also interesting only one Roon support tech has responded to this thread.

I have the sinking feeling I am on my own; Denon had nothing to offer and so far neither does Roon.

It’s not that there are dozens of them. In Roon go to Settings|About and click on “The Team” to see how few people are actually making up Roon Labs.

As many other users seem to use Roon’s AirPlay support without problems and your Denon seems to work with others of your AirPlay devices without problems, there is a good chance that something specific to your setup is what gives you problems.

I’m sure that Roon support will come back to you, trying to help you resolve that problem.

For what it’s worth, I may have another data point in 48 hours. I just ordered (being delivered today) the exact same Denon 1600H receiver for the exact same reason (second system in Home office and streaming Roon from a NAS+NUC located elsewhere in the house). We’ll see if I fare any better or I shall join the ranks of the disappointed :slight_smile:

Also as a separate data point, I activated my AV receiver as a Roon endpoint via Airplay. This is a Pioneer SC2024, at least 4 years old and Roon ‘sees’ it as soon as I turn it (the Pioneer) on. Enabling took 1 click. This same behavior is what I expect from the Denon, which is 4 years younger. Stay tuned :slight_smile:

A couple of points to consider (while we’re waiting for Roon Support):

  • Your Core is on a Synology, I notice that someone else running Roon on a Synology had trouble with Roon not seeing the Denon:

It wouldn’t work with WiFi, he had to have a wired ethernet connection. Which leads to the second point:

You can try a few things temporarily to diagnose (one at a time, obviously):

  • replace the managed switch with an unmanaged switch temporarily.
  • connect the Denon directly to the router (and remove the managed switch for surety)
  • Install full Roon on your Mac, and use the Core there to test whether it will see the Denon via the managed switch.
2 Likes

Hi @Dale_Murray,

Do you have another machine that you can temporarily use as your Core? Does this device show up when using that machine as your Core?

That result would certainly suggest the fault lies with the Denon.

I did not know what a “Core” was until 30 seconds ago.

Installed on extra laptop.
Immediately shows

  • Allo Boss DAC ALSA This is actually the RoPiee known as FamilyRoom
  • NAD C658 (Uncertified) < who is responsible for getting that certified, BTW?
  • Denon AVR-x1600H via Airplay, 192.168.1.71 < Denon using WiFi connection
  • FamilyRoom RoPieeeXL via Airplay, 192.168.1.31
  • NAD (C658) via AirPlay, 192.168.1.30

I guess anything “Airplay” does not show up when the “core” is running on the Synology?

Quick Update
I just connected the Denon via ethernet and it is still connected but with new IP as expected.
Denon AVR-x1600H via Airplay, 192.168.1.69 < Denon using Ethernet connection.

So the netgear is not an issue.