"Roon Tested" device not listed as Audio Device (nothing)

If you have another AirPlay device like an Apple TV you could certainly test this hypothesis.

I empathise with Dale. here is what I see in my setup:

  1. Roon core on Windows 10 Acer desktop
    2.Everything else on AT&T fiber giga wifi: Bluesound node and Flex speakers show as roon ready / Apple TV shows as roon tested / Yamaha AVR and Yamaha wifi speakers as ‘other’ devices via airplay / Vizio TV as roon tested via cromecast
    All these wifi devices spread between two floors have stayed connected without any trouble

Does this help in any way?

Ultimately, everything I have works as it should minus the Denon which is supposedly Roon tested, whatever that is supposed to mean, as acknowledged by both Roon and Denon.

It is also interesting only one Roon support tech has responded to this thread.

I have the sinking feeling I am on my own; Denon had nothing to offer and so far neither does Roon.

It’s not that there are dozens of them. In Roon go to Settings|About and click on “The Team” to see how few people are actually making up Roon Labs.

As many other users seem to use Roon’s AirPlay support without problems and your Denon seems to work with others of your AirPlay devices without problems, there is a good chance that something specific to your setup is what gives you problems.

I’m sure that Roon support will come back to you, trying to help you resolve that problem.

For what it’s worth, I may have another data point in 48 hours. I just ordered (being delivered today) the exact same Denon 1600H receiver for the exact same reason (second system in Home office and streaming Roon from a NAS+NUC located elsewhere in the house). We’ll see if I fare any better or I shall join the ranks of the disappointed :slight_smile:

Also as a separate data point, I activated my AV receiver as a Roon endpoint via Airplay. This is a Pioneer SC2024, at least 4 years old and Roon ‘sees’ it as soon as I turn it (the Pioneer) on. Enabling took 1 click. This same behavior is what I expect from the Denon, which is 4 years younger. Stay tuned :slight_smile:

A couple of points to consider (while we’re waiting for Roon Support):

  • Your Core is on a Synology, I notice that someone else running Roon on a Synology had trouble with Roon not seeing the Denon:

It wouldn’t work with WiFi, he had to have a wired ethernet connection. Which leads to the second point:

You can try a few things temporarily to diagnose (one at a time, obviously):

  • replace the managed switch with an unmanaged switch temporarily.
  • connect the Denon directly to the router (and remove the managed switch for surety)
  • Install full Roon on your Mac, and use the Core there to test whether it will see the Denon via the managed switch.

Hi @Dale_Murray,

Do you have another machine that you can temporarily use as your Core? Does this device show up when using that machine as your Core?

That result would certainly suggest the fault lies with the Denon.

I did not know what a “Core” was until 30 seconds ago.

Installed on extra laptop.
Immediately shows

  • Allo Boss DAC ALSA This is actually the RoPiee known as FamilyRoom
  • NAD C658 (Uncertified) < who is responsible for getting that certified, BTW?
  • Denon AVR-x1600H via Airplay, < Denon using WiFi connection
  • FamilyRoom RoPieeeXL via Airplay,
  • NAD (C658) via AirPlay,

I guess anything “Airplay” does not show up when the “core” is running on the Synology?

Quick Update
I just connected the Denon via ethernet and it is still connected but with new IP as expected.
Denon AVR-x1600H via Airplay, < Denon using Ethernet connection.

So the netgear is not an issue.

I just got my Denon. It will be set up tomorrow morning and I will know quickly.
My setup is also Roon ROCK on NUC, with music library on Synology NAS. If the issue is with Synology, I should not have the problem. I’ll be back :slight_smile:

Hi @Dale_Murray,

Thanks for running that test. This certainly helps to understand the issue.

Since no Airplay devices are showing under the Synology Core at all, this almost certainly points to something about the Synology blocking Airplay communication. I mentioned Open vSwitch previously — this is a common setting that can result in this type of issue. I’d recommend looking into firewall settings or anything else that could disrupt network traffic.

Way ahead of you.

  • no vSwitch

    • I uninstalled virtual machine manager too, just to be extra thorough
  • Firewall is not enabled on Synology

  • Uninstalled “AudioStation”
    I basically made the Synology the least secure device I could. Pretty much EVERYTHING is disabled.

  • Rebooted the Synology.

  • Disabled the firewall on the router.

  • Disabled network services filter on the router.

  • Stopped roon server on Synology

  • Started roon server on Synology

  • Closed roon app on my phone

  • Started roon app on my phone

I still do not have Airplay devices listed. Back to where I started.

It should be noted, when I ran core from the laptop it was still using WiFi from Asus, connecting to database on Synology, and communicating with the Denon via WiFi at first then via Ethernet which is connected to the Netgear.

It all boils down to something wacky on the synology or a limitation/software issue with the core.

Following are the only packages installed.

  • When you mentioned vSwitch looked at virtual machine manager to verify nothing was configured.
    Still did not work
  • I then uninstalled virtual machine manager to make sure vSwitch was not configured.
    Still did not work
  • Connected via SSH and found a folder under /run named openvswitch.
    wondered why it would still be there when I removed anything in reference to virtual machines

I did a bit more searching on openvswitch and found the setting:
Control Panel\Network\Network Interface\Lan 1\Manage\Open vSwitch Settings

deselect Enable Open vSwitch

Everything works now.

If you are running Synology and are not using virtual machines the Open vSwitch may still be the issue.

The setting can be found here on the Synology:
Control Panel\Network\Network Interface\Lan 1\Manage\Open vSwitch Settings

deselect Enable Open vSwitch

1 Like

Update: I hooked up my 1600h and switched it on. Roon ‘saw’ it instantly. I enabled it on Roon as a zone and am now streaming via Airplay. Totally painless. So it looks like having Roon on the Synology instead of a NUC (like me) or PC may be the differentiator…
EDit: I missed the previous post showing the issue was resolved :slight_smile:

Hi @Dale_Murray,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.