Roon + tidal: cannot login

I just signed up for tidal trial period on hifi, and when trying to login in roon I get the following error:

I can log in normally to the Tidal service,…, so I am led to think this is roon’s problem.

I tried restarting the server, but it did not fix the issue

I am using Roon version 1.5 (build 363) stable (64 bit), on both server and client

The client is on OSX Mojave

The server runs within a docker container, on a NAS.

Any ideas on what may be going on?

Try rebooting the roon server, if you haven’t already, and see if it makes a difference.


I already tried that, but without success.

I digged a bit through the logs of roon, and found the following line:

RoonServer_log.txt:01/03 11:46:33 Trace: [tidal/http] POST => Success
RoonServer_log.txt:01/03 11:46:33 Warn: [tidal/http] failed (deserialize): Sooloos.JSONExtensions.JSONException: JSON: missing required string field: userId

So, it seems TIDAL is not returning all the data Roon expects to be happy. In particular, the userId…
My TIDAL username is my email address I signed up with.

I did not see any userId in the TIDAL web interface… so, I do not know what the issue may be on that end.

@support to have a look.

Hey @Josep – would you mind running your Core on the Mac temporarily and trying to log into TIDAL there?

You can do this in the Mac remote by clicking Disconnect (in Settings) and then choosing “Setup Core On This Mac”. You’ll need to de-authorize the NAS temporarily.

I suspect the docker configuration on the NAS is the issue, but I’d like to eliminate anything unique about the account before we troubleshoot in one direction or another.


OK, I tried, and as you guessed, I could link to tidal.

However, my core needs to be Linux…, any idea of why this may be happening?
Everything else works fine

OK,I changed the DNS setting for the container (previously I pointed it to the DNS in my environment) to point to, and it works fine now.

Thanks for your help!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.