Roon Tidal playback delayed and pauses [resolved - ATT is known to throttle Tidal]

After pressing play in Roon for a Tidal album or song, I experience a delay of 5-15 seconds before the music starts. Sometimes after the delay the track plays for about 5 seconds then pauses for 3 seconds and resumes playing. Other times it has a delayed start, then stops after 5 seconds and skips to the next track, with Roon showing the message in orange letters: “Tidal is loading slowly. This might indicate a networking or…”

This behavior happens with different Roon endpoints: SOtM SMS-200 and Windows PC with Roon. It also happens when I play Tidal directly with Sonos. I have not tried Sonos as Roon endpoint because Roon stopped seeing my Sonos as endpoint, but we’ll save that for another topic. :slight_smile:

During the delay, a light blue tone can be seen moving back and forth in the sliding time bar for the track.

The blue star icon for the Signal Path dialog box in Roon Core does not appear until music starts playing on regular FLAC tracks. But when playing Tidal Masters, the blue star is delayed like on non-masters tracks, but then it does appear during the delay, allowing me to open the Signal Path dialog to see that the ‘Authentication’ field is blank, then after another 5 seconds it populates with MQA 96khz, and music finally starts playing. MQA tracks have an even longer delay than regular Tidal HiFi 44.1kHz tracks. The extra 5 seconds is tacked on for MQA authetication.

FF or REW using the time slide bar causes the same delay before it starts playing again. Pressing the forward track or back track buttons also causes delay, pause, skipping.

It is random as to what I will get, a delay, a pause or a skip. But one of those three things happens on every Tidal track I try to play.

Playing music files from the NAS on my LAN with Roon has instant response, and no problems with FF/REW, pausing or skipping.

Streaming Tidal directly using the Windows Tidal app from a PC on my LAN has a consistent 1 second delay from hitting play to starting the music, and no pauses or skips, even with Masters tracks.

I have verified that my network is healthy. Streaming 4k video, playing video games, etc. no problems. Network is ATT 60Mb fiber to ATT router bridged to eero. eero DHCP. Roon Core, SMS200 and eero are all wired ethernet. eero is set to use Google DNS servers. Roon Core runs on Dell Windows 8 PC with 8GB ram. Roon and OS are up to date.

I just renewed my Roon subscription. I have been using Roon for about 16 months. This all started in the last couple months. Seems like it’s getting worse the last few days. The pausing and skipping are new this weekend, but the delay has been going for <2 months.

Thanks for the help!

I moved the Core server into the music room and connected it via USB directly to the DAC, in order to eliminate two ethernet switches and the SMS-200. This had no effect.

I feel that my network is not cause of the problem, especially considering Tidal desktop app works fine on my LAN.

All of my ~dozen friends who use Roon with Tidal do not have this problem, but none of them can offer a reason why mine works badly with Roon.

I find it strange that nobody has replied to my thread. Is there a more appropriate place to post support requests?

Yes – the #support section of this community is actively followed up by Roon @support. I have moved your post there and flagged support for you so they can assist. Stay tuned!

Thanks for reaching out, @richidoo, and apologies for the delay here! For issues like this you can always notify us with the @support tag.

So we can better assist you, can you describe the exact network topology here, including all of the networking hardware? Is the Core machine connected directly the Eero router, or is a switch involved?

Are you using the TIDAL app for this? How is the Sonos connected to the network?

Do you have any antivirus or firewall active on the Core machine? If so, try disabling them and see if there is any change.

Just to verify — This does occur when playing directly to System Output of the Core machine, right?


Thanks RMB for moving me to Support forum

Hi Dylan, I originally had 2 switches between Core and eero when this started, but I have temporarily simplified everything to eliminate as many potential sources of this problem as I could.

The current network is Core server wired ethernet to eero. USB from Core to DAC. eero is wired to ATT Pace router which is bridged to eero. When this first started I bridged the router to eero and we all noticed a big improvement on gaming and videos, but not change on the Tidal problem. It has gotten worse since then.

Yes, Tidal playback is delayed when playing directly to Core’s System Output.

To eliminate my network entirely I connected Core server to my T-Mobile cellular hotspot and the problem went back to normal, which is a 1-2 second delay. That is slower than playing files from my NAS, but it’s about the same as using the Tidal desktop app, and it’s probably how Tidal on Roon performed before this all started.

Sonos has it’s own Tidal player built in. That also has the same delayed response of ~10 seconds, It is not possible to connect Sonos to internet through my TMobile hotspot to see if it improves. Sonos is connected to network by WiFi to eero.

I did have Microsoft Defender running on Core, but it is now disabled, and no change, still 7 second delay on non MQA Tidal tracks. About 10% of the time Tidal tracks start immediately, <1 second. It is random.

A new symptom started tonight. Tidal logged itself out of Roon. A red error message notified that “Tidal login failed, retry or cancel.” This happened while it was paused for <10 minutes after playing a Tidal track.

Thanks for your assistance.

Thanks for the update, @richidoo!

Since this had a major improvement for you, it definitely sounds like something on the network is causing the issue here. If possible, are you able to connect the Core machine directly to the ATT Pace router and bypass the Eero completely? When you do this is there any change in behavior?


I removed the eero from my network altogether. I shut it off and disconnected the ethernet from the ATT router. I shut off DMZ+ (pseudo bridge mode} on the router so that other computers besides eero can use the router. Then I wired the Core server to the router and cold booted the Core server to get new IP from router DHCP. Started Roon, played some Tidal tracks, but there was no change in the playback delay, still ~7 second delay.

I did notice that if I allow a Tidal track to play (after delayed start) for >5 seconds, then I can use the track forward button to skip to the next track with no playback delay. I had noticed originally that I can listen to a whole album with no pauses between the album tracks. But if I manually forward track before 5 seconds of playback has elapsed then it delays for 7 seconds before playing the next track. If I try to reverse track (play the previous track) then it always delays 7 seconds before playing. And when the forward track button causes a switch to a different album in the queue, then the delay happens even if the current track has been playing >5 seconds.

I rebooted the ATT router and fiber modem fresh but this did not make a difference. Still delayed response. But after rebooting I am again getting the pauses after 5 seconds of playback that I mentioned previously, and the orange text error message “Tidal is loading slowly, network problem, etc” then it stopped playback even though it was playing at the beginning of 69 track queue.
Thanks for any advice.

Thanks for giving that a try and following up, @richidoo!

Just to recap, on the hotspot network, everything worked great, but even with the network being just Router > Core, you’re still experiencing issues, correct?

It sounds like there may be something about the router that is causing you to see this behavior. I would take a look at your router’s settings and see if there is anything there that may be causing you to experience when connected to it. Are there any settings you see that may be related to this type of behavior?


The router has the default settings as originally installed by ATT.

Roon with Tidal worked fine with this router for about 15 months. Then it started having small delay 6 weeks ago, then it gotten much worse since then.

Anything specific I can check?


As documented above, Roon/Tidal poor behavior was cured when Core was tethered to a T-Mobile cellphone. And all other streaming clients on my network are fine on ATT network. ATT is known to throttle Tidal on their cellular network. Those 3 clues suggest ATT is throttling Tidal on my fiber network. So I tried VPN to hide my Tidal requests from ATT, and it worked.

Using VPN client solved this problem = ATT is throttling Tidal.

The Tidal desktop client did not have the problem, and Tidal desktop app takes forever to start. Both clues suggest Tidal desktop app is using built in VPN client.

Hope this information helps others who have poor Tidal performance in Roon.

I am using TunnelBear for VPN. It seems to work well, and costs $60/yr for 5 clients unlimited data.

1 Like


Were you using AT&T’s DNS servers before you switched to a VPN? If you were it would be interesting to know if a switch to an alternative DNS provider ( CloudFlare, Google or Quad9 ) would have solved your problem.

I ask because while I don’t use AT&T for my Internet I do use Comcast / Xfinity and just dropped cable so all I have is their internet service. Concerned that they may start throttling to try to get me to use their streaming services. Had to decline them several times just to get cable cancelled.

Thanks … Tim

Hi Tim thanks for replying.

Yes, I was using ATT DNS, then I switched to Google and then Cloudflare DNS, but it didn’t affect the problem. Thanks for the suggestion! I had read that changing DNS can help a lot of problems.

Throttling usually applies to the content provider. It would be fraud to throttle their own customers’ bandwidth after selling you a certain quality of service. But I wouldn’t put anything past ISPs, or content providers for that matter. :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.