Roon UI not reacting when maximizing window

Roon Core Machine

OS Name Microsoft Windows 11 Home
Version 10.0.22000 Build 22000
Processor Intel(R) Core™ i9-9900KS CPU @ 4.00GHz, 4001 Mhz, 8 Core(s), 16 Logical Processor(s)
Installed Physical Memory (RAM) 32.0 GB

Networking Gear & Setup Details

Sky Router (Full Gigabit line - Gigafast) / Ethernet connection

Connected Audio Devices

Lynx AES16e into Schiit Yggdrasil via AES/EBU breakout cable

Number of Tracks in Library


Description of Issue

This problem has only appeared recently - no changes were made to the system (and I use my main computer for listening to music - so the core is the listening station):

I launch roon and it’s all good - I start listening to a local album that I copied to my PC (Samsung 970 EVO Plus nvme drive) from one of my own discs via DBpoweramp or other methods if it’s a blu-ray audio disc.
I listen to various tracks being played on the album, then I maximize roon (I want to pause for example) and it’s not reacting for about 10 seconds, but then it works fine for the rest of the day pretty much.
Sometimes it also just closes during that 10 or more seconds of not reacting period.

My local tracks are all encoded in the flac lossless format and played via ASIO over my Lynx soundcard, this has also not changed.

Are there any settings I can alter to prevent this lag from happening?

I also changed my internet provider from Vodafone to Sky recently, but it already happened on the Vodafone internet line with an entirely different router, so I don’t believe it’s linked to anything relating to that.

Love the program by the way - been using it for quite some time now.

Might be a graphics issue. Are you running the latest drivers from the manufacturer site not windows update?

1 Like

That’s actually a really good call and I thought graphics were completely irrelevant - my 3090 has the most recent nVidia drivers installed always, HOWEVER I recently switched to a two monitor setup (extending my desktop onto the second monitor).
Could that have something to do with it?
Is there a way to “Turn off hardware acceleration” or something along those lines in roon and would it affect anything?
Or is there another solution I could go for?

@Geoff_Coupe is better at this than me.

Cough - thanks (I think) @ged_hickman1

There’s no setting in Roon AFAIK that would cure this issue - there may be a setting in the nVidia drivers that would help, although I don’t know what it would be.

I notice that you are running with two monitors - this setup has caused problems before with Roon. If your issue is the same as this thread, you could try the workaround given here:


Thanks very much!
While I don’t intend to use roon on my second monitor, I’ll try to keep it in windowed mode instead of full screen on my primary monitor and see if that changes anything - I have an inkling that it might just fix the issue (and by inkling I mean “no idea what I’m doing but hope dies last” of course).

It’s obviously not a terrible issue, but it would be nice to instantly pause first thing in the morning sometimes when someone’s inevitably at the door.

EDIT - SOLUTION: After trying NOT MAXIMIZING the window this morning - just manually dragging the window to the monitor’s size (please note once again that I use roon only on my first monitor) or using any other size as long as it’s not maximized it doesn’t seem to freeze at all so far.

So thanks very much for linking that thread! This appears to be the solution.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.