Roon update link does not work on second windows machine[answered]


Windows Tablet this morning updated itself and the core on the server - fine. Fired up laptop a couple of hours later to update that and it said core was on 1.3 and there was a link to update the laptop but clicking on it does not do anything:

I have a similar issue with OSX:

Had same issue. Left it for an hour and found that it had updated.

Can you try to manually install Remote client - This should fix this state

You can force the update by redownloading the current Roon package on the interweb.

Yes, the workaround worked - that is, I downloaded 1.3 installer package and installed that on laptop.

Quite impressive that I thought to do that after posting here and in the time it took me to do that and install it all the replies here had been posted. Very impressive support from the community and Roon support, thanks. I guess there is a bug in the system somewhere that caused the initial problem though or, at least, requires some sort of inidaction clicking update has started the process in the background.


Yes, there was a bug and it is fixed. Apologies for inconveniences.

1 Like

Again very imprssive support, thanks very much

In my case it doesn’t work. I have Roon server and Roon remote running on the same desktop. Roon remote was updated automatically. Roon server didn’t. Tried downloading the Roonserver from the site installed it but it’s still version 1.2.168 not 1.3.

Also version 1.3 of the IOS remote is not in the app store over here (the etherlands) Nothing is working at the moment

Sounds a bit strange. Let’s start from describing your setup in details.
Can you also launch the Remote and take a screenshot of the ‘About’ page (accessible from Settings).


Can’t acces the about page because roon does not start.
I’m trying to uninstall everything and installing it from the ground up.

Sure, let us know how the progress goes.

Got it working

strangly enough when I downloaded the roon server from the website and installed it it showed up as version 1.2. Tried this three times. After uninstalling the server and installng it again it showed up as 1.3. Somehow it did not update itself.

Same for the Ipad. While the appstore showed version 1.3 it wod ot update because it told me I allready had the latest version installed. Only after uninstalling 1.2 I could install 1.3.

Glad you are up and running.

Just wondering. I have Roon server and Roon remote running on the same win 10 machine. It seems that the Roonserver is 32 Bit software and the Roon remote 64 bit. When I would run Roon as all in one package does it meen that the core then also runs in 64 bit instead of 32? If so, does this have an impact on performance?

I’m running the core and remote seperatly to prevent the music to stop if the Roon software crashes, wich up till now happend quite often. Maybe there no need for this anymore if 1.3 is more stable

I downloaded OS X Roon Bridge from

for a new machine to join my room setup.

after checking roon remote on iOS the new installed machine appears as 1.0 Build 6.1

soon remote doesn’t trigger the update process.

both server build 194 and iOS build 188 are on version 1.3

tried a second mac, some issue here.

seem’s to be something wrong with the download package.