Roon will not accept my Tidal sign in

Core Machine (Operating system/System info/Roon build number)
macOS Catalina 10.15.4

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Apple Time Capsule 1 Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Apple TV Ethernet

Description Of Issue

All was working fine yesterday… today error message within Roon says any Tidal music I try to play is not available. Logged out of Tidal within Roon and tried to log back in. Roon error messages now says my Tidal log-in name / password is incorrect which is not true. I have tried the suggestions in the previous post to no avail. Please help. Thanks in advance, Ken

Don’t know what that suggestion was, but did you reboot the Core machine?

Sometimes it helps to go to the Tidal app and sign out and back in there. Then, in Roon, sign out and back in. You may even need to disable Tidal and re enable in Roon before signing in.

Multiple times

I tried signing in and out of Tidal (which works fine). I also disabled Tidal in Roon and now it will not let me sign back in.

Try going back to Tidal and sign out and in again. Reboot everything and re enable Tidal in Roon and sign in. I think it will eventually work.

Thanks Jim… Ill try again… I have been trying for over an hour now

Here’s what I get:

Have you tried logging onto the Tidal app?

Tagging @support.

Yes, many times. Tidal accepts the email / password just fine. Roon does not accept it.

Hi @Ken_Steigerwald,

Have you recently changed your TIDAL password to include any special characters?
I just tried logging out and back into TIDAL on my end and it’s working as expected.
I would also suggest that you try to reboot your networking gear.

Thanks Noris, but I have rebooted everything several times to no avail. The only thing I have not rebooted is the Cable Co. supplied modem. Roon WILL NOT allow me to sign in to TIDAL. Tidal seems to be working just fine independently. I was just about to purchase a new streamer / dac but if I cant run Roon I will have to cancel that. Please help me figure this out. Ken

BTW, I have not changed my Tidal password at all. It does not use any special characters just alpha numeric.

Hi @Ken_Steigerwald,

I’ve gone ahead and activated diagnostics mode for your Core and what this action does is automatically upload a log-set to our servers for analysis.

I see here that you are running Roon build 511 which is not the latest one we have. Can you please upgrade to build 537 and verify if that helps with the TIDAL issue?

If you want, you can perform a manual install on top, I would:

  1. Create a Backup of your Roon database for safekeeping.
  2. Navigate to our Downloads Page
  3. Select the Mac package of Roon and install it, here’s a direct link.

Once you have the latest Roon version installed, do let me know if there are still issues with TIDAL login, thanks!

Noris, apparently Roon will not allow me to install build 537 on top. Here is what I get:

Is there another way to try?

Should I completely delete Roon from my iMac (core) first?

Hi @Ken_Steigerwald,

I would use the instructions I listed above to install the latest Roon version on top, you shouldn’t have to uninstall Roon first, but a backup is highly suggested.

A post was split to a new topic: Roon TIDAL Login issues

Noris, I am getting those messages also. I have tried to update Roon exactly as you have suggested. It seems to go through the process but when I check “about Roon” to see what build is installed it still shows 511 and give the error message about checking for an update. What’s up with that? Ken


My issue has been resolved! Coincidentally, I just received a notice from APPLE to upgrade my OS to Catalina 10.5.5. After I did this update I tried again to install the 537 update from Roon. This time, instead of dropping the Roon icon into the Applications folder I just ran it from the box

. The install then proceed successfully. Thank you!

1 Like