Roon will not connect [Solved]

I hit the roon icon. I enter my name and password. Roon does not connect. It just keeps circling and circling

There is nobody to talk to at roon. I am an audible learner not just a reader of complicated instructions.
Are there no humans at roon to talk to.

I type in my name, credit card info, etc. Roon keeps saying I am entering the wrong information when I know I am entering the exact right information

Hi @Michael_Salzberg – don’t worry, we’re here to help.

Can you give me the details of your system, as described here?

Was Roon working previously? When did it stop?

Roon was initially working. I was not using it yet since I had a DAC on order and it has now arrived.

When I try to use it now, once I launch the program I am asked to sign in. I put in the correct name and password and get a " Logging On " but it never moves past this point.

I have uninstalled Roon and then downloaded the latest version, installed it and tried to open the application and the same never ending Logging in message.

If I try to log on with a wrong name or password it immediately tells me the name or password is wrong.

I am using a iMac with OS 10.11.6, 8 GB or RAM, 1TB disk drive, the latest version of Roon just downloaded.

Roon was working previously if that clue helps. It was used to play songs locally on the iMac. I do not know if this helps but it cannot hurt to add it to the request.

What procedure did you follow when you removed Roon?

I deleted the icon for Roon and emptied the trash

Try the following, NOTE I SUGGEST YOU RENAME RATHER THAN DELETE THE ROON FOLDER, Roon.old or Roon.orig or a name of your choice.

The databases, settings, and artwork live in the /Users/USERNAME/Library/Roon folder.

To get there:

Open Finder and click Go in the top bar
Hold down the Alt key to unhide the Library folder
Click the Library folder
Find and delete (or rename) the Roon folder
Depending on how you configured Roon, there might also be a /Users/USERNAME/Music/Roon folder.

Also, just drag the Roon or Roon Server application to the trash.

Then download Roon an reinstall it, note this will do a re analysis of your library which could take a while depending on the size.

1 Like

It has successfully installed and re-doing the library. It will take more than 2 hours so I will hopefully see the results successfully. Then I will go on to see how to add the Roon ready DAC.

Thanks for your help. It appears that the Roon folder must have had some corruption?


1 Like

You are welcome, glad it is working.

1 Like