ROON with M2TECH HiFace 2 [Solved, Firmware update]

Using ROON successfully, PC server running Windows 10 & ROON server, SOtM SMS-200 network streamer in Living Room. Trying to use server as another zone, family room, - server has M2TECH HiFace 2 USB to S/PDIF (to a home theater receiver via digital coax). ROON “sees” the M2TECH, lets me name it, configure it as a new zone, but will only play successfully for a few seconds, then I get errors: transport: roon lost control of audio device, and playback_error_endpoint_device_init_failed.

HI @Michael_Gerardi ------ Thank you for the report and my apologies for the troubles here. To help aide in my evaluation of what may be causing this behavior, may I kindly ask you for the following:

  1. I see you’ve already started providing some details of your setup :sunglasses: May I kindly ask you to expand on this description as seen here.

  2. Can you confirm that you are referencing the SAME PC server here? I appreciate the verification!

“Trying to use server as another zone, family room”


Thanks for the reply and offer to help.
My ROON server runs Windows 10 Home 64-bit, i3-6100T processor, 8GB RAM, SSD drive for Windows & ROON.
Library is on a Synolgy NAS, 4,100 tracks, about ~140GB of music, all FLAC format, mix of CD redbook and HD up to 192/24.
The M2TECH HiFace 2 is hooked up to the server.
ROON software is at Version 1.2 build 168, 64-bit.
Everything works great with my network device, SOtM sMS-200, a ROON endpoint in another room (living room).
I am also trying to use the Server PC audio output in the room the server is located in (family room), where the server goes USB to M2TECH to Pioneer SC-25 receiver coaxial digital input.
The ROON software clearly shows the M2TECH hiFACE TWO UAC2 connected to the core in WASAPI mode.
I have played with the Playback settings for this device in ROON, turned Exclusive mode on/off. Seems to work best with exclusive mode off, but is still spotty. I do have the M2TECH drivers loaded.
I do have a Schiit Wyrd between the M2TECH HIFACE 2 and the server USB - to clean-up the USB signal and provide cleaner, linear power to the hiface - but I tried with and without, I have the same problem whether the WYrd in in the loop or not -even with the hiface two plugged directly into the server usb.
Sometimes it works, but is not stable, will hear some occasional “scratches” in the music, can’t think of a better word, crackle of type, or sound goes out completely, or does work fine - just not reliable.

Hi @Michael_Gerardi ----- Thank you for the follow up and taking the time to answer my questions. Both are very appreciated!

Can you confirm for me if this configuration works outside of Roon? For example if you were to try playing content through Windows media player or off of youtube are you seeing the same results?


Thanks Eric,

In troubleshooting I have discovered two fairly consistent things, not necessarily related.

Yes, this could be a Windows thing, or M2TECH driver issue - Windows will “lose track” of the M2TECH device and say No audio devices connected. This can occur randomly – haven’t figured it out, possibly after Sleep/wake cycle like it did this morning. Can get it to “rediscover” by rebooting, and/or unplugging/plugging in the device – not sure why it is unstable, and of course, this does not sound like a ROON issue (and this same thing happens with the device plugged in directly to the computer, or via the Schiit Wyrd in between.

The 2nd behavior: When it does work, I can get it to drop and go silent from within ROON if I select Exclusive mode. It really doesn’t like Exclusive mode. Of course, I don’t have to use (!), but it may offer a clue.



Hi @Michael_Gerardi ----- Thank you for the feedback and the follow up. My apologies for the slow response here. As we have seen with other users in the past, these symptoms you are describing strongly point to either an unstable driver or some kind of performance issue with your hardware. Has M2Tech been able to offer you any advice here in troubleshooting this problem?


Thanks for your help Eric. Yes, M2TECH did respond. Turns out I just needed a firmware update. Everything works great now. Thanks for your support, appreciate it!

1 Like

How did you contact M2TECH? And how did you get the firmware update? I may be having similar problem

Marco at sent me a pdf file (instructions) and a .bin firmware file. If I could figure out how to attach files here, I could send them to you. If you send me your email I can forward the message to you, or you can try reaching Marco yourself


Are you running it on Apple or Microsoft ?