Roon won’t connect with Tidal

Last night I inserted a new dCS Rossini Player into my system, and now Roon won’t connect with Tidal. Trying to log in to Tidal I get a red box saying Network Connection Problem. Nor can I access my Roon account when I try there’s a short message saying Account not available or something to that effect. However using the dCS Mosaic software I can access all my Tidal albums. Please help.
James Heckman


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


Obvious question, is your core device up and running? Are both devices connected to your network, either individually or in series, with the core connected to your network and your Rossini connected to your core?

Yes to all, James.

Hi @James_Heckman,

If you reboot your Core machine and try again is there any change?

1 Like

Thanks, Dylan. I did try that, no change.
Jim Heckman

Jim, you need to be more specific about how you system is connected.

Here’s an example using my system.

NUC(Core) ==>(Ethernet) ==> Rpi ==>(USB) ==> DAC ==> Amps

Did you change your Core device?

It sounds like your Core machine is not connected to the internet?

I didn’t change core device, but you have very astutely nailed it–it’s probably a connection problem between my Core machine and the network. It’s turned out to be very greatly more complicated than anyone had guessed. After perhaps seven hours to date with an expert logged into my system, it’s still not solved. At the moment he’s logged and working on it. When the problem is finally recognized and corrected, it will mean nothing to anyone but esoteric knowledge holders of my Core machine. Many thanks for your thoughts.
Jim Heckman

Hi @James_Heckman,

It sounds like your SonicTransporter doesn’t have an active internet connection or valid DNS servers.

I recall you were working with Tony in the previous thread (Adding dCS Rossini to Roon setup), do you by any chance know if the changes you made impacted the SonicTranporters DNS servers or access to the external network?

Also, can you provide some more information regarding your network setup, such as the router’s model/manufacturer and the model/manufacturer of any switches/range extenders/powerline adapters/access points/ect?

Is it possible your firewall got reset such that it is blocking internet access?

Yes, noris, the problem is a connection problem between the Core (Antipodes DX3) and my network. It’s proven extremely difficult to unravel. What Tony has said is we have to find a way to prevent the Comcast Primary and Secondary DNS settings from being loaded in the DX each time it joins the network.

My network setup here in Pennsylvania is Comcast cable and the signal comes from the street through its Xfinity modem. A wire goes out of the modem into my Core machine (Antipodes DX3), which acts as a bridge connecting my Rossini Player (DAC) to the network. I have no switches or any of the items you mentioned, except an old Richard Gray’s Power Company unit plugged into an outlet in the circuit with nothing plugged into it.

Here is Tony’s email: Any ideas you may have would be greatly appreciated. My email is [Removed by Support]

I can listen to the system now using dCS’s Mosaic app.

Thanks much for your attention to this. We’ve spent many hours trying to solve it.
Jim Heckman

Edit: Support removed personal email address to prevent spammers from getting this info

Good thought. We’ve checked that. Thanks.

As @noris suggests, the Antipodes DX3 did not have valid DNS servers. The DX3 automatically gets the DNS setttings from the router. We see:


:which are IPV6 addresses; we would like IPV4 addresses.

When I changed these to the internet connection was restored.

I am not in the USA but we have one of our support people who is having a look at this issue. It has not occurred before as far as I am aware. It will be fixed shortly.

The issue has nothing to do with Roon or with the dCS Rossini. With the correct DNS settings everything works perfectly.

1 Like

Hi @Tony_Devitt,

Thanks for the update on this and for continuing to work with @James_Heckman to resolve the issue! It sounds like you have identified the issue and have addressed it, but if you require any input from our end please feel free to PM me, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.