Roon won't load iTunes music despite multiple attempts [Solved]

I’m a new member. created an account and downloaded Roon onto my MacBook Pro (2015; MacOS Sierra). Installed and launched the app. Roon found my podcasts and audiobooks but no music. I have several thousand songs in my iTunes library. I mapped Roon over and over again to my Music folder. I dragged and dropped the Music folder onto the app. Still no music, not one song. I tried both mapping and drag&drop individual songs. Still nothing, no songs/music in the app. I’ve read through the FAQs, I know Ive done everything right. So how do I get the music into the app???

Perhaps is indexing but how long have you let it run?

1 Like

Hi @Bruce_Austin ---- Thank you for the report and my apologies for the troubles here.

Piggy backing on what @wizardofoz has pointed out in his response, can you confirm if Roon is still currently indexing your collection or has that completed?


Thanks Eric - but NOWHERE in Roon’s setup documentation is there any reference to “indexing” - in any event I have relaunched the app and will keep it open, assuming it is “indexing” my copious music collection, even though there’s no indication this process is taking place, no load-bar for example. Will let you know if anything changes. How much time should I expect this process to take?

Hi @Bruce_Austin ---- Thank you for the follow up. What is being referenced when I use the word “indexing”, is essentially the import process. Upon starting this process, Roon must first analyze ALL of your files . So the time in which it takes to complete is contingent on the size of the library being accessed.

You can check on the progress of your import by clicking on the spinner that appears at the top right hand side of the screen, as seen in this excerpt taken from our knowledge base:


thanks for the info - unfortunately i don’t see any spinner as indicated in your screen shot, and there’s no change to my Roon library - still only features podcasts and audiobooks. Any way to “force” the indexing of music files to launch?

Hey @Bruce_Austin – sorry for the frustration here. Let’s make sure we understand the current status.

Can you start by giving us the details of your setup as described here?

In particular, I’d like to understand:

  • Where your music is stored
  • What you’re seeing on the Storage tab of Settings (a screenshot here would be great – just drag it into your reply)

Thanks @Bruce_Austin!

1 Like

Hey Mike, Thanks again for getting in touch and letting me have a second chance at this. Just as background - I’m an old time Mac user and know my way around OS X pretty well. So I understand where fees & folders are located, etc. To give a better understanding on my particular issues with Roon:
What version of Roon you are running: not sure - the Get Info on the App has the version as “Copyright © 2016 Roon Labs LLC”
What operating system you are running: MacOS Sierra 10.12.3
Basic information about the device you’re using: MacBook Pro Retina 15" mid-2015, 2.2 GHz Intel Core i7
Describe where your music is stored: on my local HD in the ~User>Music>iTunes folder
Let us know your collection size (approximate number of tracks): thousands
Where is my music stored: ~/User/Music/iTunes
Storage tab/Settings screenshot: I need to have my membership reactivated to get this

Resolved over email! The files that were not importing were in Apple’s deprecated, DRM protected M4P format.