ROON won't stop scanning on Exasound Delta Server [Solved - Server Firmware Update]

Core Machine (Operating system/System info/Roon build number)

Exasound Delta Server (ROON Core); latest ROON build; Exasound s88 DAC (ROON endpoint)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Cox Gigablast internet unlimited. Cox Gigabit cable modem. Linksys WRT1900AC wireless router Western Digital MyCloudPR4100 network server Note - Exasound Delta Server and s88 DAC, Cox cable modem, MyCloudPR4100 server are all hard wire connected. ROON plays music fine.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Exasound s88 DAC hardwired ethernet using ROON Ready ethernet

Description Of Issue

I had updated to latest version of ROON and all was absolutely fine. I just updated both the Exasound Delta Server (ROON Core) and Exasound s88 DAC ROON won’t stop scanning

Let me add: the little circle keeps circulating to show ROON is scanning files. But in Settings it shows via the # of files and # of files scanned that it looks like scanning is completed. In Settings I can’t start a new scan, the button doesn’t work. If I add music the only way to start scanning is to turn off my ROON Core Delta Server and turn back on. Also, I have some duplicate tracks, on original album, and on compilation demo albums. Everything was properly organized in ROON per album. Now, some of the albums have come up as new albums piecemeal. This happened last November and ROON updated a kernel in the operating system and fixed it. I want to emphasize last week I updated to the last ROON 1.8 OS and everything worked fine. Only this past day when I first updated my software for Exasound Delta ROON Core did the problem start. I also tried restoring a ROON backup but the same
misconduct in operating by ROON continues.

Hi Steve,

When we talked on the phone a moment ago I forgot to mention that you need to turn on Verbose Logging. The Delta server will reboot. After the reboot send us diagnostic data. We will check the system logs and the Roon logs and I will get back to you.

Hi Steve,

We checked the Roon logs and we can also send them to Roon. It appears that there are connectivity issues between Roon Core on the exaSound Delta Server and your NAS. I would think that when the intermittent connection is established Roon starts a new round scanning of the library.

You can try to connect the Delta server and the NAS to the same network switch. Also make sure to use IP address for the NAS share in the Roon Storage settings. This will avoid dependency on services for resolving the NAS host name to IP address. These services may be affected by the network conditions.

1 Like


Thanks so much. Here I reported this to you late last Friday and first thing Monday, when your programmers are back in, you figure it out. And you talked to me several times on the phone asking questions the past few days. Best customer service I have ever had.

My integrator is in the middle of installing new hardwired wi-fi throughout my home and temporarilly has everything working on the old gear until he installs the new gear - to get everything working temporarily he moved the Cox cable modem away from my home office, where the NAS and Delta server are, into my theater under reconstruction right now. Undoubtably this is the issue. Whats funny is before I simply would on occasion lose music and connection but quickly get it back, but a few days ago the issues became more severe.

Again, anyone who is interested in Exasound, you do not get better personal customer service than from George at Exasound!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

@George_Klissarov, @support,

Problem is back …

Exasound Delta ROON Core Server ROON Won’t Stop Scanning.

Hi Steve, we are waiting for the Roon to provide information about the root cause of the problem. In the mean time before trying another firmware update we need to see the Roon logs. Please send again diagnostic data.

Here is the other user that reported the same issue: exaSound Gamma Server - Scanning never ending. We’ve exchanged emails last night and Phil confirmed that on his side Roon works fine after the firmware update.

What did the firmware change?

Our exaOS is a custom minimal build based on Ubuntu Server 20.4. We’ve updated the kernel to the latest low-latency version in the LTS branch.

And the new firmware for my Delta that I got 3 days ago works flawlessly and ROON is fine now. Thanks so much George and Exasound!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.