Happy to see the addition of ROONALBUMTAG in Roon 1.7, however, I seem to be having some problems. I’m quite new to Roon so still finding my way around but don’t think I’ve done anything wrong?

Last night on one particular folder on my NAS I updated the file tags to include the ROONALBUMTAG tag and assigned a value (LQ). This appeared to work and I could see the tag within Roon and it worked as expected.

Today I updated further files in different folders and again included the ROONALBUMTAG and assigned a value (e.g.Mike). This doesn’t appear to have worked at all within Roon, I just don’t see that tag.

All tags have been updated at the file level. Any thoughts, appreciated to resolve, thanks

A post was split to a new topic: Problem with new Roon Tags

When you’re adding tags, are the file modification times being updated or preserved? If preserved, you’ll need to explicitly rescan the albums in question to have the tags show up in Roon

Hi @Mike-W,

Have you tried rebooting?

Where are your files stored?

Let’s take a look at one specific album. Can you share a screenshot of the album in Roon as well as a screenshot of the album in your tagging tool showing that it’s been tagged?


Hi Dylan

Yes I have re-booted and all my files are stored on a QNAP NAS in different folders depending primarily on quality or whether they belong to me or my wife

Before you introduced ROONALBUMTAG I had tagged some of my albums within Roon with the tag Mike or Carol (so my wife and I could have different views). On the introduction of ROONALBUMTAG I removed all the albums that where tagged with Mike or Carol in Roon so I could start using the ROONALBUMTAG. I also tried deleting the Roon tag Mike and Carol but they still seemed to be hanging around.

I am primarily using the value Mike in the ROONALBUMTAG on my files also and my profile within Roon is Mike so I was wondering whether this has something to do with the problem.

Anyway before I read your post I decided to remove all the storage locations from Roon, Clean the library and the cache and reload Roon. I am now in the process of adding back in the first storage folder from NAS. All these files have a ROONALBUMTAG of “Mike” or “Carol” or both in some cases separated by a semi-colon e.g. “Mike;Carol”

It’s still importing the files but at present when I look in tags it says I haven’t created any yet…will let you know as soon as the import finishes

I think that, because there is no information regrading user profiles available in the file tags, Roon creates always shared tags out of the file tags. Check that you’ve enabled the display of Shared Tags in Roon’s tag browser.


Yes I have shared tags enabled, here’s an update…

The import process for the first folder has completed and all the albums seem to have the correct tags when I look at each album :grinning:

However, if I click on one of the tags e.g. “Mike” it says “this tag was not found in your library”

If I go, hamburger menu, tags, it says you haven’t created any tags.

If I click on the My Tags submenu then it has entry that says Carol’s Tags but selecting it says Carol hasnt created any tags.

What BlackJack said is that Tags in Roon generated by using ROONALBUMTAG are always Shared Tags. Profile associated TAGS are added when you add a Tag in Roon, it is associated with the profile that added it.

More to the point, if you added Carol via ROONALBUMTAG it is by default a “Shared” tag. You can then move it via Editing to Change Ownership of the TAG to the profile Carol. That way if you are in the Profile Mike you can “turn-off” Carol Tags. And visa Versa.

Rugby not sure I understand? The tag Mike was also created via ROONALBUMTAG so why don’t I see that in the TAGS menu?

How do I change ownership of the Tag, can’t see any option in the TAGS menu to do that?

First, to get the hang of it, use only a couple of albums and a test tag name called TEST. Do not use a real tag name currently in use until you understand how it works.

If you add TEST via ROONALBUM Tag it will be added as a Shared Tag always. In your pic that would be the option call Shared Tags. It will not be in your Profile or any other Profile’s tags. If you want that Tag there then you have to change ownership. See Below.

FYI: In your pic, there are 3 Tag options, Carol’s Tags, Shared Tags and “My Tags” (Which would be Mike’s Tags since that is the profile you are in currently). If you switch profiles in this space you’d see Mike’s Tags, Shared Tags and “My Tags” (which would be Carol’s Tags because that is the current profile).

To change ownership, Go to Shared Tags where the TEST tag should be. Click the Tag, up top left, 3 dot menu, click Edit.

That will bring up a small screen that allows you to Rename the Tag or Change Ownership. Click on the owner dropbox and you should see a list including Shared and all other profiles, so in your case Mike and Carol. Choose Mike. Hit Save. Now you should see the Tag under “My Tags”.


Thanks Daniel

I’ve completed those steps and it works as you explained, however, what I don’t understand is why I still don’t see the albums that have been tagged with the value “Mike” or “Carol” via ROONALBUMTAG in the TAGS menu and yet they do appear on the album description as expected? Am I missing something here about the way Roon works?

I’ve added some screenshots

Hi @Mike-W — Can you share one of these albums with us that’s tagged but not working correct? You can send a private message to me with a shared Dropbox link and we can take a look. Thanks!

Done, thanks

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.