RoonAppliance error - A new guard page for the stack cannot be created

(tboooe) #1

Has anyone seen this? I did a search on this forum but found no reference to this.

#3

Is this related to “Is there a way to repair a corrupt database?” or another problem?

(Dylan Caudill) #4

Hi @tboooe,

Can you share a screenshot of what you’re seeing here?

(Francisco) #5

I got the same problem tonight when Roon was doing a backup. After I click OK the Roon client lost contact with the Roon Server.
I restarted Roon Server and tried again the client and it worked.
I manually started a backup and it worked for some time, but got the same error after 5 minutes.
This is not the first time this happened.
Capture

(tboooe) #6

The above screenshot was exactly what I was seeing too. Its odd because my Roon Remote appeared to be working fine. I only checked my RoonServer PC because I noticed Roon was stuck identifying a new album in my library. As noted, when I pressed OK on the error, Roon Remote would lose connection as Roon Server restarted. I only got this error to go away when I removed one album from my library.

(Francisco) #7

I have not been able to use Roon since this error started to happen (I am happy I still use JRiver’s).
The problem appears even if I don’t try to backup the database.
I haven’t added any albums in the last week or so and this started on Friday.

(Dylan Caudill) #8

Hi @Pacomo,

I was hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link.

(Francisco) #9

Dylan,
Below is the DropBox link to the zip file.

(Dylan Caudill) #10

Hi @Pacomo,

I spoke with the team about this, and the error you’re receiving appears to be stemming from an issue with .Net framework on your Core machine. Can you try updating .Net framework and let us know if that yields any changes for you?

(Francisco) #11

I had .NET 4.7.2 installed. I upgraded to 4.8 and still have the same problem.
I had the same install for a couple of years and this is a dedicated NUC acting as a server.

(Dylan Caudill) #12

Hi @Pacomo,

Thanks for giving that a try. Would you mind sending over a new set of logs after the updated .NET so we can compare?

(tboooe) #13

At least for me I dont think the issue is with .NET. The error went away after I got rid of the specific album that was causing all my stability issues.

(Francisco) #14

Here is the new set

(Dylan Caudill) #15

Hi @Pacomo,

The team looked into the latest logs and I wanted to follow up.

They’re seeing some errors that can correspond with running out of available memory. It looks like there are quite a lot of tracks in your database, so it RAM usage can be a bit higher than you’d see for a smaller database.

Can you confirm how much RAM your Core machine has? Are there any other apps running that are using a lot of memory? When you start up Roon how much memory is available?

(Francisco) #16

Hi Dylan,

The system has more that enough memory (16 Gbytes) and it is the only app running, aside from the antivirus.
I am slowly isolating the problem. I have my music stored in separate folders (CD, HiRes, SACD, etc.). When I disabled access to the CD folder I did not get the error, so I am now restoring a Roon backup from the day before the problem started and will slowly add the folders under the CD folder until I get the error again.
I hope this way I can isolate the folder/album with the problem so I can send it to you.

(Dylan Caudill) #17

Hi @Pacomo,

How many tracks total are in the CD folder?

This is definitely a good test — let us know when you see the crashing behavior occur and we can take a look at the media.

(Francisco) #18

Dylan,

All the folders are organized by Artist and then by Album.
I have a total of 19,924 albums and 268,161 tracks
The CD folder has 2,711 Artists, 6,376 albums and 70,138 files.
Other folders, like the HiDef one has more Artists, albums and files, so it has to be something in the CD folder.
So far I have been able to restore the backup from the day before the problem started and it looks like it has all the CDs but 15. I will now add them one at a time and see what happens.
I’ll let you know.

1 Like
(Francisco) #19

Dylan,

I tried everything I could think of and I still get the same error.

I am not going to tell you everything I tried, unless you really want to know, but I think my last test should tell us something.

This is what I did:
1. I removed from the NAS all the files added or modified after July 22, 2019
2. I restored a full computer backup from July 23, 2019. I wanted to make sure I had the computer in the same situation as when everything was working.
3. Roon rescaned everything without errors. A few moments after finishing scanning I got the same error.

At this point I am starting to believe that it may be a change in some of your services that is causing the error.

As of now, I cannot use Roon at all.

Attached are my latests logs

Let me know.

(tboooe) #20

After you removed the files from the NAS did you then restore a Roon backup prior to July 22nd? Thats what I had to do.