RoonARC not working with ATT&T BGW210

Roon Core Machine

Windows 10 Pro on Dell desktop

Processor Intel(R) Core™ i9-9900 CPU @ 3.10GHz 3.10 GHz
Installed RAM 32.0 GB (31.8 GB usable)
Device ID 0DC476C6-7492-4756-9903-5648810C05B5
Product ID 00330-52586-73191-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Networking Gear & Setup Details


Connected Audio Devices

Currently just desktop audio.

Number of Tracks in Library

Description of Issue

Cannot get Roon ARC to work.

I followed to the best of my ability this thread from someone with the same router: I'm having a problem with Roon -- how do I report it? - #5 by RoonFAQ

I continue to get this message:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“2600:1700:AAAA:BBBB:CCCC:DDDD:306c:e978”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

This was my latest attempt.


Help would be most appreciated. It was working at one time, but by now I’ve screwed with everything so much that that’s probably irrelevant.

Under settings → arc
What port does it say it’s using?

Thanks for trying to help, ipeverywhere! It says 55000.

I will also add this image, which I should have included in my initial post.


@Trent_Reynolds, it may be useful to expand the port range by a few numbers. I use 55000-55002 as Roon may cycle between these numbers. Your port forwarding rule looks correct. Have you rebooted your router and the Core PC to see if this helps?



I expanded the port range to 55000-55005.

I had already rebooted everything, but one more time couldn’t hurt so I did it again. No luck.

This is frustrating to me also. Can you post a screenshot of your NAT-Gaming port forwarding rule screen for Roon? Everything seems to be in order from what you have shown. I have the older Pace gateway and its screens are different from the BGW series.

Is this what you’re looking for?

Not quite, rather this one, a screenshot of the screen that appears when you select the “Edit” button:


Just to see how the port forward rule in the BGW210 is configured.

Just to be careful, I’ll tell you exactly what I’m doing, because I don’t understand what I’m doing at all.

I cannot edit an application while it is being hosted…


So I’m going back here and pressing Delete.


Now I can click Edit, and this is what I see.

From here, I click Return to NAT/Gaming.

I notice that the Needed by Device field has changed.


Here are the options on the drop-down.

I have been selecting DESKTOP-1CANTDK, which is the name of the machine I am working on and where Roon is installed.

I click Add.


I hope there is something useful in here!

My previous was a long post with several screenshots. I cannot see beyond the first screen shot for some reason, but it’s all there when I click Edit. Can you see it? Or do I need to make several shorter posts?

Unfortunately in your previous post there was only one screenshot that posted. Can you try reposting the missing images?

[Continued. I’ll cut and paste images from the invisible portion of the post.]


This is the last image.

Thank you, these are helpful. Can you confirm that is the LAN IP address of your Roon Core? In your last screenshot, did you select “Roon” as the Service or the Act of War selection shown in the image?

The above screenshot shows what it looks like after I clicked “Add.” I took no further action–The “Act of War” thing is giving me the option to add another after I have added Roon.

Is this what you mean by the LAN IP address?


If so, no. I have no idea what IP address is, but I’m not selecting that.

What I select from the Needed by Device menu, which you can see in the top image, is DESKTOP-1CANTDK, which is my computer name.

The Roon Core IP ( does not appear in the menu, at least not in numeric form.


I don’t know what most of this means, but maybe this helps?:

I really appreciate you taking the time to work with me!

I am becoming stumped. Everything looks correct from what I see, including the Core’s IP address of As long as your rule is attached to DESKTOP-1CANTDK your rule should work.

I’m paging another Moderator, @AceRimmer, who has the same modem and see if there is anything we are missing. I wish I could be more helpful but I am limited due to not having the same AT&T gateway.

I just logged into my router and as yourself Robert I dont see anything wrong with the setup compared to mine? Apart from ip address of course, all rules look good and settings appear to match.
May have to wait for @support on this one I am afraid.

1 Like