Roonbridge connection problems

Hi Harry and happy new year.
I still have the problem that if i install with my RPi screen on, the Ropieee zone does not show up in Roon.
If I install without the screen everything works normally and the RPi shows up i Roon as expected.

I have tried with the latest 20201212 and with the beta 20201217 version of Ropieee but the results is the same.

Up until december everything worked fine with screen on and everyting. After an update - in think to 3.015 - when the screen is on the zone doesn’t work anymore.

My Rpi is 2b version 1.1.
the log unique identifier is 242f0bff2a49e4d7

2 things:

  1. have you enabled (paired) the extension in Roon? The logs suggest you did not do that.
  2. RoonBridge is not capable of connecting with Roon server. That might be related to point 1., but it is strange. I suggest you restart your Roon server, just to be sure.


Hi Harry.
Yes you were right I hadn’t paired the extention for this install. It is now paired.
The result of having the display/remote control on and paired is that the Ropiee bridge cannot connect and doesn’t show up as a zone, and the display shows “Zone Not Found”.
If I pull the power for the screen the Ropieee bridge comes up as a zone.
While booting with display the screen “Ropieee is ready” is displayed shortly before the “Zone Not Found” screen.
I have rebooted the server and the problem persists

Weird. I’ve never seen a Roonbridge not able to connect to a Roon server.
I also don’t understand the relationship with the screen (Roonbridge and the screen are totally not related).

How does your infra look like? Where do you run your Roon server?

Everything is working fine if i am not using the RPI display. I just have to pull the power til the screen (it has separate power supply) and the bridge is shown as a Roon zone.

My network is very simple one switch and no VLANs. Roon server and bridges are all on the same network connected to the same switch.
The switch is a Unify Switch24.

Until sometime start of december everything worked fine. Now everything works fine if no power is applied to the display .

Just for testing i tried to pull the power to the display while everything was powered on. Emidiately after i pulled the power (the RPI was still powered on and booted) the Ropiee bridge zone appeared in Roon and could start playing music on the Ropieee

Is Roon server running on a windows box?

Roon is running on a Ubuntu 18.04 through the standard install script. It has been running on this server for more than a year - with updates of both Ubuntu and Roon.

Can you send me another deedback after powering on? So without the screen playing and then power on the script?

Feedback power on without power on screen: e362705eb9e68e2f
Feedback power on with power on screen: dd219650636496ae

Now it is sudently working with power on the screen.
I down know what happened. I just did the two power ons - with and without power to the screen.

So today when i turned the Ropieee on to listen to music i did not work. The zone doesn’t appear i Roon and the display shows “Zone not found”.
Initial when it boots the dislay shows the “Ropieee is ready” screen. After that the “zone not found” screen.
The feedback is b1ae4fe73f5d2a2b

Since only 3 posts in a row is allowed this is an edited post from jan 3. 2021

I think it’s time you ask the Roon team for help. For some reason RoonBridge fails to connect to the server (connection refused) and it is totally unclear for me why this is happening and how this could be related to the screen.

The only thing that could be causing issues is power supply. I do see a ‘under voltage’ report, but it happens only a few times. Normally this is harmless, but in these case I suggest you do a test with a bigger power supply.

Hi Harry.
Thank you very much for your persistence and patience.
I am aware of the undervoltage. It is because my noiseless power supply is just delivering 5.0 volt which is 0.1volt under the undervoltage limit of the Rpi. It is a 5 amp supply so there is plenty of power for the Rpi.

@dylan how to solve this matter. Shall I send the logs from the roon server (RoonServer-log.txt) or?

Hi @Jens_Kjellerup,

Can you send us logs from RoonServer and RoonBridge? Thanks!

Hi @dylan.
I have made an posting in the support thread with a snippet from the RoonServer_log.txt.:

Can we continue the issue in this new thread?
Regards Jens

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @Jens_Kjellerup,

Close this thread as per your request, please continue troubleshooting in the thread you linked above!