RoonServer stops running on ROCK

I am having a similar issue with ROCK on a NUC. Was working fine until today, now when I go to the ROCK System Status page, it shows Roon Server Software “Not Running”. Both rebooting the server and restarting the software get the Server running, but it goes back to “Not Running” after about five seconds.

Hi @Chris_Sauer,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Additionally, I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

I’m running Version 1.6 (build 390) stable Roon on ROCK Version 1.0 (build 159) on NUC6i5SYH. Music stored on NUC, on NAS and from Tidal. I’ve got an ORBI mesh router with Router Firmware Version V2.2.1.210. NUC is connected to ORBI via ethernet.

Cannot connect to Roon Core from iOS devices or Windows 10 desktop.

Hi @Chris_Sauer,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.

Here ya go!Aqec8Iw7_MAm_FcIoWe8eWDmi1g2

Hi @Chris_Sauer,

Based on the logs it looks like there are multiple instances of RoonServer running which is causing the issue to occur. Have you tried rebooting the machine? If that doesn’t yield any change can you try reinstalling RoonServer?

Yes, I’ve tried rebooting. I will try to reinstall.

Reinstalled and rebooted, no change in behavior.


Hi @Chris_Sauer,

Please accept my apologies for the delay here! I just spoke with the team about this. They analyzed the log files that you sent over to us and identified an issue that was causing RoonServer to not be able to start up. The team pushed a change to your machine that should get it out of this state. Can you try using Roon again and let me know how it goes?


So far, so good. Up and running for just over 50 minutes. Thanks.