RoonServer Synology USB SSD not found

Hi All,

I attached a usb ssd to use as roon dbase backup.
Whatever I try it just does not show up as a backup location in Roon.

To my knowledge I set all permissions Ok.

I’m on the most recent DSM.

Thanks in advance for help.

Welcome to the Roon community, @Stephan_Van_Regenmor.

Please share what you have tried. From Settings > Backups, you must Add the storage destination by browsing to the mount point on the NAS.

Thank you for you follow-up, Martin.

Correct and that is my problem. The SSD does not show up as a mount point, only the common shared folders.

I can read/write to the SSD as a shared folder on my nas.

So, it shows up in DSM? Furthermore, have you set user permissions for group and user?

Incidently, I don’t use Synology, but found this thread, which may help you.

I am pretty sure that in File Station you have to create a new shared foler which points to the USB drive. You have also give the local user RoonServer the right permissions to that folder (for this see posts from crieke).

Apologies for my ignorance, Alfred butI do not seem to have a local user Roonserver. Trying to find those posts as the SSD shows up as a shared folder anyway (do not understand what you mean with create a shared folder which points to ssd).

2x yes. Didn’t really help as dsm now seems to be a bit different.

Gave up on setting this up via Roon. I setup a rule in Synology Hyper Backup to dump the RoonServer\RoonBackups folder to the connected USB SSD.

@Stephan_Van_Regenmor, using an other backup program (such as Hyper Backup) is a creative but bad idea for backing up the Roon database. The Roon database can get corrupted because database files are locked by the backup program during the backup procedure. If Roon Core wants to write data to the database at the same time, it will not be able to do so, possibly resulting in a corrupt database. The Roon Team therefore advises (see the RoonLabs website) to only use the backup procedure of Roon Core.

You also wrote that it is not possible to make a backup via Roon Core. I have a few questions: Are you using DSM version 7 on your DiskStation. If so, have you also installed the DSM7 version of the Roon package (from

Thank you very much for the warning, Alfred.
Yes, installed the most recent roon spk.
Note that Roon can backup to a shared folder on my NAS core but for added security I want an additional backup on the SSD.
It’s not showing up as a share in Roon (only my usual shares are available but as these are all on the same volume pointless for a 2nd backup).

And dsm is up-to-date.

@Stephan_Van_Regenmor, I am sorry it took some time to help you further. I had to arrange a USB drive to test.

When you connect an USB drive to your DiskStation it will create an share with the name “usbshare1” or something like that. In my first post I was wrong that you have to create this share yourself. Sorry about that. You can check it in Control Panel → External devices. Probably you have to format the disk. Choose EXT4 als File System Type.

Then you need to set the permissions for this share. To do this, go to File Station. On the left side of the screen you will see the usbshare1. Click on usbshare1 with the right mouse button and then select “Properties”. Then choose the “Permissions” tab. Instead of “Local users” you now choose “System internal user”. In the list that opens, you will find the user “RoonServer”. Select this user and click on the permission “Read/Write” for this user. Next click on Save.

Now in Roon it should be possible to see the share “usbshare” and to select it for backups. I hope this will work and that this info will help you further.

1 Like

Hi Alfred,

Thank you so much for your detailed guidance. These were the steps I did yesterday. Note that step 2 to set the permissions is via Control Panel Shared Folder and I gave RoonServer read/write access.

Well, I just gave it another try and….success.

Maybe the source of my troubles (?)… My NAS is wired from the carrier router to a switch. For wifi I use Google wifi. In practise my RoonServer is on another ip range network than my Roon Remote.
No problem at all to let them talk to each other.

I now connected my Remote (ipad) to the carrier router wifi…and success. Roon found the drive and backup configured.

Really can’t think of anything else why it went wrong.


I am happy you got it working now. Congratulations!

Using different subnets for Roon Core and endpoints is usually a garantee for problems. :cry:

1 Like

Fully agree with you on that Alfred. As you have noticed my knowledge is limited on all this. Wonder what should be done to resolve this. My carrier router is in the basement; old house build like a tank lol so limited wifi coverage. Myabe wait for wifi 6 google wifi so I can put the mesh router in the basement as well and rje a switch on it (connected to carrier router). On that switch connect the NAS. If I understand it correctly google router would allocate ip NAS on same network as wifi this way.

Actually reconsidering my previous post. Pretty sure I hooked up the NAS to the switch which ultimately routes to the mesh router on the 1st floor. Wonder now why its not the google platform which assigns its IP address. Maybe some setting on the Synology I overlooked hmmm.

Have you enabled DHCP (meaning that your DiskStation get it’s IP-address from the router) in the DSM network settings?

Hi Alfred. Never touched those settings and again not on familiar ground. Found dhcp server in control panel now. Would I need to create ie Lan 1 input the Google mesh credentials there?
At the moment my NAS IP is allocated by the Proximus carrier router.

Hi Stephan, if I understand your network descriptions well then you have two routers one behind the other (a Proximus modem/router and a Google router). Am I right?

If this is indeed the case then you have a setup that is prone to errors if you don’t set up both devices correctly. For example, you may have two DHCP servers (a DHCP server distributes IP addresses on your local network) running on your network. That is a possible source for network problems.

The easiest way is to put the Proximus modem/router in so-called bridge mode, if that is possible (sometimes you can do this by yourself [at the providers website], sometimes the provider has to do this for you). In bridge mode, the Proximus modem/router only acts as a conduit and does nothing else itself. Your Google router then becomes your main router, which is connected directly to the Internet and which will also fully regulate security with its Firewall (if properly set up).
The other solution is that both routers are placed in a so-called NAT-after-NAT configuration. This requires some specific settings. You can find more information about this construction on the internet.

If you have set up both devices correctly, you can enter the network from your DiskStation. Put it in DHCP mode so that it automatically retrieves its IP address and other settings (such as the DNS server address) from the DHCP server of the Google router. It is best to define a fixed IP address for your DiskStation in that router.

It’s difficult to explain all this in detail from a distance, but I hope I gave you some useful tips and pointed you in the right direction.

Good luck!

Your explanation makes sense Alfred :). Just not sure how I can put the nas in dhcp mode.