rooUPnP: Finally a Roon Extension for UPnP Streamers

As far as I can see rooExtend is visible in Roon.

  • Try to turn off your UPnP streamer and turn it on again.
  • Next go in Roon to Settings/Audio and see if your device shows up there
  • Then enable it and it should work again.

Best DrCWO

Unfortunately not.
I’ve powered down the streamer, rebooted the Roon Server, powered on the streamer.

Squeezebox is searching for Squeezebox devices (under Audio).
No sign of the streamer under audio.

Squeezebox support turned off and turned back on again.
No change

Reinstalled Roon Bridge on the streamer
No change

What else can I try?
2023-01-08 18_54_53-Extended settings

2023-01-08 18_54_06-Roon

As you can see, the RooUPnP extension is searching.
When clicked it also doesn’t show any options to click or configure.

I have no LMS running elsewhere by the way.

I’m having a similar issue to @DvB69 in that my RooUPnP zone keeps disappearing, and I have to go into the extensions settings in Roon, go into RooExtend, click on RooUPnP, then the RooUPnP extension appears. This has been an issue in the past few months, and never was before. I’m happy to supply logs, @DrCWO if that would be helpful. My Roon is running on Sonic Transporter, RooUPnP on a Raspberry Pi 4.

Did you use a disabled test License Key?

I cannot understand what you did :flushed:

No, no test license. It’s the one I bought two months ago.

Nothing has changed either in the settings. Only the IP address of the roon server (Windows10), the streamer and the amplifier.

It’s similar to the daily routine where the RooUPnP disappears shortly after I switch on my music. It plays for a few minutes, then stops. It disappears and 5 minutes later he’s back…

Only in this case it’s only temporary, now it has been almost 2 days.

You mean in Roon in Settings/Extensions ist was no more visible :thinking:

Please end me the License Key so I can verify this.
I still recommend to reflash the SD Card.

Best DrCWO

No, it hasn’t been disabled, it’s showing as valid.

What are you talking about :roll_eyes:

You asked me if I used a disabled test License Key. I did not. I used the license key that I purchased.

As I’ve said, I’m happy to share my log information, any suggestions for how I can solve this would be appreciated.

If you used a test licence previously have you deleted it first before adding the current one?

I’ve not used a test license before.

Was there a reason to change it? I thought RooUPnP was configured to use DHCP by default.
Are you sure you don’t have a clash of two devices using the same IP address?

1 Like

No, the IP address is unique. It’s just static.

If it is accustomed to run under DHCP then a change of IP address should be no issue whatsoever…

When you say ‘static’ do you mean you’ve updated the network config file under /etc on the Pi? I ask because some people think adding a reserved address on the router is a static IP.
Are you using the correct gateway and DNS entries?

Hi Guys, Do I have the latest version - if not how do I update?

rooExtend 2.1.3 is quite old. V3.0.x is out with OTA updates.

Best DrCWO
From Africa Seringeti

Hi, @David_Freeman1

To update, you’ll want to:

  • Insert a USB key - your current settings will be saved onto it. Remove the USB key
  • Remove the storage card, re-flash it with the latest release. Power down.
  • Insert the USB key with your saved settings, insert the storage card, power up
  • Remove the USB key

Downloads and update documentation are here: rooExtend - Google Drive

There’s a section in the Quick Installation guide called “Saving your license Keys on a USB memory stick” that goes into more detail than I did above.

Once you’re on the latest release, you won’t need to do this again. Updates are now automatic and over the air.

Hope this helps!

1 Like


Thanks for creating this great tool! It has breathed new life into my Naim N272 streaming preamp. Very good experience with Roon using your tool.

Question: if I’m also interested in purchasing your rooDial tool, do I need to have a separate RasberryPi or can I run both utilities from the same installation on one Rasberry Pi?