Ropieee not recognising screen not showing up in Roon

I burnt the image booted and on the pi screen I can see ropieee is running, I can configure the hat (IQ Audio DAC +) via the ropieee web interface and I cannot see a screen tab. No extensions are showing up in roon and I can’t see the ropieee endpoint in roon Audio set up.

Rebooted a few times and running the latest stable ropieee release.

Any suggestions?

Sent feedback.


Hi Bob,

what’s the id of the feedback?

ahhh, i rebooted,


I think

No problem, I already found your feedback based on timestamp.

Anyhow, RoPieee did not detected a touchscreen. So you are using the official Raspberry Pi Touchscreen right? Are you sure it’s properly connected?


Yes its the official screen and it is displaying the boot process.

I’ll double check the 4 wires.


Yeah please do, because RoPieee did not detect it. Strange that it shows you the boot process, because that suggests everything is ok.

I’ll reflash tomorrow and use a larger SD card, I am on a 2Gig now and the boot process seems to be getting stuck. Thanks Harry.


Ow! yeah, 2G is very tight.
Let me know how it goes.


The 4 wires you only need the red and black 5vdc wires, the other 2 are for non RPi 3B units as far as I know…I’m only using 2 wires.

Thanks for that WoZ!


All working now thanks Harry.


1 Like

Ok good to hear!

One thing though, the web interface is very slow, taking up to 30 seconds to load, is this normal?

Also I couldn’t get touch to work properly until I rotated the display in settings (and of course physically rotated the display) then all the icons worked OK.

The slow web interface is not normal. And You’re not the first that has reported this… Could you send me feedback?


Thanks Harry,

Great support.

I’ve sent feedback it’s 171ab5c37d8cac17

I took a look at the network load times in Google dev tools and it’s always jquery.min.js that takes ages to load. in the screen shot you can see it took 30 seconds.


Ok Bob,

Thanks for the feedback!

Hi -
I’m having the same problem. Official RPi touchscreen, the boot process detects it (and I get all the console messages), but Ropieee doesn’t seem to detect it. No extension in Roon, no display tab on the web interface. FWIW, my touchscreen is powered via a USB splitter, so it’s connected to the RPi (a model 3) just at the DSI port.

Advice, please?

Drew Dean

Drew, I’m sure Harry will have some suggestions. Your setup is exactly the same as mine and for me, flashing a new image onto a larger SD card worked, along with just letting Ropieee do its thing during initial booting.

I originally used a 2g card, now using 8g.


Can you send me feedback? It’s on the ‘advanced’ tab of the web interface.